Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Wrong AC3 audio stream

  1. #1
    Join Date
    Oct 2005
    Location
    Fairfax, Virginia USA
    Posts
    156

    Wrong AC3 audio stream

    One of our favorite QAM channels has its audio streams reversed. Our cable company has set the new “voice over” channel as the default (stream 1) and the normal audio is on stream 2. I am sure the signal has been reversed by the cable company. The audio is correct when the TV is connected to an antenna. But, it is reversed on this one channel when it's connected directly to the cable or operating with NPVR. I have tried different decoders and rescanning numerous times without success.

    It seems there is little chance of getting the cable people to fix this. I can switch audio streams in NPVR, but with Comskip running, for some unknown reason it gets reset to stream 1 after every commercial. This is very annoying and the WAF is getting dangerously low.

    Is there any way of editing the channel tuning data to fix this? If so, how do I access the tuning data? Also, does anyone know why Comskip resets the audio?

    Any help would be greatly appreciated.

  2. #2
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,320
    If you can support a short sample recording, I should be able to fix this problem with the wrong audio stream being selected.

  3. #3
    Join Date
    Oct 2005
    Location
    Fairfax, Virginia USA
    Posts
    156

    Wrong AC3 audio stream

    Quote Originally Posted by sub View Post
    If you can support a short sample recording, I should be able to fix this problem with the wrong audio stream being selected.
    Thanks Sub,

    Here is a few seconds of "Doodlebops" (Sorry, it was all that was on this am). Audio 1 "spa" should be stream 2 and "eng" should be the default stream 1. This is the only cable channel set like this.

    Thanks again,

    emr
    Attached Files Attached Files

  4. #4
    Join Date
    May 2006
    Location
    Canada
    Posts
    21,264
    Did you try changing config.xml to use

    <LanguagePreference1>eng</LanguagePreference1>

    Martin

  5. #5
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,320
    Yep, I suspect that'll fix it.

  6. #6
    Join Date
    Oct 2005
    Location
    Fairfax, Virginia USA
    Posts
    156
    Yes, I set all language functions to eng, but no difference. Just for laughs, I tried setting them all to spa. No change at all. The problem channel stays on spa, but the other channels stay on eng. It seems like the language commands have no effect.

  7. #7
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,320
    Can you put a longer sample somewhere I can download from? I'd need 30 seconds or so. Preferably a recording where I can hear both Spanish and English.

  8. #8
    Join Date
    Oct 2005
    Location
    Fairfax, Virginia USA
    Posts
    156
    OK, I have uploaded a file to Dropbox. It has 30 sec of a basketball game with both audio channels. (Sorry, no Spanish programs available right now). Audio stream 1 (spa) only has the background crowd noise. The announcer can only be heard on the eng stream 2.

    Here is the link: https://dl.dropbox.com/u/91936216/Co...Basketball.zip

  9. #9
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,320
    Thanks for the sample.

    This patch fixes it. You'll need to have <LanguagePreference1>eng</LanguagePreference1> in your config.xml still.
    Attached Files Attached Files

  10. #10
    Join Date
    Oct 2005
    Location
    Fairfax, Virginia USA
    Posts
    156
    Wow, thank you Sub,

    I will test it now. Where do I install this?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •