Results 1 to 4 of 4

Thread: VLC crashing on host during streaming

  1. #1
    Join Date
    Nov 2012
    Location
    Florida, USA
    Posts
    4

    VLC crashing on host during streaming

    Hi,

    I have NextPVR and VLC 2.0.4 installed on Server 2008 R2. For troubleshooting I have disabled the firewalls on both the client and server.

    Things are working except I'm trying to get streaming working from NEWA. When I start a stream, VLC client side tells me:
    Your input can't be opened:
    VLC is unable to open the MRL 'http://s3:7648'. Check the log for details.
    Taking the args from the log file. I ran on the server:
    Code:
    vlc.exe -I http "D:\Media\Recordings\Castle\Castle_20121112_22012300.ts" :sout=#transcode{vcodec=mp4v,vb=512,width=320,height=213,acodec=mp4a,ab=32,channels=2}:standard{access=http,mux=ts,dst=:7648} vlc://quit
    That causes vlc to crash. I've tried different transcode options with the same result. VLC otherwise seems to work fine.

    What should I do next?
    Attached Files Attached Files

  2. #2
    Join Date
    Feb 2005
    Location
    Pennsylvania, USA
    Posts
    5,111
    Try using the manual setting highlighted in this post (another active thread on this subject). Running W2k8 R2 probably will introduce some things that we have yet to encounter when debugging streaming....not only is it server OS....R2 has a ton of new security things in it as compared to W2k8 SP2.....

    Let me know....

    http://forums.gbpvr.com/showthread.p...903#post445903

  3. #3
    Join Date
    Nov 2012
    Location
    Florida, USA
    Posts
    4
    Sorry for my delayed response. I got side tracked with other projects.

    I tried your settings with Windows 7 as the host and I got the same crash with VLC 2.0.4.

    I downgraded to VLC 2.0.3 server side and now it is working.

  4. #4
    Join Date
    Feb 2005
    Location
    Pennsylvania, USA
    Posts
    5,111
    Thanks....there is another thread with a VLC issue that I can't figure out....I'll sugest that they downgrade to 2.0.3 and see if that helps them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •