Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Live TV Pausing - and ending

  1. #1
    Join Date
    May 2006
    Location
    Canada
    Posts
    21,691

    Live TV Pausing - and ending

    Is pausing LiveTV supposed to work in timeshifting mode? I paused for minute or so and when I came back XBMC played a bit and hung (I had to kill the task)

    web.log

    Code:
    2012-11-08 00:11:10.499	[DEBUG][15]	about to read 32768 from location 952369152  (current length = 952401920)
    2012-11-08 00:11:10.499	[DEBUG][15]	LiveShift response: 952369152:32768 952401920 29092
    2012-11-08 00:11:10.499	[DEBUG][15]	Sent 32768 bytes
    2012-11-08 00:11:10.499	[DEBUG][15]	Got request: Range: bytes=952401920-952434688-29093
    2012-11-08 00:11:10.599	[DEBUG][15]	RollingFile.Position returning 952401920
    2012-11-08 00:11:10.599	[DEBUG][15]	about to read 32768 from location 952401920  (current length = 952467456)
    2012-11-08 00:11:10.599	[DEBUG][15]	LiveShift response: 952401920:32768 952467456 29093
    2012-11-08 00:12:05.752	[DEBUG][15]	Sent 32768 bytes
    2012-11-08 00:12:05.752	[DEBUG][15]	Renewed lease... (5F40011)
    2012-11-08 00:12:05.755	[DEBUG][15]	Renew lease failed. Dropping out.
    2012-11-08 00:12:08.756	[DEBUG][15]	StopStream(99876881)
    2012-11-08 00:12:08.756	[DEBUG][15]	clientHandle[XBMC-0f3bf497d8a44e0cabc7e888cd5b99c9] = 99876881
    NRecord.log

    Code:
    012-11-08 00:11:00.870	[DEBUG][6]	Renew lease ok (0x5F40011)
    2012-11-08 00:11:05.904	[DEBUG][6]	Renew lease ok (0x5F40011)
    2012-11-08 00:11:26.105	[ERROR][7]	Live stream expired without renewal. (handle:5F40011)
    2012-11-08 00:11:26.105	[INFO][7]	HDPVRRecorder.StopStream(17)
    2012-11-08 00:11:26.105	[INFO][7]	HDPVR/Colossus stream count now 0
    Martin

  2. #2
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,683
    It supposed to be able to pause without this happening, and it usually pauses just fine for me, but I have to admit to seeing that happen myself a couple of times over the last few days. Unfortunately I've not had time to go back and investigate - I've been busy with day-job stuff.

  3. #3
    Join Date
    Dec 2012
    Location
    Australia
    Posts
    6
    Any ideas with this issue? Basically cannot pause/timeshift, and my logs (attached) are very similar to the original post.

    Running Frodo RC2 and latest NPVR with patches applied listed here: http://forums.gbpvr.com/showthread.p...g-Started-info

    Live TV works wonderfully, no hitches. But if I pause it, I see the buffer file build to about 16-18 mb, then no more. If I resume playback it plays for a few sec then freezes and I have to end XBMC via task manager, and the buffer file is automatically deleted. Have also tried increasing buffer size via registry as well as different XBMC skin (was desperate :P ). Have also tried changing buffer file location to another drive, no difference.

    Thankyou!
    Attached Files Attached Files

  4. #4
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,683
    Can you see if this patch fixes it?
    Attached Files Attached Files

  5. #5
    Join Date
    Dec 2012
    Location
    Australia
    Posts
    6
    Thankyou, that seems to have done the trick!

    I don't know if this is related but when I fast forward to the very end of the stream so I am watching live tv, it sometimes starts to buffer, then play, buffer, play and so on in 1 sec increments. It's not significant nor does it happen everytime, but thought I should mention it anyway. Simply pausing playback manually for a couple of seconds fixes it.

    Thanks again!

  6. #6
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,683
    Quote Originally Posted by username145 View Post
    Thankyou, that seems to have done the trick!
    Great.

    I don't know if this is related but when I fast forward to the very end of the stream so I am watching live tv, it sometimes starts to buffer, then play, buffer, play and so on in 1 sec increments. It's not significant nor does it happen everytime, but thought I should mention it anyway. Simply pausing playback manually for a couple of seconds fixes it.
    Unfortunately this one will be an XBMC issue, and not something I can control in the addon.

  7. #7
    Join Date
    Dec 2012
    Location
    Australia
    Posts
    6
    Perhaps I spoke too soon, on closer inspection it looks like timeshift doesn't stop itself at all! So once I tune a channel it keeps timeshifting even after closing xbmc and seems to keeps the TS files even after changing channels. Have to manually stop the service to end it (logs mid-timeshift are attached).

    Another issue that I'm not sure is related, but was wondering how smooth rewinding during a timeshift is via XBMC? For me, after pressing the button, it actually fast forwards for a few sec, then starts rewinding, freezes, rewinds for a sec or two, and so on. Mediaportal backend, while it has its own issues, is able to rewind smoothly however.

    Thankyou!
    Attached Files Attached Files

  8. #8
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,683
    Quote Originally Posted by username145 View Post
    Another issue that I'm not sure is related, but was wondering how smooth rewinding during a timeshift is via XBMC? For me, after pressing the button, it actually fast forwards for a few sec, then starts rewinding, freezes, rewinds for a sec or two, and so on.
    Unfortunately this is fairly normal for XBMC. It's pretty horrible at rewinding, with really inconsistent results - really jerky, odd size steps, sometimes in the wrong direction.

  9. #9
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,683
    Quote Originally Posted by username145 View Post
    Perhaps I spoke too soon, on closer inspection it looks like timeshift doesn't stop itself at all! So once I tune a channel it keeps timeshifting even after closing xbmc and seems to keeps the TS files even after changing channels. Have to manually stop the service to end it (logs mid-timeshift are attached).
    I was unable to reproduce this. Any special instructions?

  10. #10
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,683
    Can you see if this patch helps? If it doesn't, post the logs again.
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •