Results 1 to 6 of 6

Thread: displayed end-times of completed recordings incorrect

  1. #1
    Join Date
    Sep 2008
    Location
    California
    Posts
    5,689

    displayed end-times of completed recordings incorrect

    Sorry, didn't catch this during pre-release... note crazy end-times of all completed recordings. It looks like they've been converted from UTC twice... -7 hours to get from UTC to PDT, and -7 hours again to get to the displayed time.
    Name:  endtimes.jpg
Views: 319
Size:  20.0 KB

    (edit: to be clear, the displayed times are correct on Pending and In-Progress recordings. only once they're completed does the end-time go wacky)
    (edit 2: out of curiousity I looked in the database, and found that for all recordings completed with 2.5.9, the start_time is in UTC, but the end_time has been changed to my local time (PDT))
    Last edited by johnsonx42; 2012-10-01 at 07:28 AM.
    NPVR Tech Support Sticky - - http://forums.gbpvr.com/showthread.p...612#post473612
    ---------------------------
    my config: NPVR 3.2.9/Win7Pro/Athlon II X3-440/radeon hd4550/hvr-2250/hvr-850/KWorld 315U/TimeWarner QAM & Analog, OTA ATSC/schedules direct

  2. #2
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,234
    Bugger. This patch should fix it.
    Attached Files Attached Files

  3. #3
    Join Date
    Sep 2008
    Location
    California
    Posts
    5,689
    I just put the patch in, and scheduled a recording that will finish in about 15 minutes to check it.

    If you're thinking about re-rolling the 2.5.9 installer with this fix, I'd vote yes. Sure, it's not a show-stopping bug, but it's pretty ugly cosmetically when you're trying to attract hordes of xbmc users.
    NPVR Tech Support Sticky - - http://forums.gbpvr.com/showthread.p...612#post473612
    ---------------------------
    my config: NPVR 3.2.9/Win7Pro/Athlon II X3-440/radeon hd4550/hvr-2250/hvr-850/KWorld 315U/TimeWarner QAM & Analog, OTA ATSC/schedules direct

  4. #4
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,234
    Quote Originally Posted by johnsonx42 View Post
    If you're thinking about re-rolling the 2.5.9 installer with this fix, I'd vote yes. Sure, it's not a show-stopping bug, but it's pretty ugly cosmetically when you're trying to attract hordes of xbmc users.
    Yes, I would update the installer with this. We're only a day into 2.5.9, so not a big deal.

  5. #5
    Join Date
    Sep 2008
    Location
    California
    Posts
    5,689
    the test recording I did ended with the correct time stamps. I'm sure that's no surprise.
    NPVR Tech Support Sticky - - http://forums.gbpvr.com/showthread.p...612#post473612
    ---------------------------
    my config: NPVR 3.2.9/Win7Pro/Athlon II X3-440/radeon hd4550/hvr-2250/hvr-850/KWorld 315U/TimeWarner QAM & Analog, OTA ATSC/schedules direct

  6. #6
    Join Date
    May 2006
    Location
    Canada
    Posts
    21,088
    Looking at manual recordings, I think I am seeing the same issue on the Manual Recording update screen. The time seems to be displayed in local time.

    Martin.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •