Results 1 to 6 of 6

Thread: updating npvr

  1. #1
    Join Date
    Jul 2012
    Location
    australia
    Posts
    28

    updating npvr

    After installing 2.5.5, I then tried to update it with the patches on the support page, however when trying to do this windows informs me that some of the files I tried to replace had newer timestamps than the patches, is this normal and how would I verify that I and other users are using the latest version.

  2. #2
    Join Date
    Aug 2012
    Location
    White Plains, NY
    Posts
    20
    Are the timestamps for the modified or created?

  3. #3
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    75,972
    Whats probably happened - a couple of weeks ago I had to repackage the installer to disable part of the web components to avoid a security issue. This would have the latest build of the components from my machine, with later dates, but functionally the same.

    Basically, dont bother installing a patch if you've already got a later file. You'll already have that patch.

  4. #4
    Join Date
    Feb 2006
    Location
    North Lawrence, NY
    Posts
    827
    Typically, the patches in the Current Patches will be newer than what is installed with sub's installer. The higher numbered patches will be the newest ones such that the NextPVR.exe in patch #1 is older than the one contained in #3. #3 will likely have the fix for the item listed and also contain #1's fix too.

    My method, just to make sure I don't get confused, is to download each into a directory, in order on that page. If there is a duplicate as I go, I delete the previous one, until I get to the end of the list OR that I get up to the patch that I'm looking for to solve my issue. I stopped at #8 this time.

    Sooner or later, with the number of patches so far, johnsonx42 will probably do this for all of us and post an R1 archive that has the latest of all those files in it.

    I probably had the installer before sub repackaged it, so I didn't see a time stamp issue like you did.

  5. #5
    Join Date
    Jul 2012
    Location
    australia
    Posts
    28
    Thanks for the quick reply,
    Sub-I think I downloaded the setup file before you updated it which is why I was surprised( I had actually thought of this)

    Jamhandman-I cant remember which one it was sorry

    Smajor-thats exactly what I do too!
    thanks again, It seems to be working fine irrespective of this timestamp issue anyway, just thought it was worth asking
    cheers!

  6. #6
    Join Date
    Sep 2008
    Location
    California
    Posts
    5,604
    I have updated the patch list with a note that the updated installer was released after patches #1-5. As for the R1 cumulative patch release, there are a few loose ends I'd like to see fixed before doing that. I'd also like to have the updated NEWA/iNEWA available, though it wouldn't actually be included in the R1 update file.
    NPVR Tech Support Sticky - - http://forums.gbpvr.com/showthread.p...612#post473612
    ---------------------------
    my config: NPVR 3.2.9/Win7Pro/Athlon II X3-440/radeon hd4550/hvr-2250/hvr-850/KWorld 315U/TimeWarner QAM & Analog, OTA ATSC/schedules direct

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •