Results 1 to 3 of 3

Thread: device rule for HVR-1250 not working

  1. #1
    Join Date
    Sep 2008
    Location
    California
    Posts
    5,752

    device rule for HVR-1250 not working

    Since adding analog to the mix here, I've had a couple of recordings report "Device Failed to start". This time I decided to investigate, and realized NPVR had tried to use my HVR-1250 for both digital and analog at the same time. I thought I'd seen an entry in DeviceRules.xml that should have handled it, but on closer inspection that rule was for a DVB device and used slightly different device names. So without further ado, here is a rule for the HVR-1250:
    Code:
    		<!-- Hauppauge 885 (HVR-1250)-->
    		<Filter name="Hauppauge WinTV 885 BDA Tuner/Demod" resource="Hauppauge 885" />
    		<Filter name="Hauppauge WinTV 885 Video Capture" resource="Hauppauge 885" />
    I don't know if this rule should be in the standard file distributed with NPVR or not - I don't know if this rule might break some other hauppauge device that actually does have two tuners like the HVR-1850 or HVR-1600.
    NPVR Tech Support Sticky - - http://forums.gbpvr.com/showthread.p...612#post473612
    ---------------------------
    my config: NPVR 3.2.9/Win7Pro/Athlon II X3-440/radeon hd4550/hvr-2250/hvr-850/KWorld 315U/TimeWarner QAM & Analog, OTA ATSC/schedules direct

  2. #2
    Join Date
    Sep 2008
    Location
    California
    Posts
    5,752
    ok, this started as just a information thread for anyone else with an HVR-1250, but the rule I added didn't have any effect so I guess now it's a support thread. I created a conflict on the HVR-1250 to test the rule, but NPVR still tried to use the HVR-1250 twice; I started recordings on all tuners first, then asked for livetv on an analog channel - there should have been no tuners available:
    Code:
    2012-08-16 02:31:32.135	[DEBUG][12]	StartStream(7077:USA)
    2012-08-16 02:31:32.135	[DEBUG][12]	looking for capture source
    2012-08-16 02:31:32.135	[DEBUG][12]	checking: Hauppauge WinTV 885 BDA Tuner/Demod     (QAM)
    2012-08-16 02:31:32.135	[DEBUG][12]	enabled and present
    2012-08-16 02:31:32.135	[DEBUG][12]	does not have channel
    2012-08-16 02:31:32.135	[DEBUG][12]	checking: WinTV HVR-950 BDA Tuner     (ATSC)
    2012-08-16 02:31:32.135	[DEBUG][12]	enabled and present
    2012-08-16 02:31:32.135	[DEBUG][12]	does not have channel
    2012-08-16 02:31:32.135	[DEBUG][12]	checking: USB 2883 Device
    2012-08-16 02:31:32.135	[DEBUG][12]	enabled and present
    2012-08-16 02:31:32.135	[DEBUG][12]	has channel
    2012-08-16 02:31:32.136	[DEBUG][12]	live tv is not possible
    **2012-08-16 02:31:32.136	[DEBUG][12]	checking: Hauppauge WinTV 885 Video Capture
    2012-08-16 02:31:32.136	[DEBUG][12]	enabled and present
    2012-08-16 02:31:32.136	[DEBUG][12]	has channel
    **2012-08-16 02:31:32.136	[DEBUG][12]	live tv is possible
    2012-08-16 02:31:32.136	[INFO][12]	AnalogRecorder.StartStream(LIVE&C:\LiveTV\live-USA-5945.ts)
    2012-08-16 02:31:32.136	[INFO][12]	AnalogRecorder stream count now 1
    2012-08-16 02:31:32.136	[INFO][12]	Creating graph
    2012-08-16 02:31:32.138	[DEBUG][12]	Building graph using: Hauppauge WinTV 885 Video Capture (1)
    2012-08-16 02:31:32.238	[DEBUG][12]	about to look for encoder
    2012-08-16 02:31:32.250	[DEBUG][12]	About to look for hardware encoder.
    2012-08-16 02:31:32.250	[DEBUG][12]	AttachHardEncoder@1
    2012-08-16 02:31:32.250	[DEBUG][12]	AttachHardEncoder@2 (got medium)
    2012-08-16 02:31:32.313	[DEBUG][12]	Hardware encoder not found. Attempting to fall back to software encoder.
    2012-08-16 02:31:32.313	[DEBUG][12]	SetCaptureResolution()
    2012-08-16 02:31:32.313	[DEBUG][12]	NTSC tuner
    2012-08-16 02:31:32.314	[DEBUG][12]	0:  720x480 (subtype: {32595559-0000-0010-8000-00AA00389B71}) 
    2012-08-16 02:31:32.314	[DEBUG][12]	1:  720x576 (subtype: {32595559-0000-0010-8000-00AA00389B71}) 
    2012-08-16 02:31:32.314	[DEBUG][12]	selected: 0:  720x480 (subtype: {32595559-0000-0010-8000-00AA00389B71}) 
    2012-08-16 02:31:32.332	[DEBUG][12]	about to add mux
    2012-08-16 02:31:32.332	[DEBUG][12]	about to add tee
    2012-08-16 02:31:32.332	[DEBUG][12]	about to connect writers
    2012-08-16 02:31:32.340	[DEBUG][12]	Graph filter list:
    2012-08-16 02:31:32.341	[DEBUG][12]	 - NPVR Writer2
    2012-08-16 02:31:32.341	[DEBUG][12]	 - NPVR Writer
    2012-08-16 02:31:32.341	[DEBUG][12]	 - Infinite Pin Tee Filter
    2012-08-16 02:31:32.341	[DEBUG][12]	 - MainConcept (HCW) MPEG Multiplexer-Plus
    2012-08-16 02:31:32.341	[DEBUG][12]	 - MainConcept (HCW) Layer II Audio Encoder
    2012-08-16 02:31:32.341	[DEBUG][12]	 - MainConcept (HCW) MPEG-2 Video Encoder
    2012-08-16 02:31:32.341	[DEBUG][12]	 - Hauppauge WinTV 885 Video Capture
    2012-08-16 02:31:32.341	[DEBUG][12]	 - Hauppauge WinTV 885 Crossbar
    2012-08-16 02:31:32.341	[DEBUG][12]	 - Hauppauge WinTV 885 TvAudio
    2012-08-16 02:31:32.341	[DEBUG][12]	 - Hauppauge WinTV 885 Tuner
    2012-08-16 02:31:32.341	[DEBUG][12]	About to check crossbar routing
    2012-08-16 02:31:32.418	[DEBUG][12]	Audio crossbar routed successfully
    2012-08-16 02:31:32.418	[DEBUG][12]	Video crossbar already routed correctly
    2012-08-16 02:31:32.418	[DEBUG][12]	Tuning to channel: 28
    2012-08-16 02:31:32.619	[DEBUG][12]	Tuner reports frequency: 247250000
    2012-08-16 02:31:32.619	[INFO][12]	About to start graph
    2012-08-16 02:31:32.619	[DEBUG][12]	Setting top field first
    2012-08-16 02:31:32.619	[DEBUG][12]	Setting encoder video format to NTSC
    **2012-08-16 02:31:33.123	[ERROR][12]	Device failed to start
    2012-08-16 02:31:33.123	[DEBUG][12]	Removing filter  NPVR Writer2
    2012-08-16 02:31:33.123	[DEBUG][12]	Removing filter  NPVR Writer
    2012-08-16 02:31:33.124	[DEBUG][12]	Removing filter  Infinite Pin Tee Filter
    2012-08-16 02:31:33.124	[DEBUG][12]	Removing filter  MainConcept (HCW) MPEG Multiplexer-Plus
    2012-08-16 02:31:33.124	[DEBUG][12]	Removing filter  MainConcept (HCW) Layer II Audio Encoder
    2012-08-16 02:31:33.125	[DEBUG][12]	Removing filter  MainConcept (HCW) MPEG-2 Video Encoder
    2012-08-16 02:31:33.125	[DEBUG][12]	Removing filter  Hauppauge WinTV 885 Video Capture
    2012-08-16 02:31:33.126	[DEBUG][12]	Removing filter  Hauppauge WinTV 885 Crossbar
    2012-08-16 02:31:33.126	[DEBUG][12]	Removing filter  Hauppauge WinTV 885 TvAudio
    2012-08-16 02:31:33.126	[DEBUG][12]	Removing filter  Hauppauge WinTV 885 Tuner
    **2012-08-16 02:31:33.127	[ERROR][12]	Unable to StartStream(): Device failed to start
    2012-08-16 02:31:33.127	[DEBUG][12]	checking: BDA 2883 TVTuner     (ATSC)
    2012-08-16 02:31:33.127	[DEBUG][12]	checking: BDA 2883 TVTuner     (QAM)
    2012-08-16 02:31:33.127	[DEBUG][12]	checking: IPTV Device
    2012-08-16 02:31:33.127	[DEBUG][12]	checking: Hauppauge WinTV 885 BDA Tuner/Demod     (ATSC)
    2012-08-16 02:31:33.127	[DEBUG][12]	checking: WinTV HVR-950 BDA Tuner     (QAM)
    2012-08-16 02:31:33.128	[DEBUG][12]	checking: WinTV HVR-950 Capture
    I also tried recording on the same channel, and it tried to start the recording then failed rather than saying no tuners available.

    It seems like there was a problem awhile ago with some part of NRecord not processing DeviceRules.xml properly... is this broken again? Or have I done something wrong?

    Here's my DeviceRules.xml with my HVR-1250 section added:
    Code:
    <Rules>
    	<SharedNames>
    		<!-- Hauppauge 88x family -->
    		<Filter name="Hauppauge WinTV 88x DVB-S/S2 Tuner/Demod" resource="Hauppauge 88x" />
    		<Filter name="Hauppauge WinTV 88x DVB-S Tuner/Demod" resource="Hauppauge 88x" />
    		<Filter name="Hauppauge WinTV 88x DVB-T Tuner/Demod" resource="Hauppauge 88x" />
    		<Filter name="Hauppauge WinTV 88x Video Capture" resource="Hauppauge 88x" />
    
    		<!-- Hauppauge HVR-22xx family -->
    		<Filter name="Hauppauge WinTV-7164 Analog Capture" resource="Hauppauge 22xx" />
    		<Filter name="Hauppauge WinTV-7164 BDA DVBT Tuner" resource="Hauppauge 22xx" />
    		<Filter name="Hauppauge WinTV-7164 BDA ATSC/QAM Tuner" resource="Hauppauge 22xx" />	
    
    		<!-- Hauppauge HVR USB2 -->
    		<Filter name="Hauppauge HVR USB2 BDA Tuner/Demod" resource="Hauppauge HVR USB2" />
    		<Filter name="Hauppauge HVR USB2 Video Capture" resource="Hauppauge HVR USB2" />		
    		
    		<!-- Hauppauge 885 (HVR-1250)-->
    		<Filter name="Hauppauge WinTV 885 BDA Tuner/Demod" resource="Hauppauge 885" />
    		<Filter name="Hauppauge WinTV 885 Video Capture" resource="Hauppauge 885" />
    	</SharedNames>
    </Rules>
    Last edited by johnsonx42; 2012-08-16 at 10:05 AM.
    NPVR Tech Support Sticky - - http://forums.gbpvr.com/showthread.p...612#post473612
    ---------------------------
    my config: NPVR 3.2.9/Win7Pro/Athlon II X3-440/radeon hd4550/hvr-2250/hvr-850/KWorld 315U/TimeWarner QAM & Analog, OTA ATSC/schedules direct

  3. #3
    Join Date
    Sep 2008
    Location
    California
    Posts
    5,752
    well nevermind about this (not that anyone seemed to be minding anyhow...).

    I just upgraded my HTPC; I'm now running an Athlon II X3-440 CPU (triple core, 3.1ghz vs my old dual core 2Ghz), and an HVR-2250 has displaced my trusty HVR-1250 in the lone PCIe x1 slot on my mobo.

    The rules for the 2250 (WinTV-7164) already in DeviceRules.xml work perfectly with this card, so I have no idea why the lines I added for the HVR-1250 didn't work. I'm no longer in a position to troubleshoot it anyhow.

    Thanks sub, it was super easy to configure the channels on my new card; even though my HVR-1250 was no longer present, it properly copied the QAM channels it had over to the new 2250 tuners, and likewise copied my analog channels without trouble. I was thinking I might still have to merge them, but nope, it had properly merged them all too. Nice, very polished.
    NPVR Tech Support Sticky - - http://forums.gbpvr.com/showthread.p...612#post473612
    ---------------------------
    my config: NPVR 3.2.9/Win7Pro/Athlon II X3-440/radeon hd4550/hvr-2250/hvr-850/KWorld 315U/TimeWarner QAM & Analog, OTA ATSC/schedules direct

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •