Page 1 of 5 123 ... LastLast
Results 1 to 10 of 44

Thread: NMT Booot to NextPVR Visual

  1. #1
    Join Date
    Nov 2006
    Location
    Sunninghill, UK
    Posts
    2,484

    NMT Booot to NextPVR Visual

    Hiya Martin,

    sorry may have asked this before. If not asking now while I think of it....

    Is there any way to give an NMT some kind of visual feedback to the TV screen once it has started booting NextPVR....

    Only all I get for a few seconds is blank screen. Would be nice to get some kind of visual feedback! Like we used to with the MVP's... At least then we knew something was on the way!!!

    v cheers

    steeb

  2. #2
    Join Date
    May 2006
    Location
    Canada
    Posts
    20,468
    The NMT connects to the server almost immediately so a visual counter wouldn't typically even register 1 second before it went black.

    Martin

  3. #3
    Join Date
    Nov 2006
    Location
    Sunninghill, UK
    Posts
    2,484
    Hi Martin, well then I must have something wrong with my set up...

    This goes back to GB-PVR days too.

    Using Jaggy's boot straight into NextPVR etc.

    I get a black screen for at least 8 seconds....

    Can you give me a link on youtube or something to show how it should be booting?

    steeb

  4. #4
    Join Date
    May 2006
    Location
    Canada
    Posts
    20,468
    That's possible but likely the delay is after the NMT has connected. If you post your MVP logs I'd be an better position to explain this.

    Martin

  5. #5
    Join Date
    Nov 2006
    Location
    Sunninghill, UK
    Posts
    2,484
    Thanks Martin (as usual)

    have finally got chance to emulate!

    Set MVP/NMT to one instance. Cleared files.

    Counted black screen from load until NextPVR screen. Somewhere between 8-10 secs.

    Logs attached. Not sure what I have missing here?

    cheers

    steeb
    Attached Files Attached Files

  6. #6
    Join Date
    May 2006
    Location
    Canada
    Posts
    20,468
    1) I wonder if it get better if you set it up with a valid configuration? You have

    2012-05-29 23:39:05.859 [DEBUG][3] Using horizontal resolution = 720
    2012-05-29 23:39:05.859 [DEBUG][3] Using vertical resolution = 720

    That could be SD alright, Steeb Definition.

    2) Going by the recording service start, which is the earliest the NMT could connect

    2012-05-29 23:38:37.609 [DEBUG][4] OnStart() complete...

    It took only 22 seconds for the NMT to connect

    2012-05-29 23:38:59.640 [DEBUG][4] Received MVP Service Locator request (zeroconf socket setup)
    2012-05-29 23:38:59.859 [INFO][3] Got control connection (GUI socket)
    2012-05-29 23:38:59.921 [INFO][7] Got streaming connection (media socket)

    After those 22 seconds where I would have to clear the screen, it took another minute for NextPVR to send an update

    2012-05-29 23:40:00.093 [DEBUG][3] Sending incremental screen updates to PCH
    2012-05-29 23:40:00.093 [DEBUG][3] updating (444, 5, 276, 27)

    That update might be odd, I would expect a full screen perhaps that is caused by SD?

    Martin

  7. #7
    Join Date
    May 2006
    Location
    Canada
    Posts
    20,468

    Thumbs down

    I should have mentioned that in my setup the first connect which I labelled zeroconf, appears seconds after hitting enter on the NMT screen. You might need to add

    <ExtendedLogging>true</ExtendedLogging>

    in the MVP section to get finer timing data.

    Also note that there could be additional delays with mvpmcx2 loads, especially from a slow share. Since mvpmcx2 isn't running it would be impossible to show you anything. You could comment out

    killall gaya

    from startmeup and it won't go black while mvpmcx2 loads.

    Martin

  8. #8
    Join Date
    Nov 2006
    Location
    Sunninghill, UK
    Posts
    2,484
    Hi Martin,

    1st chance I have had to catch up on this!

    Am about to reboot server after resetting MVP/NMT devices to 1.

    I have 720x720 as that was the only way I could force the NMT to fully display on my TV Screen?

    Will check <Extended Logging> as True

    and comment out

    killall gaya



    cheers as usual

    steeb

  9. #9
    Join Date
    Nov 2006
    Location
    Sunninghill, UK
    Posts
    2,484
    Martin, thank you so much,

    NMT instance set to 1

    Server rebooted.

    config.xml setting for that MAC address device set to <ExtendedLogging>true</ExtendedLogging>

    Logs cleared and ready

    killall gaya

    now reads

    #killall gaya

    still the same issue.

    From the startup loading screen 8 seconds of NADA black screen until NextPVR loads?

    cheers

    steeb
    Attached Files Attached Files
    Last edited by steeb; 2012-06-05 at 10:26 PM. Reason: forgot zip!

  10. #10
    Join Date
    May 2006
    Location
    Canada
    Posts
    20,468
    Jaggy, who is the only one designing skins that look good in SD, did not like the way NextPVR rendered SD PAL screens so while it is confusing, the default is now 800x600 http://forums.gbpvr.com/showthread.p...02-28&p=405415

    Martin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •