Results 1 to 6 of 6

Thread: Problem playing .mp4 videos

  1. #1
    Join Date
    Jun 2007
    Location
    UK / Ireland
    Posts
    393

    Problem playing .mp4 videos

    Hi,

    I've encountered a weird problem. The "Videos" part of NPVR plays .avi and .mkv for me perfectly, but when I select a .mp4 I get unusual behaviour.

    With a .mp4 file, the video skips forward a few seconds at the beginning (fast forwards at high frame rate) before settling down and then a couple of seconds later the audio starts but out of sync.

    Oddly, the same files play fine in Windows Media Player.

    Anyone else noticed such behaviour or have any ideas?

    Thanks
    "It's better than a box!"

  2. #2
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,716
    If you post the npvr.log, we can take a look what decoders/splitters etc Windows is choosing for playback of your .mp4 files. This probably give us a fair indication of where the problem lies.

  3. #3
    Join Date
    Jun 2007
    Location
    UK / Ireland
    Posts
    393
    Sub,

    Sorry that this took so long. I thought I'd posted these logs up from my smart phone, but when I came back to check I see that it obviously didn't work.

    Here's an example of when the audio/video is out of sync on a .mp4 file.

    Thanks for your help.
    Attached Files Attached Files
    "It's better than a box!"

  4. #4
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,716
    Unfortunately it doesn't really tell us much, but these are decoders Windows is choosing:

    2012-05-04 09:49:42.007 [DEBUG][1] Graph filter list:
    2012-05-04 09:49:42.008 [DEBUG][1] - Default DirectSound Device
    2012-05-04 09:49:42.008 [DEBUG][1] - EVR Renderer
    2012-05-04 09:49:42.008 [DEBUG][1] - Microsoft DTV-DVD Audio Decoder
    2012-05-04 09:49:42.008 [DEBUG][1] - Microsoft DTV-DVD Video Decoder
    2012-05-04 09:49:42.008 [DEBUG][1] - D:\Videos\Torrents\Mad.Men.S05E07.HDTV.x264-ASAP.mp4
    The filename decoder there is probably something like Haali splitter?

    There isn't really any settings on the NextPVR side that make any difference, but you could try installing a different splitter, like maybe the LAV Splitter.

  5. #5
    Join Date
    Jun 2007
    Location
    UK / Ireland
    Posts
    393
    Hi sub,

    Thanks. Yes I have Haali Splitter installed, it came with CoreAVC. I will try LAV splitter and report back on results.
    "It's better than a box!"

  6. #6
    Join Date
    Feb 2009
    Location
    Czech Rep.
    Posts
    1,096
    Hi.
    You can try SAF, link below.
    My projects:
    SAF6 (Standalone Filters)
    MCE standby tool addon
    My easy Amiga emulation
    HOBRing

    My HTPC

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •