Results 1 to 8 of 8

Thread: FIrst Run Only - setting doesn't stick

  1. #1
    Join Date
    Apr 2012
    Location
    US
    Posts
    24

    FIrst Run Only - setting doesn't stick

    I created a recording from NEWA and selected "First Run Only". When the recording is saved it shows the title followed by "First Run Events Only". That seems fine. When I click on this recurring program to edit it, the "First Run Only" checkbox is unchecked. So I click on the checkbox to enable it and clicked "Update Season Recording". Now the title no longer shows "First Run Events Only". It seems like the "First Run Only" option only works the first time the recording is created. Any ideas or logs that I should attach?
    Thanks.

  2. #2
    Join Date
    Feb 2005
    Location
    Pennsylvania, USA
    Posts
    5,111
    Quote Originally Posted by kevbotheone View Post
    I created a recording from NEWA and selected "First Run Only". When the recording is saved it shows the title followed by "First Run Events Only". That seems fine. When I click on this recurring program to edit it, the "First Run Only" checkbox is unchecked. So I click on the checkbox to enable it and clicked "Update Season Recording". Now the title no longer shows "First Run Events Only". It seems like the "First Run Only" option only works the first time the recording is created. Any ideas or logs that I should attach?
    Thanks.
    My guess would be that when looking at the season recording the value is not being mapped there....I know the feature works on season recordings so for now beolieve what you see on the individual recordings created by the season recording until I can find the bug.

  3. #3
    Join Date
    Apr 2012
    Location
    US
    Posts
    24
    I wanted to let you know that I was editing the "Recurring" program, not an individual pending recording. This issue is very easy for me to reproduce so if you need any logs or tests run, please let me know.

  4. #4
    Join Date
    Feb 2005
    Location
    Pennsylvania, USA
    Posts
    5,111
    Quote Originally Posted by kevbotheone View Post
    I wanted to let you know that I was editing the "Recurring" program, not an individual pending recording. This issue is very easy for me to reproduce so if you need any logs or tests run, please let me know.
    Not sure if you noticed or not but this is corrected in the 1.25 release I posted this week.

  5. #5
    Join Date
    Apr 2012
    Location
    US
    Posts
    24
    Quote Originally Posted by UncleJohnsBand View Post
    Not sure if you noticed or not but this is corrected in the 1.25 release I posted this week.
    I saw that the 'First Run Only' checkmark is properly checked when I view the details. The problem still exists that when I uncheck this box, apply the settings, then view the details again, check the box back, and apply the settings. Now the recording is no longer set to 'First Run Events Only'. Basically, once you uncheck 'First Run Only' you will never be able to get it back unless you delete the recurring program and add it again. This may be something in NPVR during the schedule update and not necessarily the NEWA interface.

  6. #6
    Join Date
    Feb 2005
    Location
    Pennsylvania, USA
    Posts
    5,111
    Thanks....there is an issue with the NPVR API.....it is missing the ability to add the value.....I am checking with sub on a fix.

  7. #7
    Join Date
    May 2006
    Location
    Canada
    Posts
    20,472
    Quote Originally Posted by UncleJohnsBand View Post
    Thanks....there is an issue with the NPVR API.....it is missing the ability to add the value.....I am checking with sub on a fix.
    I forgot to post about that when I tested this last week. I was able to fix the enabling of the tick but the values gets lost on the .Save NextPVR doesn't allow toggling the value after it is set but at least it doesn't lose it.

    Martin

  8. #8
    Join Date
    Feb 2005
    Location
    Pennsylvania, USA
    Posts
    5,111
    Quote Originally Posted by mvallevand View Post
    I forgot to post about that when I tested this last week. I was able to fix the enabling of the tick but the values gets lost on the .Save NextPVR doesn't allow toggling the value after it is set but at least it doesn't lose it.

    Martin
    Yea....API doesn't support it....talked to sub.....we'll get it working with the next release of NPVR.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •