Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Vidoes plugin - slow thumbnail refresh

  1. #1
    Join Date
    Sep 2005
    Location
    Ottawa, ON, Canada
    Posts
    623

    Vidoes plugin - slow thumbnail refresh

    in NPVR, I've only got a few files for testing and once I go down a couple of folders and come back up the thumbnails do not refresh. In fact they won't reappear until I go back over the folder icon.
    E6400, 2 GB RAM ,500 GB + 250 GB HD, PVR150+ Adaptec 3610, RW 2 + HIP, Antec 2480 w/ mini ninja ...still using v 0.99

  2. #2
    Join Date
    Sep 2005
    Location
    Ottawa, ON, Canada
    Posts
    623
    bump this thread since no one responded.

    I've upgraded to the newest NPVR and it's still happening.

    I've attached the logs.

    In thumbnail (video wall) view it's the most noticeable.

    In list mode it takes a long time to show the thumbnail as I scroll down the list.

    In the third mode where everything is horizontal the thumbnails don't show up once I go in and out of several folders.
    Attached Files Attached Files
    E6400, 2 GB RAM ,500 GB + 250 GB HD, PVR150+ Adaptec 3610, RW 2 + HIP, Antec 2480 w/ mini ninja ...still using v 0.99

  3. #3
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,415
    Quote Originally Posted by jam_zhou View Post
    In list mode it takes a long time to show the thumbnail as I scroll down the list.
    As of 2.5.5 its supposed to update the thumbnail about a half second after you stop navigating around. It does this lazy update keep the application more responsive. ie, if you press and hold the down key, it doesn't bother showing the cover artwork for every item in the list because it just slows things down.

    Are you using network drives? These can be slow to load artwork etc from.

  4. #4
    Join Date
    Sep 2005
    Location
    Ottawa, ON, Canada
    Posts
    623
    well list mode seems to be working as needed.

    I really want the "fanart" view though where it just shows thumbnails when there are a whole bunch of folders present with folder.jpg in each.

    The thumbnails just don't show up at all in this case.

    Here's a description:
    when I go into the videos plugin it shows all the thumbnails for each folder (three total for testing)
    I go into one of the folders which contains only a movie
    I come back out
    I go into another folder and come back out
    I'm now at the top of the hierarchy and now there are no thumbnails
    when I move over to the other folders the thumbnails may or may not show up
    E6400, 2 GB RAM ,500 GB + 250 GB HD, PVR150+ Adaptec 3610, RW 2 + HIP, Antec 2480 w/ mini ninja ...still using v 0.99

  5. #5
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,415
    Can you zip up that same directory structure, minues the video files, and attach it? I'll try it here for the same test, with the same metadata.

  6. #6
    Join Date
    Sep 2005
    Location
    Ottawa, ON, Canada
    Posts
    623
    Here's the tree.

    I'm testing on a E8400 64 Bit, Windows 7 and 4 GB of RAM.
    Attached Files Attached Files
    E6400, 2 GB RAM ,500 GB + 250 GB HD, PVR150+ Adaptec 3610, RW 2 + HIP, Antec 2480 w/ mini ninja ...still using v 0.99

  7. #7
    Join Date
    Sep 2005
    Location
    Ottawa, ON, Canada
    Posts
    623
    I've also tried it on my I7 with 10 GB of RAM and it does the same thing.
    E6400, 2 GB RAM ,500 GB + 250 GB HD, PVR150+ Adaptec 3610, RW 2 + HIP, Antec 2480 w/ mini ninja ...still using v 0.99

  8. #8
    Join Date
    May 2006
    Location
    Canada
    Posts
    21,354
    That's one of the icon mode bugs that I've been writing about for 2 years.

    Martin.

  9. #9
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,415
    Hopefully this patch will help.
    Attached Files Attached Files

  10. #10
    Join Date
    Feb 2008
    Location
    Scotland, UK
    Posts
    2,126
    If it does, it'll be a happy day in the imilne household. My wife has been harping on about this one for as long as Martin has

    Iain
    NextPVR Plugins: AudioAdjust | AutoRefresh | MediaInfo | MovieTrailers | ReClockOrNot | SubMenu

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •