Page 3 of 7 FirstFirst 12345 ... LastLast
Results 21 to 30 of 66

Thread: Recording service problem

  1. #21
    Join Date
    Dec 2006
    Location
    The Netherlands
    Posts
    516
    Quote Originally Posted by Reddwarf View Post
    There should be no need to stop the recording service before the pc goes to sleep, but in Resume.bat (in Scripts) you should use "net stop ..." to stop it, kill Ntray, "net start ..." again and then launch Ntray. This should work if all other components of your windows is functioning properly.

    BTW, have you checked that the network interface card is not set to power down or some other "green" function, which is known to create problems for server/client setup.
    Well, in post #17, I wrote:
    Quote Originally Posted by WKleeven View Post
    After sleep and wake, I manually stopped nrecord.exe, ntray.exe and nextpvr.exe then "start NPVR service" from startmenu.
    NTray is frozen, I can start NPVR from startmenu, I can program a recording, recordings starts but when I try to cancel the recording NPVR freezes.
    Wim
    Last edited by WKleeven; 2012-02-28 at 02:08 PM.
    Server: Core2Duo 3,16GHz| Windows 7 Ultimate 64 bit | NPVR 3.2.9 | Analogue: Hauppauge PVR-150 | Digital dvb-c: Technisat CableStar HD 2 | No plugins
    Clients: Laptop Windows 7 Home 64 bit via Wifi | Android tablet via Wifi | Androidbox s89-H via Lan

  2. #22
    Join Date
    Mar 2007
    Location
    Gjovik, Norway - PAL
    Posts
    5,534
    Quote Originally Posted by WKleeven View Post
    Well, in post #17, I wrote:


    Wim
    Do you have the logs from that test? And do you get the message box that says "Started" after starting npvr Service? A workaround would ofcourse be to not let the computer sleep at all...

    "Show me your passport and I'll tell you who you are"
    (new Norwegian saying)

  3. #23
    Join Date
    Dec 2006
    Location
    The Netherlands
    Posts
    516
    No, I don't have that logs anymore but I will reproduce that situation and post the logs tonight.
    Yes, I did get the message "started".

    Unfortunately, my own workaround (scheduled task) doesn't seem to work. But I don't know why the stop seems to be implemented after the resume from sleep instead of before sleep. Any suggestions about that?
    Server: Core2Duo 3,16GHz| Windows 7 Ultimate 64 bit | NPVR 3.2.9 | Analogue: Hauppauge PVR-150 | Digital dvb-c: Technisat CableStar HD 2 | No plugins
    Clients: Laptop Windows 7 Home 64 bit via Wifi | Android tablet via Wifi | Androidbox s89-H via Lan

  4. #24
    Join Date
    Dec 2006
    Location
    The Netherlands
    Posts
    516
    I did the following:
    After sleep and wake, I manually stopped nrecord.exe, ntray.exe and nextpvr.exe then "start NPVR service" from startmenu.
    NTray is frozen, I can start NPVR from startmenu. This time I can't program a recording, NPVR freezes.

    Attached the logs. I think basically the same as I posted in post #1.
    Server: Core2Duo 3,16GHz| Windows 7 Ultimate 64 bit | NPVR 3.2.9 | Analogue: Hauppauge PVR-150 | Digital dvb-c: Technisat CableStar HD 2 | No plugins
    Clients: Laptop Windows 7 Home 64 bit via Wifi | Android tablet via Wifi | Androidbox s89-H via Lan

  5. #25
    Join Date
    Mar 2007
    Location
    Gjovik, Norway - PAL
    Posts
    5,534
    Quote Originally Posted by WKleeven View Post
    I did the following:
    After sleep and wake, I manually stopped nrecord.exe, ntray.exe and nextpvr.exe then "start NPVR service" from startmenu.
    NTray is frozen, I can start NPVR from startmenu. This time I can't program a recording, NPVR freezes.

    Attached the logs. I think basically the same as I posted in post #1.
    Althou I'm not that good in Dutch, it seems to me that something else is holding the port, so that the recording service can't communicate. Sub?

    "Show me your passport and I'll tell you who you are"
    (new Norwegian saying)

  6. #26
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,690
    To be honest, I haven't been able to follow this thread. Too confusing.

  7. #27
    Join Date
    Dec 2006
    Location
    The Netherlands
    Posts
    516
    I'll try to explain again.

    After a reboot, everything is normal.
    When (after a reboot) I do "Stop NPVR service" and let the pc go to sleep and wake it up again, then "Start NPVR service". Everything is normal.
    When (after a reboot) I let the pc go to sleep and wake it up again, then NTray freezes, I can start NPVR through windows start, but when I program a recording NPVR freezes.

    It has nothing to do with MVP, firewall or antivirus.

    Error message is always like this:
    2012-02-25 21:32:26.464 [ERROR][4] Error listing for recording service interface: System.Net.Sockets.SocketException: Elk socketadres (protocol/netwerkadres/poort) kan normaal slechts één keer worden gebruikt
    Translation: every socketadress (protocol/networkadress/port) can only be used once.

    When I try to workaround the problem, using task scheduler, event, system, kernel-power, id=42, which would happen before the pc goes to sleep, the action I programmed (stop NPVR service) doesn't happen until after the pc has woken again. So this doesn't function as a workaround.

    I hope it's not confusing any more.

    Wim
    Server: Core2Duo 3,16GHz| Windows 7 Ultimate 64 bit | NPVR 3.2.9 | Analogue: Hauppauge PVR-150 | Digital dvb-c: Technisat CableStar HD 2 | No plugins
    Clients: Laptop Windows 7 Home 64 bit via Wifi | Android tablet via Wifi | Androidbox s89-H via Lan

  8. #28
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,690
    Which log is that error in?

  9. #29
    Join Date
    Dec 2006
    Location
    The Netherlands
    Posts
    516
    In the logs in post #1. In post #2 you suggested it might be related to firewall or antivirus issues, but I disabled both and the problem persisted.
    Server: Core2Duo 3,16GHz| Windows 7 Ultimate 64 bit | NPVR 3.2.9 | Analogue: Hauppauge PVR-150 | Digital dvb-c: Technisat CableStar HD 2 | No plugins
    Clients: Laptop Windows 7 Home 64 bit via Wifi | Android tablet via Wifi | Androidbox s89-H via Lan

  10. #30
    Join Date
    Sep 2008
    Location
    California
    Posts
    5,884
    Just upgrade to 2.3.6. Regardless of whether this problem would go away if you upgrade, what's the point of trying to troubleshoot this on an old version? Sub maintains only one version of the code, the "right now" version, so he can't give you any fixes for what you're running anyway.
    NPVR Tech Support Sticky - - http://forums.gbpvr.com/showthread.p...931#post480931
    ---------------------------
    my config: NPVR 3.3.8/Win7Pro/Athlon II X3-440/radeon hd4550/hvr-2250/hvr-850/OTA ATSC via Winegard Flatwave Amped antenna/Schedules Direct

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •