Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: NPVR 2.3.6 Music No Longer Plays DTS Audio Wavs

Hybrid View

  1. #1
    Join Date
    Oct 2008
    Location
    Severn Estuary (Mendip) UK
    Posts
    804

    NPVR 2.3.6 Music No Longer Plays DTS Audio Wavs

    Only about 3 weeks ago I discovered NPVR would play DTS wav files using LAV splitter and audio decoder, so I started ripping my DTS CD's to disc.

    NPVR 2.3.6 no longer plays these files with either a wav or dts file extension. They still play fine in graph studio (Lav Splitter - LAV Audio Codec - Default Audio Renderer) I presume its to do with the new music renderer option.

    If it is awkward to fix, I will fully understand - vlc was the only program to ply these files previously and I only have about 10 surround sound cd's so no big hardship.
    It's not an overly complicated system - it's more - overly simple operatives

  2. #2
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,401
    NextPVR does know anything about .wav or .dts files. It just askes Directshow to play these. Something must have changed about the directshow decoders on your machine.

  3. #3
    Join Date
    Oct 2008
    Location
    Severn Estuary (Mendip) UK
    Posts
    804
    I will do some more investigation in a few days and come back to this (probably a connect to remote graph in Graph Studio might shed some light) rendering the file directly in Graph Studio works fine but in NPVR all I get now is Digital Hiss

    Only change was update to NPVR 2.3.6 - maybe the new music renderer option and ReclockorNot plugin are miss behaving together.
    It's not an overly complicated system - it's more - overly simple operatives

  4. #4
    Join Date
    Feb 2008
    Location
    Scotland, UK
    Posts
    2,126
    Quote Originally Posted by Lao Pan View Post
    I will do some more investigation in a few days and come back to this (probably a connect to remote graph in Graph Studio might shed some light) rendering the file directly in Graph Studio works fine but in NPVR all I get now is Digital Hiss

    Only change was update to NPVR 2.3.6 - maybe the new music renderer option and ReclockorNot plugin are miss behaving together.
    I haven't really looked at what the implications of the new renderer and ReClockOrNot are. It's still working ok for me for video stuff, and that is the only renderer it's meant to be toggling. When I get the time I want to try to merge it with AudioAdjust as well and control everything via one plugin.

    Can you post a short DTS sample (or link to where I can find one). Might be fun to try...

    Iain
    NextPVR Plugins: AudioAdjust | AutoRefresh | MediaInfo | MovieTrailers | ReClockOrNot | SubMenu

  5. #5
    Join Date
    Oct 2008
    Location
    Severn Estuary (Mendip) UK
    Posts
    804
    Swedish Radio has several DTS samples for download http://sverigesradio.se/sida/default...programid=2446 - probably safest for copyright reasons - don't want to shut down another file repository just yet

    If you want some thing better let me know and we can sort something - Art of Noise?
    It's not an overly complicated system - it's more - overly simple operatives

  6. #6
    Join Date
    Sep 2005
    Location
    germany
    Posts
    1,503
    I have currently no AudioAdjust or ReClockOrNot installed and experience the same issue. So imilne, again, isn't guilty. ;D
    I think the main cause is the fact, that a 3rd party audio decoder won't be loaded.
    It looks like, as if would be the system default (microsoft dtv) would be loaded. And this one decodes DTS only, if the driver of the audio hardware is licensed and supports it.
    Have you by any chance changed the driver for your audio hardware?
    Now you could check within the windows audio mixer, if dts is supported by your audio hardware, and more important, if it's enabled. Of course you could check the audio card software itself (e.g. realtek menu).
    You like nPVR? Then please help pay the bills, and keep the project alive!

    My happy NextPVR family

    Frei nach Dieter Nuhr: Wenn man keine Ahnung hat, einfach mal die Fresse halten.

  7. #7
    Join Date
    Feb 2008
    Location
    Scotland, UK
    Posts
    2,126
    I tried one of the sample files with the LAV Splitter and AC3filter installed (note, no LAV audio decoder) on my laptop with the following being built automatically in GraphStudio:

    Name:  Image1.jpg
Views: 88
Size:  24.3 KB

    That certainly had music coming out, rather than hissing, so I assume the DTS decoding was working properly. Just testing it on my laptop during lunch at work, so can't be 100% sure.

    Within NPVR, all I got was noise/hissing, and the logs show a graph that only contains the Default DirectSound Device and the LAV Splitter; for some reason AC3filter didn't get inserted.
    Code:
    Graph filter list:
    2012-01-25 13:27:26.352	[DEBUG][1]	 - Default DirectSound Device
    2012-01-25 13:27:26.352	[DEBUG][1]	 - LAV Splitter
    2012-01-25 13:27:26.352	[DEBUG][1]	 - C:\Music\Music for Lau.wav
    If ReClockOrNot is enabled, you'll see messages from it in the logs but I think they can be safely ignored. It's probably just changing the video renderer based on whether the filename ends with .ts or not, so should be harmless with these wav files. As ShiningDragon says though, the result is the same without it.

    Iain
    NextPVR Plugins: AudioAdjust | AutoRefresh | MediaInfo | MovieTrailers | ReClockOrNot | SubMenu

  8. #8
    Join Date
    Oct 2008
    Location
    Severn Estuary (Mendip) UK
    Posts
    804
    At work so this is from memory:

    Graph Studio is loading LAV Splitter LAV Audio Decoder (SAF 5.0.5) and Default Sound Renderer which then goes via Realtek DTS Connect to the Amp which works fine.
    Last week NPVR 2.2.6 was doing similar stuff (I presume using same chain) but NPVR 2.3.6 just gives loud hissing sound.

    I know that not many codecs recognise the DTS in wav stream - LAV Audio does it FFDshow does if you check the check for DTS in wav box and obviously AC3filter and VLC.

    For some reason some other codec is being loaded instead of the direct show codec.
    It's not an overly complicated system - it's more - overly simple operatives

  9. #9
    Join Date
    Mar 2007
    Location
    Gjovik, Norway - PAL
    Posts
    5,502
    Quote Originally Posted by Lao Pan View Post
    At work so this is from memory:

    Graph Studio is loading LAV Splitter LAV Audio Decoder (SAF 5.0.5) and Default Sound Renderer which then goes via Realtek DTS Connect to the Amp which works fine.
    Last week NPVR 2.2.6 was doing similar stuff (I presume using same chain) but NPVR 2.3.6 just gives loud hissing sound.

    I know that not many codecs recognise the DTS in wav stream - LAV Audio does it FFDshow does if you check the check for DTS in wav box and obviously AC3filter and VLC.

    For some reason some other codec is being loaded instead of the direct show codec.
    I had a case recently where ffdshow "took over" all codecs after beeing installed by TSDoctor, once I went into Settings->Decoders and clicked OK everything was fine again.

    "Show me your passport and I'll tell you who you are"
    (new Norwegian saying)

  10. #10
    Join Date
    Oct 2008
    Location
    Severn Estuary (Mendip) UK
    Posts
    804
    I have just done some quick testing
    It is not possible to connect to remote greph in Music

    Here is log entry for a FLAC File

    2012-01-25 17:49:52.470 [DEBUG][1] Starting first track: \\TOWER\Music\Flac CDs\Ambient Lounge 5\Ambient Lounge 5 (Disc 1)\01 - My Culture [Album Version] - 1 Giant Leap feat. Robbie Williams & Maxi Jazz - Ambient Lounge 5 (Disc 1).flac
    2012-01-25 17:49:52.470 [DEBUG][1] AutoRefresh: Checking \\TOWER\Music\Flac CDs\Ambient Lounge 5\Ambient Lounge 5 (Disc 1)\01 - My Culture [Album Version] - 1 Giant Leap feat. Robbie Williams & Maxi Jazz - Ambient Lounge 5 (Disc 1).flac
    2012-01-25 17:49:52.532 [DEBUG][1] AutoRefresh: MediaInfo cannot detect framerate
    2012-01-25 17:49:52.533 [DEBUG][1] AutoRefresh: Current refresh rate of 50Hz is ok
    2012-01-25 17:49:52.533 [DEBUG][1] ReClockOrNot: Audio renderer is already Reclock; doing nothing
    2012-01-25 17:49:52.535 [DEBUG][1] adding music renderer: Default DirectSound Device
    2012-01-25 17:49:52.704 [DEBUG][1] Graph filter list:
    2012-01-25 17:49:52.704 [DEBUG][1] - Default DirectSound Device
    2012-01-25 17:49:52.704 [DEBUG][1] - LAV Audio Decoder
    2012-01-25 17:49:52.704 [DEBUG][1] - LAV Splitter
    2012-01-25 17:49:52.704 [DEBUG][1] - \\TOWER\Music\Flac CDs\Ambient Lounge 5\Ambient Lounge 5 (Disc 1)\01 - My Culture [Album Version] - 1 Giant Leap feat. Robbie W

    Here is the log entry for a DTS Wav File

    2012-01-25 17:48:30.459 [DEBUG][1] Starting first track: D:\Audio\New Folder\01 - MAIN TITLE- Bride in Cold Tears - Tangerine Dream - The Video Dream Mixes (Dolby Digital 5.1).dts
    2012-01-25 17:48:30.459 [DEBUG][1] AutoRefresh: Checking D:\Audio\New Folder\01 - MAIN TITLE- Bride in Cold Tears - Tangerine Dream - The Video Dream Mixes (Dolby Digital 5.1).dts
    2012-01-25 17:48:30.504 [DEBUG][1] AutoRefresh: MediaInfo cannot detect framerate
    2012-01-25 17:48:30.504 [DEBUG][1] AutoRefresh: Current refresh rate of 50Hz is ok
    2012-01-25 17:48:30.504 [DEBUG][1] ReClockOrNot: Changing audio renderer to Reclock
    2012-01-25 17:48:30.506 [DEBUG][1] adding music renderer: Default DirectSound Device
    2012-01-25 17:48:30.604 [DEBUG][1] Graph filter list:
    2012-01-25 17:48:30.604 [DEBUG][1] - Default DirectSound Device
    2012-01-25 17:48:30.604 [DEBUG][1] - LAV Splitter
    2012-01-25 17:48:30.604 [DEBUG][1] - D:\Audio\New Folder\01 - MAIN TITLE- Bride in Cold Tears - Tangerine Dream - The Video Dream Mixes (Dolby Digital 5.1).dts

    (Exactly the same result with a wav extension)(Also Disregard the Dolby Digital in the File name - from cddatabase rename)

    In graph Studio it is putting the LAV Audio Decoder in the chain and rendering perfectly
    It's not an overly complicated system - it's more - overly simple operatives

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •