Page 3 of 3 FirstFirst 123
Results 21 to 30 of 30

Thread: [Plugin] Pandora Internet Radio

  1. #21
    Join Date
    Aug 2011
    Location
    Virginia, USA
    Posts
    476
    I've never seen this before. If this doesn't occur with the default skin then it would seem that it might be a problem with using an alternate skin and copying the skin files over might not be enough (I've never tried a different skin).

  2. #22
    Join Date
    Mar 2006
    Location
    Carterton, NZ
    Posts
    2,724
    Technically with "my skins" I can't see any reason copying the plugin skin from default into BRVE+ (or JustRetro) shouldn't work as I have all the fonts & colours etc. from default defined in my global.xml files for just this purpose (I'm not saying it will work for other skins though). I can't test this (or do a plugin skin) myself as I don't live in the States therefore Pandora won't work for me.

  3. #23
    Join Date
    Aug 2011
    Location
    Virginia, USA
    Posts
    476
    Sorry, I can't reproduce this. I installed the BlueRetroVE+ skin, copied the PandoraRadio default skin directory over, and it runs fine without any problems. NPVR always has focus after the Pandora player window is launched so Ctrl+s closes the window and "Up" displays the top menu as expected. You should eventually see a loading error message in the Pandora player window (message supplied by the Pandora website). Do you not see that when it fails to load? What operating system are you running?

  4. #24
    Join Date
    Sep 2011
    Location
    Kansas City, MO USA
    Posts
    231
    I am running Win 7-64. At 6:22am I started Pandora and it froze as before. Had no mouse, crlt-s does nothing. Was unable to use alt-enter to toggle out of full screen node. The time shown at top of Pandora screen never changed and it showed the station selected. Had to end the npvr app via task manager.

    I drilled through the npvr logs and was unable to decipher whether it would show pandora startup and failure. I did find something of interest.
    Code:
    2012-01-25 06:21:25.008	[INFO][3]	last notified version: 2.3.6
    2012-01-25 06:21:26.394	[DEBUG][1]	Element not found: /Skin/Element[@name="ButtonList"]
    2012-01-25 06:21:26.419	[ERROR][1]	Failed to find element: /Skin/Element[@name="ListView"]
    2012-01-25 06:21:26.420	[DEBUG][1]	Element not found: /Skin/Element[@name="ListView"]
    2012-01-25 06:21:26.420	[DEBUG][1]	Element not found: /Skin/Element[@name="ListView"]
    2012-01-25 06:21:26.420	[ERROR][1]	Failed to find element: /Skin/Element[@name="ListSelectionMetaData"]
    2012-01-25 06:21:26.420	[DEBUG][1]	Element not found: /Skin/Element[@name="ListSelectionMetaData"]
    2012-01-25 06:21:26.420	[DEBUG][1]	Element not found: /Skin/Element[@name="ListSelectionMetaData"]
    2012-01-25 06:21:26.420	[DEBUG][1]	Element not found: /Skin/Element[@name="ListView"]
    2012-01-25 06:21:26.424	[ERROR][1]	Failed to find element: /Skin/Element[@name="CoversView"]
    2012-01-25 06:21:26.424	[DEBUG][1]	Element not found: /Skin/Element[@name="CoversView"]
    2012-01-25 06:21:26.424	[DEBUG][1]	Element not found: /Skin/Element[@name="CoversView"]
    2012-01-25 06:21:26.424	[ERROR][1]	Failed to find element: /Skin/Element[@name="CoversSelectionMetaData"]
    2012-01-25 06:21:26.424	[DEBUG][1]	Element not found: /Skin/Element[@name="CoversSelectionMetaData"]
    2012-01-25 06:21:26.424	[DEBUG][1]	Element not found: /Skin/Element[@name="CoversSelectionMetaData"]
    There is a lot of these. Surely not related as the time shows before Pandora startup. May be normal? This was from npvr.log1.
    Code:
    2012-01-25 06:24:31.355	[DEBUG][1]	OnKeyDown() called: {ALT}Menu, Alt
    2012-01-25 06:24:31.355	[DEBUG][1]	OnKeyDown() called: {ALT}Menu, Alt
    2012-01-25 06:24:31.356	[DEBUG][1]	OnKeyDown() called: {ALT}Menu, Alt
    2012-01-25 06:24:31.356	[DEBUG][1]	OnKeyDown() called: {ALT}Menu, Alt
    2012-01-25 06:24:31.359	[DEBUG][1]	raw message: C0
    2012-01-25 06:24:31.359	[DEBUG][1]	raw message: C0
    2012-01-25 06:24:31.365	[DEBUG][1]	CoversView. Alpha:255
    2012-01-25 06:24:31.366	[DEBUG][1]	CoversView. Alpha:255
    2012-01-25 06:24:39.700	[DEBUG][1]	CoversView. Alpha:255
    2012-01-25 06:24:39.820	[DEBUG][1]	storing Position (1):0,0
    2012-01-25 06:24:39.821	[DEBUG][1]	storing Size (1):1049,624
    2012-01-25 06:24:39.821	[DEBUG][1]	TV Listings: Got event EXITING 
    2012-01-25 06:24:39.823	[INFO][1]	TV Listings: RecordingSchedule: deactivated.
    2012-01-25 06:24:39.831	[INFO][1]	Exiting...
    2012-01-25 06:24:39.831	[INFO][1]	Done.
    This was from npvr.log. It looks to me that npvr was still running, and shut down properly when forced. Complete log files attached. A focus issue makes sense!

    Greg

  5. #25
    Join Date
    Sep 2011
    Location
    Kansas City, MO USA
    Posts
    231
    no mouse, crlt-s does nothing. Was unable to use alt-enter to toggle out of full screen node. The time shown at top of Pandora screen never changed and it showed the station selected. Had to end the npvr app via task manager.
    When using the default skin, the above does not apply. Functionality remains but no playback! Trying different stations makes no difference..

    Greg

  6. #26
    Join Date
    Aug 2011
    Location
    Virginia, USA
    Posts
    476
    I'm really not sure what is going on. It might be an Adobe Flash Player issue with the embedded browser. Maybe try this: In Programs and Features uninstall all instances of Adobe Flash Player. Then, open NPVR and in the Default skin try to play a Pandora station. It should somehow indicate to you that you need to install Adobe Flash. Try to navigate and install Flash within the Pandora player window/browser inside NPVR. Restart NPVR and try to play a station again.

    Unfortunately, there won't be any clues as to why the player is not loading in the NPVR logs because it is all up to the browser to load the web page and it is all internal to the Pandora web site at that point.

  7. #27
    Join Date
    Sep 2011
    Location
    Kansas City, MO USA
    Posts
    231
    I tried the recommendation, but no indication to install Flash. One thing which may be normal is when I run npvr in full screen, start Pandora, press alt-enter to toggle out of full screen. Pandora browser remains same size. Any other app which I may start will show under the Pandora browser. Ctrl-s only closes the browser when alt-tabbing puts npvr back in focus.

    I originally installed Pandora with Firefox as the default browser. Changed default to IE9 as a test. No difference, probably doesn't matter anyway.

    Greg

  8. #28
    Join Date
    Aug 2011
    Location
    Virginia, USA
    Posts
    476
    The Pandora window behavior is expected because it is a separate window displayed on top of NPVR. When you toggle out of full screen if you exit the Pandora screen and then go back in it should be resized and positioned appropriately.

    I just tried uninstalling Flash on one of my PCs and I get similar behavior to what you were seeing before: the Pandora background image is shown but it never tries to load or gives any loading error or any prompt to install Flash (however, I never have to kill NPVR as Ctrl+s always works for me). So, make sure you uninstall all instances of Flash in Programs & Features as I described before. Then, with NPVR closed open IE and navigate to 'http://get.adobe.com/flashplayer/'. Install the latest Flash Player from there and try NPVR again. If it still doesn't work and you never get any loading error displayed in the Pandora player window it suggests a more fundamental issue with your setup that I unfortunately can't identify at the moment.

  9. #29
    Join Date
    Aug 2011
    Location
    Virginia, USA
    Posts
    476
    I'm not sure if anyone is still using this, but I just wanted to let you know I will probably be pulling this plugin from the Wiki soon. I've wasted a lot of time trying to figure out and fix the Pandora loading problems with no success. Also, their "unofficial" API that sends song information is not reliable anymore (pretty much never sends information).

    I would recommend just using the Kylo full-screen browser. It's not quite as convenient but is very reliable and you can access other online music services too like Slacker, etc.

  10. #30
    Join Date
    Sep 2008
    Location
    California
    Posts
    5,691
    bummer... I hadn't used it in awhile, but wanted to in the last few days and couldn't get it to work so I came here looking to see if there was an update I needed.

    Oh well, you can't make it work if Pandora won't give you the needed data. Thanks for the work you did, it was great for awhile!
    NPVR Tech Support Sticky - - http://forums.gbpvr.com/showthread.p...612#post473612
    ---------------------------
    my config: NPVR 3.2.9/Win7Pro/Athlon II X3-440/radeon hd4550/hvr-2250/hvr-850/KWorld 315U/TimeWarner QAM & Analog, OTA ATSC/schedules direct

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •