Page 36 of 56 FirstFirst ... 26343536373846 ... LastLast
Results 351 to 360 of 551

Thread: YouTube Plugin

  1. #351
    Join Date
    Jul 2005
    Location
    HK - Pal I
    Posts
    2,919
    Nice plugin thanks!!!

    I have it playing fine on the PC now...but I have the "Object Reference not set..." exception (like Sheik Yerbouti) on the NMT.
    Any ideas?

    k.

    One thing in a log (MVP.log.1) is a hard coded path ... F:\Projects\NextPVR\YouTube\Yutube (I don't have that)....

    "YouTube: Error getting video streams:Object reference not set to an instance of an object.
    at NextPVR.YouTube.YouTubePlugin.thisVs_GetVideoStrea msCompleted(Object sender, GetVideoStreamsCompletedEventArgs e) in F:\Projects\NextPVR\YouTube\YouTube\NewStyleButton ListPlugin.cs:line 563
    at NextPVR.YouTube.VideoStream.OnGetVideoStreamsCompl eted(GetVideoStreamsCompletedEventArgs e) in F:\Projects\NextPVR\YouTube\YouTube\VideoStream.cs :line 177
    at NextPVR.YouTube.VideoStream.wc_DownloadStringCompl eted(Object sender, DownloadStringCompletedEventArgs e) in F:\Projects\NextPVR\YouTube\YouTube\VideoStream.cs :line 77"
    Last edited by jksmurf; 2012-05-12 at 06:51 AM.
    ASUS P5K-PRO Q9300 @ 2.5GHz | Win7 x64 | 6GB RAM | ATI Radeon HD3400 PCIe Video Card | 1 x PVR-150 | 2 x WinTV DMB-TH | Various HD's | AC66U | USB-UIRT | PCH-A100 |
    If you've ever become frustrated because something in GBPVR or NPVR is not working, take a moment and consider this and this and this and this and this and this. Credit where credit's due; for one guy (with a wife and two kids), most problems are solved outrageously quickly. Patience.

  2. #352
    Join Date
    Feb 2008
    Location
    Scotland, UK
    Posts
    2,097
    The paths are just references to where the error occurred in the original source code. They won't mean anything to you, but will help whurlston debug whatever's going wrong.

    Iain
    NPVR Plugins: AudioAdjust | AutoRefresh | MediaInfo | MovieTrailers | ReClockOrNot | SubMenu | System | Videos+

  3. #353
    Join Date
    May 2006
    Location
    Canada
    Posts
    20,772
    Quote Originally Posted by jksmurf View Post
    I have it playing fine on the PC now...but I have the "Object Reference not set..." exception (like Sheik Yerbouti) on the NMT.
    Any ideas?
    Looking at your YouTube.xml you aren't using ffmpeg it is using raw streaming for both the PC and NMT. Change these to true for ffmpeg.

    useBufferForNMT="false" useBufferForPC="false"

    Native streaming worked on the NMT originally, I haven't tried it recently.

    Martin

  4. #354
    Join Date
    Jul 2005
    Location
    HK - Pal I
    Posts
    2,919
    <General hqThumbs="true" useBufferForNMT="false" useBufferForPC="false" sticky="true">

    to

    <General hqThumbs="true" useBufferForNMT="true" useBufferForPC="true" sticky="true">

    So these changes
    ASUS P5K-PRO Q9300 @ 2.5GHz | Win7 x64 | 6GB RAM | ATI Radeon HD3400 PCIe Video Card | 1 x PVR-150 | 2 x WinTV DMB-TH | Various HD's | AC66U | USB-UIRT | PCH-A100 |
    If you've ever become frustrated because something in GBPVR or NPVR is not working, take a moment and consider this and this and this and this and this and this. Credit where credit's due; for one guy (with a wife and two kids), most problems are solved outrageously quickly. Patience.

  5. #355
    Join Date
    Jul 2005
    Location
    HK - Pal I
    Posts
    2,919
    Hmmm... no joy....

    After changing both settings to true, I ran on PC, then NMT.

    Unfortunately while I can see the file grow in the buffer, which it did not do before, song plays, but jumps out after about 20secs, on both.

    Changing buffer to false on the PC works fine again (which I did in between the PC and NMT runs).

    k.
    ASUS P5K-PRO Q9300 @ 2.5GHz | Win7 x64 | 6GB RAM | ATI Radeon HD3400 PCIe Video Card | 1 x PVR-150 | 2 x WinTV DMB-TH | Various HD's | AC66U | USB-UIRT | PCH-A100 |
    If you've ever become frustrated because something in GBPVR or NPVR is not working, take a moment and consider this and this and this and this and this and this. Credit where credit's due; for one guy (with a wife and two kids), most problems are solved outrageously quickly. Patience.

  6. #356
    Join Date
    Jul 2005
    Location
    HK - Pal I
    Posts
    2,919
    Something else that happens, is if I hover my mouse pointer over the YouTube/Bufffer dir, it crashes windows explorer without fail. Below the Event Viewer error. Anyone else seen or experienced this?

    Code:
    Faulting application explorer.exe, version 6.0.6002.18005, time stamp 0x49e01da5, faulting module qedit.dll, version 6.6.6002.18005, time stamp 0x49e037dc, exception code 0xc0000005, fault offset 0x0005badf, process id 0x1f78, application start time 0x01cd364671743f7b.
    k.
    Attached Images Attached Images  
    ASUS P5K-PRO Q9300 @ 2.5GHz | Win7 x64 | 6GB RAM | ATI Radeon HD3400 PCIe Video Card | 1 x PVR-150 | 2 x WinTV DMB-TH | Various HD's | AC66U | USB-UIRT | PCH-A100 |
    If you've ever become frustrated because something in GBPVR or NPVR is not working, take a moment and consider this and this and this and this and this and this. Credit where credit's due; for one guy (with a wife and two kids), most problems are solved outrageously quickly. Patience.

  7. #357
    Join Date
    Jan 2005
    Location
    London
    Posts
    2,829
    Explorer will crash if trying to render the thumbnail for an invalid/corrupt video file. Windows has had this problem for years. I think there is a registry setting to disable the thumbnail generation feature (or don't browse that folder)
    Silverstone LC17 Case,
    ASUS P5Q, Intel E7200, 4GB RAM
    Blackgold DVB-T2, ATI 7750, Windows 7 64-bit
    SAF codec pack,Sony 40" Z5500

  8. #358
    Join Date
    Jul 2005
    Location
    HK - Pal I
    Posts
    2,919
    OK Thanks, will try and find that setting. The YouTube plugin does seem to generate more invalid files than most though, if buffering is used.

    k.
    ASUS P5K-PRO Q9300 @ 2.5GHz | Win7 x64 | 6GB RAM | ATI Radeon HD3400 PCIe Video Card | 1 x PVR-150 | 2 x WinTV DMB-TH | Various HD's | AC66U | USB-UIRT | PCH-A100 |
    If you've ever become frustrated because something in GBPVR or NPVR is not working, take a moment and consider this and this and this and this and this and this. Credit where credit's due; for one guy (with a wife and two kids), most problems are solved outrageously quickly. Patience.

  9. #359
    Join Date
    Jul 2005
    Location
    HK - Pal I
    Posts
    2,919

    exception has been thrown by the target of an invocation ?

    My previously working feed to a track is now throwing an exception; I tried one or two others, some work but some have the same problem?
    Another query - The buffer file is in the Buffer dir and works using VLC. Is it supposed to use that if it is there and of so, why doesn't it play it without an exception?
    I took out the file to see if it would work without the buffered version - no dice?

    A second question - is there a way to make a playlist of your own, from indivdual tracks? I guess it's called a "feed"
    Apologies for my ignorance, but I've just been using saved searches, however these take a long time to download the list each time, when I only want one song.

    k.
    Attached Images Attached Images  
    ASUS P5K-PRO Q9300 @ 2.5GHz | Win7 x64 | 6GB RAM | ATI Radeon HD3400 PCIe Video Card | 1 x PVR-150 | 2 x WinTV DMB-TH | Various HD's | AC66U | USB-UIRT | PCH-A100 |
    If you've ever become frustrated because something in GBPVR or NPVR is not working, take a moment and consider this and this and this and this and this and this. Credit where credit's due; for one guy (with a wife and two kids), most problems are solved outrageously quickly. Patience.

  10. #360
    Join Date
    Mar 2008
    Location
    USA
    Posts
    39
    I also have the exception being thrown but I think I uninstalled QT so I putting that back to see if it helps.

    For a playlist, I use the feed to my YouTube account favorites in the Custom URLs:

    "https://gdata/youtube.com/feeds/API/users/MyUserName/favorites?v=2"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •