Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: 2.1.4 Is -UpdateEPGOnly working from command line?

  1. #1
    Join Date
    May 2007
    Location
    Hamilton, New Zealand
    Posts
    64

    2.1.4 Is -UpdateEPGOnly working from command line?

    I did a clean reinstall of Win7 HP in the weekend (downgraded from 64-bit to 32-bit), great timing for new release of NPVR thanks Sub.

    I had previously used Windows Task Scheduler to update the XMLTV file and then run NextPVR.exe -UpdateEPGOnly
    I setup the scheduled task on the new system, the XMLTV file/s are updating but the EPG is not being updated.
    Update EPG works from The Settings window or using the System plugin.
    I have tried running the command from the command prompt (run in the C:\Program Files\NPVR directory) but nothing is happening. Has something changed?
    Cheers
    Case - Antec Fusion; MB - Gigabyte GA-MA78GM-S2H; Video - AMD HD4350; Tuner - Hauppauge HVR-2200 and Nova-T; CPU - Athlon 64x2 4200; System drive 128GB Intel SSD, WD Greenpower 1TB HDD, Seagate 2TB ; OS - Win7 HP 32-bit

  2. #2
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,710
    It should be working. Nothing has changed on that front. Try running it, then zip and attach the npvr.log and I'll take a look.

  3. #3
    Join Date
    May 2007
    Location
    Hamilton, New Zealand
    Posts
    64
    Thanks Sub, will do that tonight
    Case - Antec Fusion; MB - Gigabyte GA-MA78GM-S2H; Video - AMD HD4350; Tuner - Hauppauge HVR-2200 and Nova-T; CPU - Athlon 64x2 4200; System drive 128GB Intel SSD, WD Greenpower 1TB HDD, Seagate 2TB ; OS - Win7 HP 32-bit

  4. #4
    Join Date
    Dec 2008
    Location
    Hamilton, New Zealand
    Posts
    6
    I'm struggling with this as well.

    Clean install of Windows7 64. EPG Collector V3.1

    The XML Document seems to be generating ok and looks normal size but N-PVR 2.1.4 EPG isn't being populated. Live TV works ok. I'm assuming you are also Waikato (Te Aroha).

    NPVR 2.0.3 and EPG Collector V3.0 were fine in this respect but we were getting NPVR shutting down on us sometimes when skipping through the ads.

  5. #5
    Join Date
    May 2006
    Location
    Canada
    Posts
    21,703
    I use -updateepgonly mode and I have no issues with 2.1.4 (I thought I used -updateepg but that loads nextpvr afterwards)

    As a further test I decided to try without the recording service running and I ran into lots of issues with the database being locked and NPVR crashing before things where scheduled.

    Martin
    Last edited by mvallevand; 2011-07-06 at 04:35 AM.

  6. #6
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,710
    Quote Originally Posted by Buster View Post
    I'm struggling with this as well.

    Clean install of Windows7 64. EPG Collector V3.1

    The XML Document seems to be generating ok and looks normal size but N-PVR 2.1.4 EPG isn't being populated. Live TV works ok. I'm assuming you are also Waikato (Te Aroha)..
    Can you reproduce and zip and attach the npvr.log?

  7. #7
    Join Date
    Dec 2008
    Location
    Hamilton, New Zealand
    Posts
    6
    Also two new channels have appeared in the scans. TV Rotorua and Info-Rotorua, which don't work as yet and I suspect I will never use.

  8. #8
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,710
    Did you copy and restore your old 2.0.3 database after upgrading to 2.1.4? It looks like you have, and have lost the database upgrade.

    It can be fixed by using sqlitespy or other sqlite tool to execute the following statement:

    Code:
    alter table EPG_EVENT add column dvb_service_event_id int

  9. #9
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,710
    You could probbably also fix it by editing config.xml and setting <CurrentVersion>2.1.3</CurrentVersion>, then running nextpvr.exe, which will trigger it to update the database again.

  10. #10
    Join Date
    Dec 2008
    Location
    Hamilton, New Zealand
    Posts
    6
    Might be getting confused here. We tend to use N-PVR for watching recorded Freeview TV (Terrestrial).
    All I've done in the past is copy anything not yet watched into the Video folder and watch from there while any new recordings go to the Recording directory.

    My problem is that the 'TV Guide' screen shows a matrix of 'no show details'.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •