Page 2 of 7 FirstFirst 1234 ... LastLast
Results 11 to 20 of 61

Thread: Dvd iso's on mvpmcx2

  1. #11
    Join Date
    Dec 2004
    Location
    Wellington, New Zealand
    Posts
    461

    iso will not play

    I've got my DVD iso files on the HDX1000 internal hard drive. I've enabled the Samba server on the HDX1000 and I can see and play all the video and iso files through the main NextPVR server without any problem... but trying to play the iso files through either the mvpmcx2 on the HDX1000 or the EGreat fails. I can see the files, but clicking on them does nothing.

    Through the egreat I've created the directory, and here is the mount command:

    mount -t cifs //192.168.0.6/share /mnt/\\\\HDX1000\\share -o username=nmt,password=1234,ro

    Doing an ls command gives me this so I know that the mount works:

    ls /mnt/\\\\HDX1000\\share
    Apps Music Video start_app.sh
    Breach.iso Photo lost+found

    But clicking on Breach.iso for example through mvpmcx2 on the egreat does absolutely nothing. And there's nothing in the web log indicating I've done anything when I click on the iso file. Any suggestions?
    Regards,
    Hasso

    Server: NPVR 2.2.6, Asus E35M1-M PRO motherboard, 2 x 2GB DDR-1333 memory, 1 x 1.5TB SATA Samsung HD, 2 x 2TB SATA Seagate Green HD, 1 x Hauppauge HD4400, 2 x Hauppauge Nova T 500, Windows 7 Home.
    Clients: EGreat M34A with MVPMCX2; HDX1000 with MVPMCX2 and internal 2TB SATA Seagate Green HD.

  2. #12
    Join Date
    May 2006
    Location
    Canada
    Posts
    21,281
    Quote Originally Posted by hasso View Post
    I've got my DVD iso files on the HDX1000 internal hard drive. I've enabled the Samba server on the HDX1000 and I can see and play all the video and iso files through the main NextPVR server without any problem... but trying to play the iso files through either the mvpmcx2 on the HDX1000 or the EGreat fails. I can see the files, but clicking on them does nothing.
    NMT's will not play .iso files that are encrypted.

    Through the egreat I've created the directory, and here is the mount command:

    mount -t cifs //192.168.0.6/share /mnt/\\\\HDX1000\\share -o username=nmt,password=1234,ro

    Doing an ls command gives me this so I know that the mount works:
    The mount is only needed when you play your files on the PC, there is special handling for files shared from the NMT's internal drive. When you configure the mount in config.xml use the IP of the NMT to trigger this.


    ls /mnt/\\\\HDX1000\\share
    Apps Music Video start_app.sh
    Breach.iso Photo lost+found
    To playback from NextPVR on mvpmcx2 you would need Breach.iso in

    Video/Breach/Breach.iso

    But clicking on Breach.iso for example through mvpmcx2 on the egreat does absolutely nothing. And there's nothing in the web log indicating I've done anything when I click on the iso file. Any suggestions?
    Because of an unaddressed bug in NPVR you would have to hit play on the Breach folder

    Martin

  3. #13
    Join Date
    Dec 2004
    Location
    Wellington, New Zealand
    Posts
    461
    Martin,
    Sorry, I'm a bit confused.

    So you are saying that the only way I can play iso files through NextPVR on mvpmcx2 is to have each and every one in their own folder?

    This wasn't the impression I was getting from reading the threads, but maybe I'm missing something. I thought that as long as all the iso's were in one folder it would work. In my situation, I've got the unencrypted iso files on the internal SATA drive of the HDX1000, all sitting in a DVD folder. I can play them from the NextPVR server, but not through mvpmxc2 on the egreat. If I highlight the DVD folder on NextPVR on the egreat, it'll play the first iso only.
    Regards,
    Hasso

    Server: NPVR 2.2.6, Asus E35M1-M PRO motherboard, 2 x 2GB DDR-1333 memory, 1 x 1.5TB SATA Samsung HD, 2 x 2TB SATA Seagate Green HD, 1 x Hauppauge HD4400, 2 x Hauppauge Nova T 500, Windows 7 Home.
    Clients: EGreat M34A with MVPMCX2; HDX1000 with MVPMCX2 and internal 2TB SATA Seagate Green HD.

  4. #14
    Join Date
    May 2006
    Location
    Canada
    Posts
    21,281
    Quote Originally Posted by hasso View Post
    Martin,
    Sorry, I'm a bit confused.

    So you are saying that the only way I can play iso files through NextPVR on mvpmcx2 is to have each and every one in their own folder?
    Until you can convince sub to fix this, yes.

    Martin

  5. #15
    Join Date
    Dec 2004
    Location
    Wellington, New Zealand
    Posts
    461
    OK. thanks, Martin for your quick response.
    Regards,
    Hasso

    Server: NPVR 2.2.6, Asus E35M1-M PRO motherboard, 2 x 2GB DDR-1333 memory, 1 x 1.5TB SATA Samsung HD, 2 x 2TB SATA Seagate Green HD, 1 x Hauppauge HD4400, 2 x Hauppauge Nova T 500, Windows 7 Home.
    Clients: EGreat M34A with MVPMCX2; HDX1000 with MVPMCX2 and internal 2TB SATA Seagate Green HD.

  6. #16
    Join Date
    Dec 2004
    Location
    Wellington, New Zealand
    Posts
    461
    Martin,
    I know I'm probably flogging a dead horse when it comes to playing iso files through mvpmxc2 but one last question if you don't mind...
    So I've created a folder which contains one iso file. On the egreat this works great. When I press play on the folder through mvpmxc2 on the HDX1000, though, it briefly goes to a blue-green-red rectangular image background in the top left quarter of the screen with 'sigmadesign' in small print, and then just returns to the previous NextPVR mvpmxc2 screen. Any ideas?
    Regards,
    Hasso

    Server: NPVR 2.2.6, Asus E35M1-M PRO motherboard, 2 x 2GB DDR-1333 memory, 1 x 1.5TB SATA Samsung HD, 2 x 2TB SATA Seagate Green HD, 1 x Hauppauge HD4400, 2 x Hauppauge Nova T 500, Windows 7 Home.
    Clients: EGreat M34A with MVPMCX2; HDX1000 with MVPMCX2 and internal 2TB SATA Seagate Green HD.

  7. #17
    Join Date
    May 2006
    Location
    Canada
    Posts
    21,281
    Playing iso files should be fine through mvpmcx2. Upload your logs and I will have a look. It probably is a mapping issue.

    Martin

  8. #18
    Join Date
    Dec 2004
    Location
    Wellington, New Zealand
    Posts
    461
    I tried plating crash.iso. The only possibly rlevent logs I could find was the MVP.log...
    2011-09-14 20:24:08.847 [DEBUG][3] PlaybackPositionHelper.GetLastPlaybackDate(\\HDX10 00\dvd\Crash\Crash.iso)
    2011-09-14 20:24:08.872 [DEBUG][13] CheckCache() indicates:\\HDX1000\dvd\Crash\Crash.jpg is not cached.
    2011-09-14 20:24:08.947 [DEBUG][13] Loading disk file: \\HDX1000\dvd\Crash\Crash.jpg:204,210:True (and cached to C:\Users\Public\NPVR\Thumbs\D4D3FD40C6F08E88C8961F 711FBCD8E7.jpg)
    2011-09-14 20:24:08.970 [DEBUG][13] CheckCache() indicates:\\HDX1000\dvd\Crash\Crash.jpg:204,210:Tr ue is cached (C:\Users\Public\NPVR\Thumbs\D4D3FD40C6F08E88C8961 F711FBCD8E7.jpg)
    2011-09-14 20:24:08.974 [DEBUG][13] Loading cached file: \\HDX1000\dvd\Crash\Crash.jpg:204,210:True (C:\Users\Public\NPVR\Thumbs\D4D3FD40C6F08E88C8961 F711FBCD8E7.jpg)
    2011-09-14 20:24:09.569 [DEBUG][3] MVP frame sent
    2011-09-14 20:24:09.569 [DEBUG][3] MVP request processed
    2011-09-14 20:24:09.569 [DEBUG][3] MVP waiting for data
    2011-09-14 20:24:09.759 [DEBUG][3] Sending incremental screen updates to PCH
    2011-09-14 20:24:09.759 [DEBUG][3] clearing (16, 339, 1192, 234)
    2011-09-14 20:24:09.949 [DEBUG][3] updating (736, 339, 232, 234)
    2011-09-14 20:24:09.989 [DEBUG][3] updating (0, 584, 1224, 30)
    2011-09-14 20:24:10.009 [DEBUG][3] MVP data read: 1 (3)
    2011-09-14 20:24:10.009 [DEBUG][3] MVP request processed
    2011-09-14 20:24:10.009 [DEBUG][3] MVP waiting for data
    2011-09-14 20:24:10.076 [DEBUG][3] MVP data read: 1 (3)
    2011-09-14 20:24:10.076 [DEBUG][3] MVP request processed
    2011-09-14 20:24:10.076 [DEBUG][3] MVP waiting for data
    2011-09-14 20:24:10.281 [DEBUG][3] MVP data read: 1 (3)
    2011-09-14 20:24:10.281 [DEBUG][3] MVP request processed
    2011-09-14 20:24:10.281 [DEBUG][3] MVP waiting for data
    2011-09-14 20:24:10.281 [DEBUG][3] MVP data read: 1 (3)
    2011-09-14 20:24:10.281 [DEBUG][3] MVP request processed
    2011-09-14 20:24:10.281 [DEBUG][3] MVP waiting for data
    2011-09-14 20:24:12.901 [DEBUG][3] MVP data read: 1 (8)
    2011-09-14 20:24:12.901 [DEBUG][3] Responded to MVP ping
    2011-09-14 20:24:12.901 [DEBUG][3] MVP request processed
    2011-09-14 20:24:12.901 [DEBUG][3] MVP waiting for data
    2011-09-14 20:24:12.931 [DEBUG][3] MVP data read: 1 (3)
    2011-09-14 20:24:12.931 [DEBUG][3] MVP request processed
    2011-09-14 20:24:12.931 [DEBUG][3] MVP waiting for data
    2011-09-14 20:24:15.341 [DEBUG][3] MVP data read: 1 (4)
    2011-09-14 20:24:15.341 [DEBUG][3] User pressed: P
    2011-09-14 20:24:15.341 [DEBUG][3] PlaybackPositionHelper.GetLastPlaybackDate(\\HDX10 00\dvd\Crash\Crash.iso)
    2011-09-14 20:24:15.346 [DEBUG][3] Playing video file: \\HDX1000\dvd\Crash\Crash.iso
    2011-09-14 20:24:15.346 [DEBUG][3] StartVideoPlayback: \\HDX1000\dvd\Crash\Crash.iso
    2011-09-14 20:24:15.356 [DEBUG][3] Sent playback request
    2011-09-14 20:24:15.356 [DEBUG][3] Sent 'Hide OSD' request
    2011-09-14 20:24:15.396 [DEBUG][3] CheckCache() indicates:\\HDX1000\dvd\Crash\Crash.jpg is cached.
    2011-09-14 20:24:15.396 [DEBUG][3] CheckCache() indicates:\\HDX1000\dvd\Crash\Crash.jpg is cached.
    2011-09-14 20:24:15.401 [DEBUG][3] TV Listings: Got event PLAYING_VIDEO \\HDX1000\dvd\Crash\Crash.iso
    2011-09-14 20:24:15.401 [DEBUG][3] OnKeyDown() complete
    2011-09-14 20:24:15.401 [DEBUG][3] MVP request processed
    2011-09-14 20:24:15.401 [DEBUG][3] MVP waiting for data
    2011-09-14 20:24:15.401 [DEBUG][3] MVP data read: 1 (7)
    2011-09-14 20:24:15.401 [DEBUG][3] Got ACK
    2011-09-14 20:24:15.411 [DEBUG][7] Received: STREAM_REQUEST
    2011-09-14 20:24:15.411 [DEBUG][7] Requested file: System.Byte[] (\\HDX1000\dvd\Crash\Crash.iso)
    2011-09-14 20:24:15.411 [DEBUG][7] Playback on PCH
    2011-09-14 20:24:15.411 [DEBUG][7] RollingFile(\\HDX1000\dvd\Crash\Crash.iso)..
    2011-09-14 20:24:15.411 [DEBUG][7] SharedMemoryHelper::Open()
    2011-09-14 20:24:15.411 [DEBUG][7] Unable to find in 'Global', about to check 'Local'
    2011-09-14 20:24:15.411 [DEBUG][7] Unable to find in either 'Global' or 'Local'
    2011-09-14 20:24:15.416 [DEBUG][7] about to read 20032 from location 0 (current length = 4681293824)
    2011-09-14 20:24:15.441 [DEBUG][7] RollingFile.Seek(38)
    2011-09-14 20:24:15.441 [DEBUG][7] RollingFile.Seek(0)
    2011-09-14 20:24:15.441 [DEBUG][7] about to read 32000 from location 0 (current length = 4681293824)
    2011-09-14 20:24:15.476 [DEBUG][7] Received: STREAM_SEEK
    2011-09-14 20:24:15.476 [DEBUG][7] RollingFile.Position returning 32000
    2011-09-14 20:24:15.476 [DEBUG][7] Received request to seek to pos:32000
    2011-09-14 20:24:15.476 [DEBUG][7] RollingFile.Seek(32000)
    2011-09-14 20:24:15.476 [DEBUG][7] RollingFile.Position returning 32000
    2011-09-14 20:24:15.601 [DEBUG][3] MVP request processed
    2011-09-14 20:24:15.601 [DEBUG][3] MVP waiting for data
    2011-09-14 20:24:15.601 [DEBUG][3] MVP data read: 1 (3)
    2011-09-14 20:24:15.601 [DEBUG][3] MVP request processed
    2011-09-14 20:24:15.601 [DEBUG][3] MVP waiting for data
    2011-09-14 20:24:15.601 [DEBUG][3] MVP data read: 1 (7)
    2011-09-14 20:24:15.601 [DEBUG][3] Got ACK
    2011-09-14 20:24:15.601 [DEBUG][3] MVP request processed
    2011-09-14 20:24:15.601 [DEBUG][3] MVP waiting for data
    2011-09-14 20:24:15.601 [DEBUG][3] MVP data read: 1 (3)
    2011-09-14 20:24:15.601 [DEBUG][3] MVP request processed
    2011-09-14 20:24:15.601 [DEBUG][3] MVP waiting for data
    2011-09-14 20:24:15.601 [DEBUG][3] MVP data read: 1 (7)
    2011-09-14 20:24:15.601 [DEBUG][3] Got ACK
    2011-09-14 20:24:22.911 [DEBUG][3] MVP request processed
    2011-09-14 20:24:22.911 [DEBUG][3] MVP waiting for data
    2011-09-14 20:24:22.911 [DEBUG][3] MVP data read: 1 (8)
    2011-09-14 20:24:22.911 [DEBUG][3] Responded to MVP ping
    2011-09-14 20:24:22.911 [DEBUG][3] MVP request processed
    2011-09-14 20:24:22.911 [DEBUG][3] MVP waiting for data
    2011-09-14 20:24:32.951 [DEBUG][3] MVP data read: 1 (8)
    2011-09-14 20:24:32.951 [DEBUG][3] Responded to MVP ping
    2011-09-14 20:24:32.951 [DEBUG][3] MVP request processed
    2011-09-14 20:24:32.951 [DEBUG][3] MVP waiting for data
    2011-09-14 20:24:33.806 [DEBUG][7] Received: STREAM_STOP
    2011-09-14 20:24:33.806 [DEBUG][7] RollingFile.Close()
    2011-09-14 20:24:33.806 [DEBUG][7] Posting PLAYBACK_ENDED
    2011-09-14 20:24:33.821 [DEBUG][3] MVP data read: 1 (7)
    2011-09-14 20:24:33.821 [DEBUG][3] Got ACK
    2011-09-14 20:24:34.016 [DEBUG][3] MVP request processed
    2011-09-14 20:24:34.016 [DEBUG][3] MVP waiting for data
    2011-09-14 20:24:34.016 [DEBUG][3] Handling PLAYBACK_ENDED
    2011-09-14 20:24:34.016 [DEBUG][3] PLAYBACK_ENDED@1.0
    2011-09-14 20:24:34.016 [DEBUG][3] PLAYBACK_ENDED@1.1
    2011-09-14 20:24:34.016 [DEBUG][3] About to store playback position information
    2011-09-14 20:24:34.016 [DEBUG][3] PlaybackPositionHelper.StorePlaybackPosition(\\HDX 1000\dvd\Crash\Crash.iso, 0, 0)
    2011-09-14 20:24:34.076 [DEBUG][3] TV Listings: Got event PLAYBACK_STOPPED
    2011-09-14 20:24:34.076 [DEBUG][3] UiStatic.Dispose()
    2011-09-14 20:24:34.081 [DEBUG][3] PLAYBACK_ENDED@1.2
    2011-09-14 20:24:34.081 [DEBUG][3] Showing OSD
    2011-09-14 20:24:34.081 [DEBUG][3] trying to force complete refresh

    What other logs would be of help?
    Regards,
    Hasso

    Server: NPVR 2.2.6, Asus E35M1-M PRO motherboard, 2 x 2GB DDR-1333 memory, 1 x 1.5TB SATA Samsung HD, 2 x 2TB SATA Seagate Green HD, 1 x Hauppauge HD4400, 2 x Hauppauge Nova T 500, Windows 7 Home.
    Clients: EGreat M34A with MVPMCX2; HDX1000 with MVPMCX2 and internal 2TB SATA Seagate Green HD.

  9. #19
    Join Date
    May 2006
    Location
    Canada
    Posts
    21,281
    If you read my comment on the special handling of files on internal drive, I wasn't clear about the importance, but you must configure config.xml with the NMT's IP and not the name.

    Martin

  10. #20
    Join Date
    Dec 2004
    Location
    Wellington, New Zealand
    Posts
    461
    Quote Originally Posted by mvallevand View Post
    If you read my comment on the special handling of files on internal drive, I wasn't clear about the importance, but you must configure config.xml with the NMT's IP and not the name.

    Martin
    Appreciate your continued efforts to help, Martin. I have tried this before but when I change the NextPVR config.xml from
    <Directory name="HDX-1000 DVD">\\HDX1000\dvd</Directory>
    to
    <Directory name="HDX-1000 DVD">\\192.168.0.6\dvd</Directory>
    I get Directory Unavailable on both server and Egreat and HDX1000, so there must be something else I'm missing.

    Incidentally if I telnet to the HDX1000 and do the following commands, the HDX1000 through mvpmcx2 does play the iso file, but it is jerky, probably because the iso file is being served by the HDX1000 over the network and being consumed by the HDX1000 over the network... ie. the HDX1000 doesn't realise the file is local.:
    mkdir /mnt/\\\\HDX1000\\dvd
    mount -t cifs //192.168.0.6/dvd /mnt/\\\\HDX1000\\dvd -o username=nmt,password=1234,ro


    EDIT: Mounting the share on the server with \\192.168.06\dvd and supplying the username and password gets rid of the Directory Unavailable on the server, but not the clients.
    Last edited by hasso; 2011-09-14 at 08:24 PM.
    Regards,
    Hasso

    Server: NPVR 2.2.6, Asus E35M1-M PRO motherboard, 2 x 2GB DDR-1333 memory, 1 x 1.5TB SATA Samsung HD, 2 x 2TB SATA Seagate Green HD, 1 x Hauppauge HD4400, 2 x Hauppauge Nova T 500, Windows 7 Home.
    Clients: EGreat M34A with MVPMCX2; HDX1000 with MVPMCX2 and internal 2TB SATA Seagate Green HD.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •