Page 1 of 10 123 ... LastLast
Results 1 to 10 of 91

Thread: NPVR - VMR9 have wrong AR (WinXP)

  1. #1
    Join Date
    Feb 2009
    Location
    Czech Rep.
    Posts
    1,095

    NPVR - VMR 7/9 renderer have wrong AR + interlaced video not stretched to fullscreen

    Hi.
    Firstly thanks for new nPVR release!
    There is a problem with AR if VMR7/9 is in use, look on picture (problem was there in older nPVR too):

    This one it "fast shot" from LiveTV.
    It happend on all videos undepended on used decoder.

    It can be "fixed" by using EVR, but that will kill DxVA on WinXP, so it is useless.
    There is no such issue in GB-PVR or if i play video in Graphstudio.

    BTW, "capture screenshot" will be usefull feature

    EDIT:
    LOG
    Last edited by hoborg; 2010-12-29 at 06:57 PM.
    My projects:
    SAF6 (Standalone Filters)
    MCE standby tool addon
    My easy Amiga emulation
    HOBRing

    My HTPC

  2. #2
    Join Date
    Feb 2009
    Location
    Czech Rep.
    Posts
    1,095
    Log Added.

    BTW, in LOG i noticed "AC3Filter" entry:

    Code:
    2010-12-28 17:25:55.109	[DEBUG][1]	FindFilterByName failed to locate filter: AC3Filter
    Why nPVR looking for it? I newer have install it on my HTPC.
    My projects:
    SAF6 (Standalone Filters)
    MCE standby tool addon
    My easy Amiga emulation
    HOBRing

    My HTPC

  3. #3
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,336
    Quote Originally Posted by hoborg View Post
    Hi.
    Firstly thanks for new nPVR release!
    There is a problem with AR on WinXP system, look on picture (problem was there in older nPVR too):
    This one it "fast shot" from LiveTV.
    It happend on all videos undepended on used decoder.

    It can be "fixed" by using EVR, but that will kill DxVA on WinXP, so it is useless.
    There is no such issue in GB-PVR.

    BTW, "capture screenshot" will be usefull feature

    EDIT:
    LOG
    If you disable DXVA does the aspect ratio show correctly?

  4. #4
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,336
    Quote Originally Posted by hoborg View Post
    Log Added.

    BTW, in LOG i noticed "AC3Filter" entry:

    Code:
    2010-12-28 17:25:55.109	[DEBUG][1]	FindFilterByName failed to locate filter: AC3Filter
    Why nPVR looking for it? I newer have install it on my HTPC.
    Its just checks if the decoder is present in the user machine when you're in the Decoders screen. It doesnt use it in live tv or playback unless you've selected it as a decoder.

  5. #5
    Join Date
    Feb 2009
    Location
    Czech Rep.
    Posts
    1,095
    Quote Originally Posted by sub View Post
    If you disable DXVA does the aspect ratio show correctly?
    Hi SUB.
    This have nothing to do with DxVA. It happend on all sources - divx,xvid,mjpg,...
    My projects:
    SAF6 (Standalone Filters)
    MCE standby tool addon
    My easy Amiga emulation
    HOBRing

    My HTPC

  6. #6
    Join Date
    Feb 2009
    Location
    Czech Rep.
    Posts
    1,095
    BTW, similar AR issue can be reproduced if VMR9 renderer is used on Win7.
    My projects:
    SAF6 (Standalone Filters)
    MCE standby tool addon
    My easy Amiga emulation
    HOBRing

    My HTPC

  7. #7
    Join Date
    Feb 2009
    Location
    Czech Rep.
    Posts
    1,095
    Not sure if this can help, i am just looking for any diference:

    VMR9: (wrong AR)
    Code:
    2010-12-28 18:15:46.820	[DEBUG][1]	Adding VMR9 renderer
    2010-12-28 18:15:47.054	[DEBUG][1]	Source Aspect Ratio: 4x3
    2010-12-28 18:15:47.054	[DEBUG][1]	Setting display rect: 1.308252,-0.000000,-0.308252,1.000000
    2010-12-28 18:15:47.123	[DEBUG][1]	Graph filter list:
    2010-12-28 18:15:47.123	[DEBUG][1]	 - Default DirectSound Device
    2010-12-28 18:15:47.123	[DEBUG][1]	 - Video Mixing Renderer 9
    2010-12-28 18:15:47.123	[DEBUG][1]	 - ffdshow Audio Decoder
    2010-12-28 18:15:47.123	[DEBUG][1]	 - ffdshow Video Decoder
    2010-12-28 18:15:47.123	[DEBUG][1]	 - D:\_DVD\svatba\01-holicky.mpg
    EVR: (good AR)
    Code:
    2010-12-28 18:18:29.653	[DEBUG][1]	Adding EVR renderer
    2010-12-28 18:18:29.883	[DEBUG][1]	Source Aspect Ratio: 4x3
    2010-12-28 18:18:29.884	[DEBUG][1]	Setting display rect: 0.084090,0.000000,0.915910,1.000000
    2010-12-28 18:18:29.900	[DEBUG][1]	Graph filter list:
    2010-12-28 18:18:29.900	[DEBUG][1]	 - Default DirectSound Device
    2010-12-28 18:18:29.900	[DEBUG][1]	 - EVR Renderer
    2010-12-28 18:18:29.900	[DEBUG][1]	 - ffdshow Audio Decoder
    2010-12-28 18:18:29.900	[DEBUG][1]	 - ffdshow Video Decoder
    2010-12-28 18:18:29.900	[DEBUG][1]	 - D:\_DVD\svatba\01-holicky.mpg
    Does "Setting display rect:" set AR?
    My projects:
    SAF6 (Standalone Filters)
    MCE standby tool addon
    My easy Amiga emulation
    HOBRing

    My HTPC

  8. #8
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,336
    See if this helps.

  9. #9
    Join Date
    Aug 2007
    Location
    USA
    Posts
    329
    Quote Originally Posted by sub View Post
    See if this helps.
    Thank you so much for looking into this problem. For me on WinXP MCE, using the cyberlink mpeg decoder and the default ms demultiplexer 16x9 is displayed as 4x3. However, if you let directshow default using

    <ForceMpgGraph>false</ForceMpgGraph>

    the aspect ratio is correct. (my test was a .mpg file)

    I'll try a few other decoders and report back.

  10. #10
    Join Date
    Feb 2009
    Location
    Czech Rep.
    Posts
    1,095
    Quote Originally Posted by sub View Post
    See if this helps.
    SUB, thans you for looking on this issue.
    Your new Unmanaged.dll helps, but not fully.

    Now all seems to be OK except interlaced files (*.MPG, *.TS, LiveTV) - here the problem remain.

    So it looks like it is related to interlaced media.

    EDIT:
    I found another file with the same issue, this time it is *.m2ts - interlaced AVC: - this confirm it affect interlaced videos only.
    Code:
    Video
    ID                               : 4113 (0x1011)
    Menu ID                          : 1 (0x1)
    Format                           : AVC
    Format/Info                      : Advanced Video Codec
    Format profile                   : High@L4.0
    Format settings, CABAC           : Yes
    Format settings, ReFrames        : 2 frames
    Format settings, GOP             : M=1, N=26
    Codec ID                         : 27
    Duration                         : 6s 680ms
    Bit rate mode                    : Variable
    Bit rate                         : 7 133 Kbps
    Maximum bit rate                 : 16.0 Mbps
    Width                            : 1 440 pixels
    Height                           : 1 080 pixels
    Display aspect ratio             : 16:9
    Frame rate                       : 25.000 fps
    Color space                      : YUV
    Chroma subsampling               : 4:2:0
    Bit depth                        : 8 bits
    Scan type                        : Interlaced
    Scan order                       : Top Field First
    Bits/(Pixel*Frame)               : 0.183
    Stream size                      : 5.68 MiB (92%)
    Last edited by hoborg; 2010-12-28 at 07:15 PM.
    My projects:
    SAF6 (Standalone Filters)
    MCE standby tool addon
    My easy Amiga emulation
    HOBRing

    My HTPC

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •