Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 34

Thread: Cannot get drag and drop favourites to work

  1. #11
    Join Date
    Sep 2005
    Location
    UK
    Posts
    4,451
    Quote Originally Posted by mvallevand View Post
    The second option is being used today using edcast http://www.oddsock.org/tools/edcast/ to stream to the NMT. If you'd like, once 1.5 is out I'll create a library that can do this generically.
    Yes, I would like

  2. #12
    Join Date
    Mar 2006
    Location
    Sweden
    Posts
    604
    Quote Originally Posted by McBainUK View Post
    Could you attach one of the URL shortcuts so I can try here? It might be something different in the URL file on different languages.
    Well I could, but I doubt that's a problem, as I have the same problem on a win 7 ult. with English locale.

    I added a couple of albums in gbpvr, just to get the favourites.xml populated.
    Then I started the exe and it is still empty. I had expected that the albums should be shown now.
    Are there some dependencies that you have in MusicSpot that I do miss. Another plugin, like MusicLibrary 2 or 3 maybe?
    GBPVR PC: Win7 ult x64 / Intel P Duo / 2 gb RAM / Asus Extreme Radeon HD3450 HDTV
    Video: Sony 40'' LCD TV
    Plugins: MovieWiz, MLpanel, Videos library, Music Spot, WebRadio - and skin: Community WS
    _____________________________________________
    XML is like kids. They start small and cute. Then they grow.

  3. #13
    Join Date
    Sep 2005
    Location
    UK
    Posts
    4,451
    Are there entries in the favourites.xml file now? Ihave a build ready with some config.exe logging - will post it on the wiki later today.

  4. #14
    Join Date
    Mar 2006
    Location
    Sweden
    Posts
    604
    Sorry to be unclear, yes there are entries in the xml-file.
    They show up nicely in the gbpvr as well.
    But when I tried to edit the xml-file to add a playlist of my own, it is not shown.

    The links that shows looks like: spotify:album:[Hash#]
    And my playlist that is invisible starts with: spotify:user:7ore:playlist:[Hash#]

    But just as I write the above I came to think of the windows 7 "feature" to save a working copy in "C:\Users\[user]\AppData\Local\VirtualStore\Program Files (x86)\Devnz\GBPVR\Plugins" folder. But MusicSpot do not show my playlist even if I remove that file first. The albums do show in gbpvr.

    The xml-format is the same no matter the play-list type, right?
    GBPVR PC: Win7 ult x64 / Intel P Duo / 2 gb RAM / Asus Extreme Radeon HD3450 HDTV
    Video: Sony 40'' LCD TV
    Plugins: MovieWiz, MLpanel, Videos library, Music Spot, WebRadio - and skin: Community WS
    _____________________________________________
    XML is like kids. They start small and cute. Then they grow.

  5. #15
    Join Date
    Sep 2005
    Location
    UK
    Posts
    4,451
    Quote Originally Posted by 7ore View Post
    The xml-format is the same no matter the play-list type, right?
    Yes. They are just URLs like any other file or internet shortcut.

    Can you get v0.3.4 from the wiki, reproduce the problem and then post the config.exe.log file.

  6. #16
    Join Date
    Sep 2004
    Location
    Stockholm, Sweden
    Posts
    680
    Quote Originally Posted by agerdin View Post
    Regarding adding favourites with the add functionality, I need to do some more testing since I dont think I did it correctly.
    I retested the add functionality and it works as expected. The only problem I have is to dragn'drop directly from Spotify, but I can live with that.

    \\Agerdin

  7. #17
    Join Date
    Mar 2006
    Location
    Sweden
    Posts
    604
    The icons are showing and the albums in the xml is loaded in this version.

    But playlists are considered as: "URL is an unsuported type. url='[InternetShortcut]"
    Last edited by 7ore; 2010-03-16 at 09:49 AM. Reason: removed log-file
    GBPVR PC: Win7 ult x64 / Intel P Duo / 2 gb RAM / Asus Extreme Radeon HD3450 HDTV
    Video: Sony 40'' LCD TV
    Plugins: MovieWiz, MLpanel, Videos library, Music Spot, WebRadio - and skin: Community WS
    _____________________________________________
    XML is like kids. They start small and cute. Then they grow.

  8. #18
    Join Date
    Sep 2005
    Location
    UK
    Posts
    4,451
    That is to be expected as there's currently no API support (with a free account at least) for getting the contents of a playlist.

  9. #19
    Join Date
    Mar 2006
    Location
    Sweden
    Posts
    604
    OK, thats good to know.
    I'll just have to try with a premium account then...

    Is there any point to add an artist as favourite in the GBpvr UI?
    They look the same to me as when I added an album.
    Only difference is an extra row in the xml.

    Ooh, By the way. Tha drag'n'drop didn't work in the test run I did when I posted the log.
    I used the Add button.
    GBPVR PC: Win7 ult x64 / Intel P Duo / 2 gb RAM / Asus Extreme Radeon HD3450 HDTV
    Video: Sony 40'' LCD TV
    Plugins: MovieWiz, MLpanel, Videos library, Music Spot, WebRadio - and skin: Community WS
    _____________________________________________
    XML is like kids. They start small and cute. Then they grow.

  10. #20
    Join Date
    Sep 2005
    Location
    UK
    Posts
    4,451
    Quote Originally Posted by 7ore View Post
    I'll just have to try with a premium account then...
    Note that the plugin doesn't support Spotify playlists regardless of the account type. My comment was related to the fact that at the moment the plugin targets free and premium accounts and so is restriceted to Spotify URLs and the public Metadata API.

    Quote Originally Posted by 7ore View Post
    Tha drag'n'drop didn't work in the test run I did when I posted the log.
    Where you able to drag n drop and it just didn't add anything or was the drag and drop disabled icon being shown?

    Quote Originally Posted by 7ore View Post
    Is there any point to add an artist as favourite in the GBpvr UI?
    No point. The Search Results popup shouldn't say it's been added if you try and add an Artist - will have to check this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •