Page 4 of 4 FirstFirst ... 234
Results 31 to 38 of 38

Thread: sTranscode - Transcoder and cutter for PC and PCH

  1. #31
    Join Date
    Mar 2005
    Location
    Wisconsin, USA
    Posts
    898
    Agerdin. Although I can't open your sample, I found the problem. It has to do with how the script interprets the comskip log file. I'm working on a fix.

  2. #32
    Join Date
    Mar 2005
    Location
    Wisconsin, USA
    Posts
    898
    Actually, since I can't view the sample, I need to know how it's formatted.

    From what I can gather from the logs, it's resolution is 576x720 and it's Aspect ratio is 16:9. Are there any horizontal or vertical bars (letterboxing or pillarboxing)?

  3. #33
    Join Date
    Sep 2004
    Location
    Stockholm, Sweden
    Posts
    678
    stattik,

    Sorry about the sample. I could have sworn I tried it before I sent it. Anyhow, picure below shows the information (using MediaInfo). There are usually no letterboxing or pillarboxing in my shows unless its a movie which are letterboxed. However, I see no need to change the resolution in any of my transcoding.

    \\Agerdin

  4. #34
    Join Date
    Mar 2005
    Location
    Wisconsin, USA
    Posts
    898
    Here's a fixed file. I assumed that there were no black bars. Let me know how it works.

  5. #35
    Join Date
    Sep 2004
    Location
    Stockholm, Sweden
    Posts
    678
    stattik, with one of the files I am now trying I am getting the following message:
    Code:
    23:15:57,46 Now Processing "E:\My Recordings\Harry Potter och den flammande b„garen\Harry Potter och den flammande b„garen_20101224_19002200.ts" 
    23:15:57,48 Commandline  "C:\Documents and Settings\All Users\Application Data\NPVR\Tools\sTranscode\_sTranscode.bat" "E:\My Recordings\Harry Potter och den flammande b„garen\Harry Potter och den flammande b„garen_20101224_19002200.ts" guided_transcode "   full_resolution=yes"  
    23:15:57,48 debug_commandline  _sTranscode.bat "E:\My Recordings\Harry Potter och den flammande b„garen\Harry Potter och den flammande b„garen_20101224_19002200.ts" guided_transcode "   full_resolution=yes"  
    	SET full_resolution=yes 
    ---------------- 
    23:15:57,50 Analyzing.... 
    ---------------- 
    	SET container_format=MPEG-TS
    	SET duration=03:02:49.684
    	SET video_width=720
    	SET video_height=576
    	SET aspect_ratio=1.778
    	SET frame_rate=25.000
    	SET standard=PAL
    	SET scan_type=Interlaced
    	SET scan_order=TFF
    	SET ID=640
    	SET audio_format=MPEG Audio
    	SET audio_bitrate=256000
    	SET audio_channels=2
    	SET audio_rate=48000
    	SET audio_language=sv
    	SET video_delay=-928
    --------
    
    ----Show Duration: 138.23min	Cut Duration: 44.55min	Total: 182.78min----
    NOTICE - EDLP file has wrapped PTS values.  Source file will be remuxed to perform cuts.
    final_avg_diff=
    	final_frames=207325 
    	source_duration=8293 seconds 
    ---------------- 
    23:17:18,17 Video Transcoding 
    ---------------- 
    23:17:18,31 ----Video Commandline pass1---- 
    start "sTranscode" /B /low /wait "C:\Documents and Settings\All Users\Application Data\NPVR\Tools\sTranscode\tools\mplayer\mencoder.exe"  -edl "E:\My Recordings\Harry Potter och den flammande b„garen\Harry Potter och den flammande b„garen_20101224_19002200-adjpts.edl"     -hr-edl-seek  -lavdopts threads=2 -ovc x264 -x264encopts crf=21:level_idc=40:frameref=4:mixed_refs:bframes=15:deblock=0,0:b_adapt:weight_b:b_pyramid=normal:direct_pred=auto:subq=6:trellis=0:partitions=p8x8,b8x8,i4x4,i8x8:8x8dct:me=hex:threads=auto:force-cfr:nopsnr  -oac pcm  -vf yadif=0,   -o "E:\My Recordings\Harry Potter och den flammande b„garen\Harry Potter och den flammande b„garen_20101224_19002200.avi" "E:\My Recordings\Harry Potter och den flammande b„garen\Harry Potter och den flammande b„garen_20101224_19002200-newpts.mpg"
    Any way I can modify to NOT have wrapped EDLP values?

    \\Agerdin

  6. #36
    Join Date
    Mar 2005
    Location
    Wisconsin, USA
    Posts
    898
    Quote Originally Posted by agerdin View Post
    stattik,

    Sorry about the sample. I could have sworn I tried it before I sent it. Anyhow, picure below shows the information (using MediaInfo). There are usually no letterboxing or pillarboxing in my shows unless its a movie which are letterboxed. However, I see no need to change the resolution in any of my transcoding.

    \\Agerdin
    If you have a larger size, I'd still like to add to my collection of files that use when testing out new features. I got the same medinfo output, I just couldn't view the file to look for black bars. Comskip stated that the file had an aspect ration of 1.33:1 which is technically correct however, the file was animorphic and mediainfo stated the aspect was 16:9. When you have a 1.33:1 aspect in a 16:9 frame it's typically pillarboxed and the script attempted to create a proper crop value. Because the source was animorphic, this was all wrong. ATSC broadcasts are never animorphic. Now when the script detects a PAL source and thinks it's pillarboxed, it doesn't try to crop.

  7. #37
    Join Date
    Mar 2005
    Location
    Wisconsin, USA
    Posts
    898
    Quote Originally Posted by agerdin View Post

    Any way I can modify to NOT have wrapped EDLP values?

    \\Agerdin
    The wrapped EDLP values are part of the source file. Unlike Mpeg recordings which start at 0, transport streams copy whatever timestamps the broadcaster is sending. After a values of about 95000 or so, the broadcaster will start back at zero so instead of the EDLP number increasing, they will wrap which will make mencoder skip all of the wrapped commercials. The only solution is to remux the file which the script does. It also runs comskip because the timestamps aren't always lined up but it will transpose your original comskip cuts when it's done. If you want to manually remux a file I've got a small script that you could drop a source file on.

  8. #38
    Join Date
    Jan 2007
    Location
    Oregon, USA
    Posts
    890
    _sTranscode.bat has this at line 106
    IF EXIST "%~dpn1.edlp" IF "%~x1" EQU ".ts" SET noskip=no

    When I manually run _sTranscode.bat it executes lines 110-112 because noskip=no because I do not have an EDLP file, only EDL and TXT files for my TS recording.
    Should line 107 read
    Code:
    IF EXIST "%~dpn1.edl" IF "%~x1" EQU ".ts" SET noskip=no
    and line 403
    Code:
    IF "%~x1" EQU ".ts" SET edl=-edl "%~dpn1.edl"
    With these 2 changes I got an MKV file, but the commercials weren't removed; log file is attached.
    Attached Files Attached Files
    Last edited by Wakalaka; 2013-01-23 at 03:28 PM.
    NPVR 3.2.9 o XBMC 13.1 o EventGhost 0.4.1.r1640 o SchedulesDirect o SAF 6.2.2

    Case: Apevia X-Qpack HTPC o Motherboard: Asus P8H67-MLE o CPU: Intel Core i3-2100 o RAM: 8 GB o OS: Win7 64-bit
    Tuner: HDHomeRun dual tuner o Amplified Leaf antenna o Remote: Microsoft MCE
    Hard drives: Western Digital 1 TB SATA2, Seagate 2 TB SATA2, Samsung 540 GB SATA2 o Input: Logitech USB keyboard & mouse
    Video: ATI Radeon 7750 o Monitor: Viewsonic 27" VX2703MH-LED, Vizio 47" LCD TV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •