Results 1 to 4 of 4

Thread: Weather2 crashes when put on a sub-menu

  1. #1
    Join Date
    Mar 2009
    Location
    Portugal
    Posts
    176

    Weather2 crashes when put on a sub-menu

    First of all, after finally getting it running, congrats on the work you've done on the plugin. I sure love the AccuWeather upgrade, and the easy search id function.

    Anyway, on to the problem. I spent the last hour scratching my head with this one...

    I hate cluttering the main menu, so I usually put non-media oriented plugins inside sub-menus (cinema listings, webcams, weather, etc). And after configuring Weather2, the next thing I did, was just that: put it in my "Serviços" (services in portuguese) sub-menu.

    Whenever I tried to open the plugin app I got a error window. From the pvrx2.exe-log (multiple instances of similar/equal error lines such as theses appear after my Enter command):
    2009-09-10 23:25:36.328 ERROR [1] Unexpected error: System.NullReferenceException: A referência de objecto não foi definida como uma instância de um objecto.
    em weather2.WeatherTask.needsRendering()
    em GBPVRX2.MenuTask.x0be92cb4e3ac1817.needsRendering( )
    em GBPVRX2.MenuTask.x9006c1ed9ccb79de.needsRendering( )
    em GBPVRX2.MenuTask.x9006c1ed9ccb79de.needsRendering( )
    em GBPVRX2.x0061b801bdf12d35.xdb012c437aec4a40(Boolea n xd23bf32f3b17e3be)
    em GBPVRX2.xb979ad394703258e.xfb409e85bd292293(String[] xf18a926310372520)
    I tried reinstalling wiz' dlls, changing the video renderer, the works. Nothing did the trick. In the end, what was causing all the fuss, was me putting it in a sub-menu. Put it in the root menu, and voilá, worked like a charm. Put it back in a sub-menu, error...

    I can upload some logs if you wish. Just say which ones you need.

  2. #2
    Join Date
    Nov 2006
    Location
    Pennsylvania, USA
    Posts
    809
    No need, I can get the error on my system as well.

    I will look into it.

  3. #3
    Join Date
    Nov 2006
    Location
    Pennsylvania, USA
    Posts
    809
    I found the problem, and it will be fixed in the next release.

    For now, you'll just have to keep it out of a sub-menu. Sorry.

  4. #4
    Join Date
    Mar 2009
    Location
    Portugal
    Posts
    176
    Quote Originally Posted by scb147 View Post
    I found the problem, and it will be fixed in the next release.
    For now, you'll just have to keep it out of a sub-menu. Sorry.
    No problem. It doesn't matter how much we try to cover our ground, the user always find THAT error we didn't thought of... LOL
    Anyway, glad you managed to fix it. I'll wait for the next release, and use it in the main menu for now. I just like to have them out of the way, to keep the scroolling to a minimum...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •