Page 1 of 17 12311 ... LastLast
Results 1 to 10 of 168

Thread: UltraXMLTV Enhancer Version 2 - rc1

  1. #1
    Join Date
    Feb 2006
    Location
    Calgary, Alberta, Canada
    Posts
    5,105

    UltraXMLTV Enhancer Version 2 - rc1

    Let's discuss UltraXMLTV Enhancer Release Candidate 1 here!
    Frank Z

    I used to ask 'why?' Now I just reinstall...
    ______________________________________________
    Author: ZTools: ZProcess, MVPServerChecker; UltraXMLTV Enhancer, Renamer, Manager;


  2. #2
    Join Date
    Feb 2006
    Location
    Calgary, Alberta, Canada
    Posts
    5,105
    Quote Originally Posted by LewE View Post
    I thought that because it seemed to move its position in the "Sub Title Tag" list on the right side of the page every time I click on its definition with the SAVE TAG button, that it was hard coded to put the tag in a particular position.

    I've attached the tag definitions file in case that helps you spot why this is happening to me.
    Actually I know why it is. I saw the problme. I have the choice of completely disallowing the tag from anywhere (Easiest) or a little bit of time to sort this out. I suspect the second choice is best, just need some time...

    Don't let me forget about it...
    Frank Z

    I used to ask 'why?' Now I just reinstall...
    ______________________________________________
    Author: ZTools: ZProcess, MVPServerChecker; UltraXMLTV Enhancer, Renamer, Manager;


  3. #3
    Join Date
    Feb 2006
    Location
    Calgary, Alberta, Canada
    Posts
    5,105
    Release: Enhancer: 2.0.3381.24676

    * Merge with with Master file improved

    * Logging tweaks

    * Ratings can go anywhere of the main available fields

    * SeasEpnum and EpOnScreen numbers corrected. SeasEpNum will supercede IF both tags are to be in the same field and date for both exist. If you have one tag in SubTitle and One in Description, they will both show.

    * Date Format tag has been added
    ** On Misc tab, chose a date format from the drop down list. If you wish to customize, (and you know the syntax) just edit the text in the drop down to suit, and ten to see the output, just click the Date sample label to the left...

    * Confirmed again, that Ultra will run from Recording Service NO interacting with desktop...

    To confirm: Star Ratings are a value of x out of the max value 'Stars'. For example, 4/5 4 out of 5 stars, and it's value will be stored in either the [[StarRating]] field (seems logical) or if the programme is a movie, in the Movie title... Currently those are your choices... You can disable this option on the Misc tab

    Movie Ratings are Ratings that are noted as their 'System' being MPAA. These ratings will show up as an extra Rating and if a Movie, in the title. You can disable this option on the Misc tab.

    If there are still unhandled situations of a tag being sent to a field for which I was not anticipating, you will probably see a '[TAG]' or nothing. Let me know what you wanted, and I'll see if I can do it...
    Frank Z

    I used to ask 'why?' Now I just reinstall...
    ______________________________________________
    Author: ZTools: ZProcess, MVPServerChecker; UltraXMLTV Enhancer, Renamer, Manager;


  4. #4
    Join Date
    Mar 2009
    Location
    New Mexico, USA
    Posts
    39
    In VMC (I know, I know . . .), the listings have a little icon that displays what shows are being broadcast in HD. So, apparently that information is being broadcast - does UltraXMLTV Enhancer (version 1 or 2) also pull in that HD flag?

  5. #5
    Join Date
    Feb 2006
    Location
    Calgary, Alberta, Canada
    Posts
    5,105
    Quote Originally Posted by jdabling View Post
    In VMC (I know, I know . . .), the listings have a little icon that displays what shows are being broadcast in HD. So, apparently that information is being broadcast - does UltraXMLTV Enhancer (version 1 or 2) also pull in that HD flag?
    If your area's listings has it, then Yes Ultra can read it out of your XMLTV file.

    There isn't any place to put it though, so I have it going into the Categories.
    http://gbpvr.com/pmwiki/pmwiki.php/U...traXMLTV2#toc1
    (Currently GB-PVR's TV Guide won't display a special field or graphic for HD...TV Listings (alternate Plugin) can...

    Typically the tag is sent as HDTV ,and on the Misc tab, I make it so you can choose whatever you want as a replacement. In my default case I shorten HDTV to HD, to make room for other stuff.
    Frank Z

    I used to ask 'why?' Now I just reinstall...
    ______________________________________________
    Author: ZTools: ZProcess, MVPServerChecker; UltraXMLTV Enhancer, Renamer, Manager;


  6. #6
    Join Date
    Oct 2006
    Location
    Holland
    Posts
    130
    simple question.

    Does it work for tvgids.nl the dutch channels?

    Tnx..

  7. #7
    Join Date
    Feb 2006
    Location
    Calgary, Alberta, Canada
    Posts
    5,105
    Quote Originally Posted by -=TJ=-Stefan View Post
    simple question.

    Does it work for tvgids.nl the dutch channels?

    Tnx..
    Don't know. It should. While developing, I worked with North American listings a lot. But I tried keeping everything pretty generic...

    However, for the web queries for the SeasEpNum, theTVdb.com is mostly English speaking shows. They do have some multilanguage support, but it's usually hit or miss.

    Everything else should work. If you have some trouble, you should send me a xmltv file and I can play with it...
    Frank Z

    I used to ask 'why?' Now I just reinstall...
    ______________________________________________
    Author: ZTools: ZProcess, MVPServerChecker; UltraXMLTV Enhancer, Renamer, Manager;


  8. #8
    Join Date
    Feb 2006
    Location
    Calgary, Alberta, Canada
    Posts
    5,105
    Quote Originally Posted by -=TJ=-Stefan View Post
    simple question.

    Does it work for tvgids.nl the dutch channels?

    Tnx..
    Actually I went through another sample file I had with tvgids.nl, and it really looks there's very little to process.

    I don't think Ultra will be much use, unless the tlisting source has gotten better...

    It can't make up data out of thin air...


    Code:
          <programme start="20080403074000 +0100" stop="20080403080000 +0100" channel="1.tvgids.nl">
                <title lang="nl">Goedemorgen Nederland</title>
                <desc lang="nl">Vervolg. Breedbeelduitzending</desc>
                <category lang="nl">Nieuws/actualiteiten</category>
          </programme>
          <programme start="20080403080000 +0100" stop="20080403081000 +0100" channel="1.tvgids.nl">
                <title lang="nl">NOS Journaal</title>
                <desc lang="nl">Breedbeelduitzending</desc>
                <category lang="nl">Nieuws/actualiteiten</category>
          </programme>
          <programme start="20080403081000 +0100" stop="20080403083000 +0100" channel="1.tvgids.nl">
                <title lang="nl">Goedemorgen Nederland</title>
                <desc lang="nl">Vervolg. Breedbeelduitzending</desc>
                <category lang="nl">Nieuws/actualiteiten</category>
          </programme>
    Frank Z

    I used to ask 'why?' Now I just reinstall...
    ______________________________________________
    Author: ZTools: ZProcess, MVPServerChecker; UltraXMLTV Enhancer, Renamer, Manager;


  9. #9
    Join Date
    Jan 2009
    Location
    Ontario, Canada
    Posts
    229
    Just a little thing I noticed...progress indicator does not seem to be updating/refreshing properly. The upper progress indicator is not moving or clearing.

  10. #10
    Join Date
    Feb 2006
    Location
    Calgary, Alberta, Canada
    Posts
    5,105
    Quote Originally Posted by TomR View Post
    Just a little thing I noticed...progress indicator does not seem to be updating/refreshing properly. The upper progress indicator is not moving or clearing.
    When you noticed that, did ultra fetch anything at all except prepare itself for enhancing?

    I have that progress bar doing a few things just before enhance, and I know that one or two of the routines don't actually bring the progress bat to 100%. It's suppose to zero shortly before Enhance begins. Looks like it's not...

    On another note, I discovered that Ultra looks quite differently when XP themes are activated (I always have them off) so I tweaked the program to look better with XP themes enabled...)

    So I'll check out your note before I release another cosmetic fix. Good news is that I haven't been tweaking the logic very much at all...

    I have got Ultra Post working I think...
    Frank Z

    I used to ask 'why?' Now I just reinstall...
    ______________________________________________
    Author: ZTools: ZProcess, MVPServerChecker; UltraXMLTV Enhancer, Renamer, Manager;


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •