Page 1 of 4 123 ... LastLast
Results 1 to 10 of 79

Thread: ExternalDisplay New Release - (MediaPortal MiniDisplay Port)

Hybrid View

  1. #1
    Join Date
    Nov 2006
    Location
    Australia - Sydney
    Posts
    248

    ExternalDisplay New Release - (MediaPortal MiniDisplay Port)

    It's been twelve months and one day since the last update was posted here. With the release of 1.3.11 and the new shutting down event, I finally got around to doing a little more work on this plugin.

    Also over the last twelve plus months, cybrmage has done significant work on this plugin for MediaPortal, including a substaintial rewrite of some sections and renamed it 'minidisplay', including better integration with the iMON software and spectrum analyser displays.

    Unfortunately, I have not been able to implement the Spectrum Analyser/VU Meter display the way I would like to, despite some researching. There are plenty of examples to get sound samples of a microphone input/line in, but I've not found any C# examples to grab samples of 'what you hear'. I've found some C++ examples that seem interesting to explore and pursue, but they use MFC, and Visual Studio Express doesn't include these files, and the Open Source OFC hasn't helped me either. So I've parked this problem for now and thought I just release what I have.

    There may not be any significant changes in this version that would cause users to choose to updrade, however, the more significant changes include:

    • shutdown should be improved with the new 'shutting down' event. Please not that release is note compatible with pre 1.3.11 as a result.
    • the LCDHype driver has been revised, and provides greater functionity with LCDHype drivers. I have not included the drivers here, in case there are licencing issues, but you can get them from other sources and put the driver into the externaldisplay\lcddrivers folder. I hope that this new driver remains compatible with the drivers users may currently be using.
    • font editors and icon editors in iMON
    • improved integration with the iMON remote control. Some users have reported difficulties in getting the iMON remote control working correctly in the past. Since my Hauppauge remote is intermittment (I put into a dehumdifying dry cabinet for a day of so, and it works again for a day or so!), I was forced to use the iMON remote, so this part of the code I know works for me. I had to add some additional code not included in MiniDisplay to get this working. (The original MediaPortal code wouldn't work for my system if iMON was already running, so if it is running and some initialisation fails, iMON is shut down, initialisation continues and then iMON is restarted so that the remote control works)
    • improved integration with iMON Frontview (it can be set to reload upon PVRX2 exit).
    • the intergration with Soundgraph hardware extends to searching for the drivers actually used by the iMON software based on the information in the registry.
    • better integrated support for all other SoundGraph devices - Antec, 3R systems
    • MatrixMX and MatrixGX Drivers are included


    The only risk is that something might have broken in the port, and since I do not have any other VFD/LCD displays, I am not able to test. I don't use all the options available in the setup panels and have not bothered testing them all. Some options are not implemented although not disabled (EQ is the obvious one). So you've been warned!!

    Nonetheless, if you are game,
    1. download the new version below
    2. make a backup of the xml configuration file in the plugins\ExternalDisplay folder if you have customised your message, and backup your LCDHype driver.
    3. uninstall the old ExternalDisplay via the uninstaller
    4. install the new version
    5. reinstall your backup xml file and LCDHype Driver.
    6. run the ExternalDisplay configuration


    As usual, please set debug logging for PVRX2, and extending logging in the ExternalDisplay configuration and post the logs for support. I'll do my best. I think I've just opened a can of worms with this post.

    RELEASE NOTES:
    Aug 1, 2009
    Bug Fix - Fix arithmentic overflow error for display type LCD2 (see this post)


    Mar 30 2009
    Bug Fix
    • Debug Form – internal volume monitor now working
    • RestartFrontView was always run, irrespective of options setting
    V0.2 Mar 22 2009
    Bug fixes
    • Fixed the installer to re-include CommonGBPVRUtilities.dll
    • Recording in progress/pending message broke in the Feb 09 version
    • iMon display type LCD2 wasn’t handled correctly (shutdown errors and no icons displayed)
    • Stray music icon when watching movies removed
    • Cancel button in setup form cancels

    Additions
    • #currentmodule set to the EventText when
    • EventType=”PluginActivated”. Message will ‘flash’ for five seconds
    V0.2 February 2009
    Extensive changes to drivers following great work by cybermage for ‘minidisplay’ at MediaPortal. This has required some changes to the interface with GBPVR
    Last edited by ralphy; 2009-08-02 at 11:11 AM. Reason: 2009-08-01 installer uploaded
    Silverstone GD01S-MXR (three dead rows of pixels in the LCD and defective remote control), Power: Zalman ZM460B-APS (blew up - can't remember what's there now); CPU: Pentium D 3.2 GHz with Asus V72 Cooler; MD: Asus P5LD2 Deluxe 2048MB,
    WDC WD10EADS 1TB Data, 320GB System, Asus EN9400GT Silent 512MB, Hauppauge HVR 1300,
    XP Home SP3, GB-PVR 2.0, ExternalDisplay v0.3

  2. #2
    Join Date
    May 2008
    Location
    Belgium
    Posts
    124
    1000x Thx!!!

    I've tested it very quickly with the v1.3.7
    and it works with my Antec Fusion Case (iMON v7.20).
    Had only one problem, and that is that pvrx2 does not shut down completely.
    Will upgrade to V1.3.11 tomorrow, I guess that will fix it.
    I'll also take a look into the LCDHype software and see if it provides a nice
    finishing touch sinds the iMON software isn't really all that.

    Only one minor question. What software/driver did you use on you iMON lcd?
    the iMON sofware or an alternative?

    Thx in advance,
    Nick

  3. #3
    Join Date
    Nov 2006
    Location
    Australia - Sydney
    Posts
    248
    Quote Originally Posted by kindt nick View Post
    1000x Thx!!!

    I've tested it very quickly with the v1.3.7 and it works with my Antec Fusion Case (iMON v7.20).
    Great to hear some positive feedback Nick - Thanks

    Quote Originally Posted by kindt nick View Post
    Had only one problem, and that is that pvrx2 does not shut down completely.
    Will upgrade to V1.3.11 tomorrow, I guess that will fix it.
    Yes, I am sure it will. This version is not compatible with pre 1.3.11 and WILL cause the problem you experience I'm afraid. I was having some problems with object disposed errors, and I wasn't sure if it was caused by having both the old shutdown method (which had other problems with the implementation) and the new event notification method (which is more reliable - I hope - particularly for hibernation). Due to the object disposed errors, I disabled the old shutdown method and made some other changes, and the problem seemed to disappear. I am afraid users pre 1.3.11 will need to use the older ExternalDisplay version 0.1 Feb 2008.

    Quote Originally Posted by kindt nick View Post
    I'll also take a look into the LCDHype software and see if it provides a nice finishing touch sinds the iMON software isn't really all that.
    I don't think the LCDHype drivers will add functionality. What nice finishing touch are you looking for?
    Quote Originally Posted by kindt nick View Post
    Only one minor question. What software/driver did you use on you iMON lcd?
    the iMON sofware or an alternative?
    SG_VFD.dll and SG_RC.dll in the soundgraph folder are used by this plugin. iMON.exe is not used by the plugin, although it will try to run this program for the remote control functionality.

    In the ExternalDisplayConfig, I use the Soundgraph iMON Integrated USB VFD/LCD driver.
    Silverstone GD01S-MXR (three dead rows of pixels in the LCD and defective remote control), Power: Zalman ZM460B-APS (blew up - can't remember what's there now); CPU: Pentium D 3.2 GHz with Asus V72 Cooler; MD: Asus P5LD2 Deluxe 2048MB,
    WDC WD10EADS 1TB Data, 320GB System, Asus EN9400GT Silent 512MB, Hauppauge HVR 1300,
    XP Home SP3, GB-PVR 2.0, ExternalDisplay v0.3

  4. #4
    Join Date
    May 2008
    Location
    Belgium
    Posts
    124
    Hi,

    As exprected,the shutting down problem is fixed by updating to 1.3.11.
    The reason why I asked which Imon version you use is because in the beginning Exteral Display and iMON where fighting. (I used an older version of iMON, V6, just for testing)
    Now I've updated to the 7.20 and they don't fight anymore.

    So whenever PVRX2 is started, Externaldisplay restarts iMON and disables Frontview.
    That works fine.
    But the "shutdown on exit"-function and "restart frontview after shutdown" do not work here with my lcd display.

    PS: the "Display option (only valid with LCD and LCD2)" also do not work, but hey, I don't care. I bought the antec fusion case last month and I'm guessing I hava a display with the latest firmware. I guess they changed some things. I already tried other software programs/test programs last month and nothing worked.
    This is the first stable prog that can display non-iMON information.
    But could you please tell me what software and version you have installed?
    iMON Vxx or something else?

    Thx, Nick

  5. #5
    Join Date
    Nov 2006
    Location
    Australia - Sydney
    Posts
    248
    Nick

    Quote Originally Posted by kindt nick View Post
    Exteral Display and iMON where fighting. (I used an older version of iMON, V6, just for testing)
    Now I've updated to the 7.20 and they don't fight anymore.
    Not sure exactly what you mean by 'fighting', but I believe some folks had problems with iMON running and getting the remote control working with ExternalDisplay v0.1. This version has more checking for iMON processes, and restarts them if necessary, so there is much better integration with the plugin and iMON.

    I run Silverstone version 6.01 iMON.


    Quote Originally Posted by kindt nick View Post
    But the "shutdown on exit"-function and "restart frontview after shutdown" do not work here with my lcd display.
    This surprises me. I use 'restart frontview after shutdown' and it works fine. If you want, please post logs and maybe this will help narrow down the problem.
    Quote Originally Posted by kindt nick View Post
    PS: the "Display option (only valid with LCD and LCD2)" also do not work
    I use the 'show top bar' and 'show bottom bar', and have tested the Large Icons - all work for me, so again, please post the logs if you'd like me to look at them.

    (I don't think the 'Display Contol Options' work with PVRX2 though - and as mentioned, I know the "Equalizer Options' aren't implemented in this port)

    Thanks for the feedback too.
    Silverstone GD01S-MXR (three dead rows of pixels in the LCD and defective remote control), Power: Zalman ZM460B-APS (blew up - can't remember what's there now); CPU: Pentium D 3.2 GHz with Asus V72 Cooler; MD: Asus P5LD2 Deluxe 2048MB,
    WDC WD10EADS 1TB Data, 320GB System, Asus EN9400GT Silent 512MB, Hauppauge HVR 1300,
    XP Home SP3, GB-PVR 2.0, ExternalDisplay v0.3

  6. #6
    Join Date
    Jan 2006
    Location
    germany
    Posts
    138

    Thumbs up

    Quote Originally Posted by ralphy View Post
    It's been twelve months and one day since the last update was posted here. With the release of 1.3.11 and the new shutting down event, I finally got around to doing a little more work on this plugin.
    Thanks ralphy !

    The new release works nicely with a clean install of 1.3.11 - noticed one minor bug though:
    I had to install 0.1, then uninstall 0.1 and finally install 0.2, otherwise ExternalDisplay Configuration would crash.

    Keep up the good work !

    iwan.
    GBPVR 1.3.11 · Loewe Xemix 5106 DVD Player Case · Noritake 20045 Series 4x20 VFD · Win XP HomePro
    AOpen i915GMm-HFS · Pentium Mobile 1.7 GHz · Pinnacle DVB-T · Matsushita SlimLime DVD · 160 GB 2.5" Fujitsu Hornet
    Plugins: Movie Wizard · External Display · TV Listings

  7. #7
    Join Date
    Nov 2006
    Location
    Australia - Sydney
    Posts
    248
    iwan,
    You won't happen to still have the ExternalDisplayConfig.exe.log files floating around to post would you? Not sure what file must be missing from the 0.2 installer yet.
    Silverstone GD01S-MXR (three dead rows of pixels in the LCD and defective remote control), Power: Zalman ZM460B-APS (blew up - can't remember what's there now); CPU: Pentium D 3.2 GHz with Asus V72 Cooler; MD: Asus P5LD2 Deluxe 2048MB,
    WDC WD10EADS 1TB Data, 320GB System, Asus EN9400GT Silent 512MB, Hauppauge HVR 1300,
    XP Home SP3, GB-PVR 2.0, ExternalDisplay v0.3

  8. #8
    Join Date
    Jan 2006
    Location
    germany
    Posts
    138
    Quote Originally Posted by ralphy View Post
    iwan,
    You won't happen to still have the ExternalDisplayConfig.exe.log files floating around to post would you? Not sure what file must be missing from the 0.2 installer yet.
    ralphy,

    Will have a look tonight when I'm back at my computer.
    GBPVR 1.3.11 · Loewe Xemix 5106 DVD Player Case · Noritake 20045 Series 4x20 VFD · Win XP HomePro
    AOpen i915GMm-HFS · Pentium Mobile 1.7 GHz · Pinnacle DVB-T · Matsushita SlimLime DVD · 160 GB 2.5" Fujitsu Hornet
    Plugins: Movie Wizard · External Display · TV Listings

  9. #9
    Join Date
    Jan 2006
    Location
    germany
    Posts
    138
    Quote Originally Posted by ralphy View Post
    iwan,
    You won't happen to still have the ExternalDisplayConfig.exe.log files floating around to post would you? Not sure what file must be missing from the 0.2 installer yet.
    Not sure whether this is helpful or not - please find logs attached.

    When playing around with External Display, I noticed two other issues:

    • My display doesn't get completely dark when exiting gbpvr, but rather siwtches to the lowest brightness level
    • Whatever the date format in config.xml might be (here DD. mmmm, I think), it gets displayed as e.g. march 1


    Anything that springs to your mind ?
    GBPVR 1.3.11 · Loewe Xemix 5106 DVD Player Case · Noritake 20045 Series 4x20 VFD · Win XP HomePro
    AOpen i915GMm-HFS · Pentium Mobile 1.7 GHz · Pinnacle DVB-T · Matsushita SlimLime DVD · 160 GB 2.5" Fujitsu Hornet
    Plugins: Movie Wizard · External Display · TV Listings

  10. #10
    Join Date
    May 2008
    Location
    Belgium
    Posts
    124
    Hi Ralphy,

    After intensive testing I can give you more info.

    It's just as if ExternalDisplay does not read "ExternalDisplay_iMONLCD.xml". I've tested this also by deleting the xml file and the behaviour is exactly the same.
    Like I said before, nothing of the Advanced, Display Options (Valid only with LCD/LCD2 displays) work.
    So I'm guessing it has something to do with this.
    I've also checked if ExternalDisplayconfig actually rewrites the xml files when changing an option.
    And it does that so that's not the problem.

    I also noticed that the "Cancel"-buttong in ExternalDisplayConfig does not work.
    Is this also a fact on you computer?

    These are my log files.

    =========================================
    I've checked when iMON is started and by which service with ProcessExplorer. This is the information I could retrieve;
    A. Startsituation (After PC startup or after GBPVR is shut down);
    ==> Parent process: explorer.exe(1236) or PVRX2(1844)
    ==> Startup time: 21:37:04 1/03/2009

    B. Started GBPVR:
    ==> Parent process: PVRX2(1844)
    ==> Startup time: 21:38:42 1/03/2009

    C. With or withou the "restart iMON on Exit"-feature enabled:
    ==> Parent process: PVRX2(1844)
    ==> Startup time: 21:38:42 1/03/2009

    so this is the proove that iMON does not get restarted when GVPR shuts down.
    It also makes no difference if I shut down GBPVR in the main menu, in the system tab of just press ALT+F4

    For now I do the following steps manualy;
    A. Shutdown GBPVR
    B. Double click the iMON manager system tray.
    C. Go to the General Frontview tab (it's slimmed down)
    D. Set the "startup display when iMON is started"-function to "auto."
    E. Kill iMON
    F. Restart iMON.
    Because I setted the "startup display when iMON is started"-function to "auto.
    Now you see the normal general tab. And also the display is shutdown when shutting down the HTPC.


    =========================================
    I've also tested different version of iMON.
    The following is a complete overview of all the steps I've taken to narrow down the problem:

    01. I've completely uninstalled GBPVR, Externaldisplay and iMON. cleaned up the "Devnz" directory and registry with Ccleaner.

    02. Installed GBPVR 1.3.11, Skinplugin 3.2 and iMON 6.01 (official software)
    ==> iMON system tray gives the following notification: "iMON H/W not connected"

    03. Uninstalled 6.01 and installed iMON 6.2 (Silverstone Edition)
    ==> The software connected to the display without problems.
    ==> This one has the "3th party software function

    04. installed Externaldisplay 0.2
    ==> ExternaldisplayConfig and PVRX2 crashed on startup.
    ==> logs are attached , something about FATAL UNHANDLER EXEPTION and CommonGBPVRUtilities. you can see it in the "PVRX2.exe-1.log"-text file.

    05. Uninstalled everything again. Cleaned up the "Devnz" directory and registry with Ccleaner

    06. Installed iMON 7.2 (official software), GPBVR 1.3.11, Skinplugin 3.2 and Externaldisplay 0.2
    ==> Again, ExternaldisplayConfig and PVRX2 crashed on startup.

    07. Then I did the same like iwan, installed 0.1 and finally install 0.2, but I installed it without uninstalling 0.1.
    ==> GBPVR was displayed correctly But, the "Restart Frontview on Exit" or the "Turn OFF display on Exit" also didn't work.
    ==> logs are attached.

    08. Uninstalled Externaldisplay 0.2 and manually deleted Interop.GIRDERLib.dll, SG_VFD.dll and WaveLibMixer.dll because the uninstalled doesn't perform these actions. Is this normal?

    09. Uninstalled iMON 7.2 and cleaned up the "logs"-directory.

    10. Installed iMON 6.2. (Silverstone Edition), activated the "3th party software"-function and installed Externaldisplay 0.2
    ==> Externaldisplay de-activated the "3th party software"-function. And sett, as usual, the "startup display when iMON is started"-function to "never".
    ==> when I started PVRX2, the display didn't start up.

    11. Then I sett the "startup display when iMON is started"-function to "auto."
    ==> the display immediately was started and when I started PVRX2, the GBPVR information was displayed to it.
    ==> Still when I shut down PVRX2, Frontview does nog get restarted.
    ==> Externaldisplay sett the "startup display when iMON is started"-function again to "Never".
    When set this feature again to auto, Frontview was restarted.
    However, the General Frontview tab in iMON manager was slimmed down.
    You could only change the "startup display when iMON is started"-feature.
    Normally you can also set the font, brightness etc...

    12. Killed iMON and restarted iMON manually. Now i got the complete (normal- General Frontview tab.
    And set the "startup display when iMON is started"-function again to "auto.
    Next I started PVRX2.
    ==> GBPVR display was correctly displayed, but when shutting down GBPVR, Frontview was not restarted, again. Turn OFF on exit also doesn't work.
    When checking the General Frontview tab, again it was slimmed down and "startup display when iMON is started"-function was set to "Never".

    I know, it's allot, but I hope you can find the problem.
    I find it strange that everything works on iwan HTPC and not on mine.

    Thx,
    Nick

    PS: this is my setup:
    - LCD iMON Firmware ver 0x3801.
    - All the dotnet updates are installed.
    - CCCP is installed
    - GBPVR v1.3.11
    - skinplugin 3.2
    - community skin 3.2
    - OS is a fresh windows xp pro
    Last edited by kindt nick; 2009-03-01 at 09:31 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •