Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Newbie to PCH

  1. #1
    Join Date
    Jul 2004
    Location
    Lincolnshire, UK
    Posts
    77

    Newbie to PCH

    Hi all,


    My setup is Server2003 running GBPVR 1.3.7. with 1 mvp.

    I've just received my new PCH A110, came in a lovely box
    Just hooked it upto my network and have already had some problems.
    I updated the firmware to the lastest version with no issues.

    1) I then used the network browser to connect to my nas box.
    Connects fine but it is very... slow. Infact when I play either music of video it comes to a grinding holt and I getting 'Buffering' this may take upto 2mins to get going. If I put the same file on a pen drive plays straight away.

    2) Then thought I will have a go at getting gbpvr to work. I ran the dummies install. All appeared to be good.
    Then started up the browser on PCH and tried to connect to my server.
    The message I get is "No content found on server" I think this is a password problem.

    Just to test a little more a downloaded the pch_script_samples to a pen drive. I tried to run these. I'm finding that I'm unable to get these linux scripts to run. I get the message " Request cannot be processed". I've played about with the scripts and it seems that I can't run the bash code.
    Is there something on the PCH that lets me run the code?

    Any help would be very greatfull. If anyone out there is using server 2003 please get incontact.

    Thanks again

    cidc
    AMD Athlon 64 X2 4200 Server 2003 3.25GB Ram
    GBPVR v1.3.11 - Nova T 500, Nova HD S2
    80GB EIDE System, 160GB EIDE Junk, 200GB EIDE Video, 320GB SATA Recorded_TV
    750GB NAS Mirrored Raid, 320GB NAS
    MVP D3a
    PCH A110

  2. #2
    Join Date
    May 2006
    Location
    Canada
    Posts
    20,825
    No content typically means that you don't the proper share permissions set. The default for both the Network Browser and the mvpmc share options requires that a Guest share is enabled for the mvpmc folder and all the contents.

    Martin

  3. #3
    Join Date
    Oct 2004
    Location
    The Big Easy
    Posts
    3,343
    I had the same problem but Martin beat me to it...the guest share was the key.
    I'm finding the learning curve of what's possible more steep than I expected. I'm not geek enough but I'm patient. The NMT forum is great but there's so much there, it takes a hibernation period to read thru it and it's an ever evolving piece which I kinda like.
    Not real sure how or if having Server 2003 will affect it negatively but I wouldn't think so.


    Paul
    Custom ASUS P8Z77 V-Deluxe, Core i7 3770k, 16 GB Memory-ASUS ENGTX560 DCII TOP/2DI/1GD5 GeForce GTX 560, H80i Cooler, 750W PS, CM HAF XM RC-922XM-KKN1 case,Corsair GS CSSD-F240GBGS-BK 2.5" 240GB SATA III SSD, InfiniTV4 & HDHomerun Tuners- running Windows 8 (and other goodies)
    #2--P877WS- Core i7 3770k, 16GB Memory-GeForce GTX 650Ti, SATA III SSD, H100i cooler, 750W PS, Windows 8.1

  4. #4
    Join Date
    May 2006
    Location
    Canada
    Posts
    20,825
    I had a thought, are selecting the rightmost icon to find the GB-PVR html file?

    Martin

  5. #5
    Join Date
    Jul 2004
    Location
    Lincolnshire, UK
    Posts
    77
    Thanks fro the replys

    I enter PCH > Network Browser > Workgroup > Victoria > mvpmc then the circle on the left hand side starts spinning - wait about 3 mins comes up with error "request cannot be processed"

    On the share i have guest enabled and also applied to the ntfs

    If i copy those files to a pen drive I can't seem to get them to run either.

    "I had a thought, are selecting the rightmost icon to find the GB-PVR html file?"

    I don't think i'm even at that point yet
    AMD Athlon 64 X2 4200 Server 2003 3.25GB Ram
    GBPVR v1.3.11 - Nova T 500, Nova HD S2
    80GB EIDE System, 160GB EIDE Junk, 200GB EIDE Video, 320GB SATA Recorded_TV
    750GB NAS Mirrored Raid, 320GB NAS
    MVP D3a
    PCH A110

  6. #6
    Join Date
    May 2006
    Location
    Canada
    Posts
    20,825
    This still sounds like problems with the guest share. You might try these

    - configure access using a username and password
    - disable 2k3 network encryption to allow guest to work
    - set up a guest share on your NAS

    Martin

  7. #7
    Join Date
    Jul 2004
    Location
    Lincolnshire, UK
    Posts
    77
    After reading some posts in the pch forums, I created a network share

    smb://192.168.200.1/tv

    folder was shared out with user pch and a password.

    This works fine.

    Applied same idea to the mvpmc folder and now can get the gbpvr.html to load.

    Followed instructions and changed startmeup file aswell and gbpvr.cgi

    I still get "Request can not be processed"

    Reading from another thread, I've tried a few things.

    I copied the below files to a usb drive and then ran the gbpvr.html

    gbpvr.html
    <html>
    <head>
    </head>
    <body bgcolor="blue">
    <font face="Verdana" size=3>
    <p>&nbsp;</p>
    <p>&nbsp;</p>
    <p>&nbsp;</p>
    <p>&nbsp;</p>
    <p>&nbsp;</p>
    <table align="center" bgcolor="white" border="2" cellpadding="30">
    <tr>
    <th align="center" valign="middle">
    <BR>
    <a href="http://localhost.drives:8883/USB_DRIVE_A-1/test.cgi">Test</a>
    </th>
    </tr>
    </table>
    </font>
    </body>
    </html>


    test.cgi

    #!/bin/sh

    echo "Content-Length: 11";
    echo "Content-type: text/html";
    echo "";

    echo 'hello world';
    exit 0;


    This also gives me the same error
    Should the above work?
    I'm expecting to see "hello world" on my tv
    AMD Athlon 64 X2 4200 Server 2003 3.25GB Ram
    GBPVR v1.3.11 - Nova T 500, Nova HD S2
    80GB EIDE System, 160GB EIDE Junk, 200GB EIDE Video, 320GB SATA Recorded_TV
    750GB NAS Mirrored Raid, 320GB NAS
    MVP D3a
    PCH A110

  8. #8
    Join Date
    May 2006
    Location
    Canada
    Posts
    20,825
    I don't debug user scripts but if you compress and upload gbpvr.cgi and startmeup and I will have a look.

    Martin

  9. #9
    Join Date
    Jul 2004
    Location
    Lincolnshire, UK
    Posts
    77
    Hi mvallevand,

    I've been away for a bit and have come back with a fresh head.

    I've shared out the mvpmc folder with a username as pch with full permissons.

    From the PCH, if i go to the share and run GB-PVR.html I get a window with 3 options. I use the 1st GB-PVR.

    I get a message " Request cannot be processed".

    I've attached my mvpmc folder and also logs.

    For testing reasons I was able to use another telnet.html
    I telneted onto the PCH and manually typed each of the lines in the GBPVR.cgi file. With this I know my share permissons are correct.

    Any other ideas or tests I can do?

    Thanks in advance.
    AMD Athlon 64 X2 4200 Server 2003 3.25GB Ram
    GBPVR v1.3.11 - Nova T 500, Nova HD S2
    80GB EIDE System, 160GB EIDE Junk, 200GB EIDE Video, 320GB SATA Recorded_TV
    750GB NAS Mirrored Raid, 320GB NAS
    MVP D3a
    PCH A110

  10. #10
    Join Date
    May 2006
    Location
    Canada
    Posts
    20,825
    What do you see on your PCH via telnet when you type this

    ls /opt/sybhttpd/localhost.drives/NETWORK_SHARE/

    Martin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •