Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: ML2 7.2 fails with GBPVR 1.2.13

  1. #1
    Join Date
    Jun 2006
    Location
    Maryland - USA
    Posts
    15

    ML2 7.2 fails with GBPVR 1.2.13

    After upgrading to V1.2.13, I am getting an error when I try to launch ML2. The text in the box is "Object reference not set to an instance of an object". If I click Continue, the screen behind the error window goes white with a rex X through the screen. Appears to be a place holder. The relevant log entries are:



    2008-06-05 20:56:08.921 ERROR [1] MusicLibrary2: Error rendering: The given key was not present in the dictionary.
    2008-06-05 20:56:08.921 ERROR [1] MusicLibrary2: Error rendering: at System.ThrowHelper.ThrowKeyNotFoundException()
    at System.Collections.Generic.SortedList`2.get_Item(T Key key)
    at PsycikProductions.MusicLibrary.MusicLibrary2.rende r(Boolean& requiresMoreRendering)
    2008-06-05 20:56:09.031 VERBOSE [1] ReturnToMainMenu()
    2008-06-05 20:56:09.031 VERBOSE [1] Music Library2 is currently active
    2008-06-05 20:56:09.031 VERBOSE [1] Music Library2.Deactivate() called
    2008-06-05 20:56:09.031 VERBOSE [1] MusicLibrary2: Deactivate called






    The deactivate is task manager killing the PVRX2 application. Any assistance would be appreciated. As a test, I removed GBPVR and installed v1.2.13 clean. I added ML2 and did the config. Same error.

    Thank you

  2. #2
    Join Date
    Sep 2005
    Location
    Lower Hutt, NZ
    Posts
    4,896
    Sounds like a skin error. ML2 being a legacy type plugin has it's skin in devnz\gbpvr\skin. And while it will copy it's skin there, it needs supporting files as well. 1.2.13 removes this skin directory. Theres a thread by me in the community announcements with a zip file with a basic skin directory. Apply this and you should be ok.

    The other thing it can sometimes be is there may need to be a MusicLibrary2 directory in the skin2 directory - this is somtimes used internally by gbpvr for verification of the skin.
    AMD FM1 x4 A8-3870 Llano, Gigabyte GA-A75-D3H, 4 Gb DDR3 Ram, Seagate 500 Gb, Seagate 1500 Gb, HVR3000 x 2 (DVB-S), Nova-T 500 (DVB-T), USB-Uirt, SPDIF -> Yamaha RX-V540, ATI HD6550 (OnBoard) > Samsung LA46A650 TV (HDMI), Harmony Remote 525
    Windows 7 Ultimate x64 SP1, NPVR 2.4.3, AC3Filter, 1 x Popcorn Hour A-100, 1 x AppleTV with Plex

  3. #3
    Join Date
    Jun 2006
    Location
    Maryland - USA
    Posts
    15
    Thanx. I'll try it tonight.

  4. #4
    Join Date
    Jun 2006
    Location
    Maryland - USA
    Posts
    15
    Worked like a champ. As always, I'm impressed by the level of support within this group. Thank you for you assistance.

  5. #5
    Join Date
    Nov 2007
    Location
    Philadelphia, PA USA
    Posts
    142
    Quote Originally Posted by psycik View Post
    Sounds like a skin error. ML2 being a legacy type plugin has it's skin in devnz\gbpvr\skin. And while it will copy it's skin there, it needs supporting files as well. 1.2.13 removes this skin directory. Theres a thread by me in the community announcements with a zip file with a basic skin directory. Apply this and you should be ok.

    The other thing it can sometimes be is there may need to be a MusicLibrary2 directory in the skin2 directory - this is somtimes used internally by gbpvr for verification of the skin.
    OK, I know we went through this before, but I am getting the same error. I used the patch to put in the devnz\gbpvr\skin folder, and made a MusicLibrary2 directory in skin2, and still get the error. Any other suggestions?

  6. #6
    Join Date
    Sep 2005
    Location
    Lower Hutt, NZ
    Posts
    4,896
    can you package up your logs directory and post them here and i'll have a look
    AMD FM1 x4 A8-3870 Llano, Gigabyte GA-A75-D3H, 4 Gb DDR3 Ram, Seagate 500 Gb, Seagate 1500 Gb, HVR3000 x 2 (DVB-S), Nova-T 500 (DVB-T), USB-Uirt, SPDIF -> Yamaha RX-V540, ATI HD6550 (OnBoard) > Samsung LA46A650 TV (HDMI), Harmony Remote 525
    Windows 7 Ultimate x64 SP1, NPVR 2.4.3, AC3Filter, 1 x Popcorn Hour A-100, 1 x AppleTV with Plex

  7. #7
    Join Date
    Nov 2007
    Location
    Philadelphia, PA USA
    Posts
    142
    Quote Originally Posted by psycik View Post
    can you package up your logs directory and post them here and i'll have a look
    Guess what? :ast night I said what the heck let me load Community Skin. (I was going to load one at a time as this was a whole new installation) and MusicLibrary2 just started working!! It works great. Something was missing even with the patch that Community Skin put in.
    Thanks for your help, and a great plugin! Now I need a plugin that does laundry! LOL

  8. #8
    Join Date
    Nov 2007
    Location
    Philadelphia, PA USA
    Posts
    142
    psycik, just tried an experiment with ML2. It works fine as long as I stick with Community skin, but I tried switching to the default blue skin and it did the same thing. Gave me the red x and locked up. Not a big deal to me, I like Community Skin, but thought you'd like the bug report. If you want me to check some things out let me know.

  9. #9
    Join Date
    Sep 2005
    Location
    Lower Hutt, NZ
    Posts
    4,896
    If you can post the logs with it on the blue skin, that would be useful..Hopefully I can see a skin error in there.
    AMD FM1 x4 A8-3870 Llano, Gigabyte GA-A75-D3H, 4 Gb DDR3 Ram, Seagate 500 Gb, Seagate 1500 Gb, HVR3000 x 2 (DVB-S), Nova-T 500 (DVB-T), USB-Uirt, SPDIF -> Yamaha RX-V540, ATI HD6550 (OnBoard) > Samsung LA46A650 TV (HDMI), Harmony Remote 525
    Windows 7 Ultimate x64 SP1, NPVR 2.4.3, AC3Filter, 1 x Popcorn Hour A-100, 1 x AppleTV with Plex

  10. #10
    Join Date
    Nov 2007
    Location
    Philadelphia, PA USA
    Posts
    142
    Quote Originally Posted by psycik View Post
    If you can post the logs with it on the blue skin, that would be useful..Hopefully I can see a skin error in there.
    Sorry, been a busy week. Today is rainy here, so I should have some time to play today, but later.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •