Page 1 of 13 12311 ... LastLast
Results 1 to 10 of 125

Thread: MusicLibrary2 - Version 7 Support thread.

  1. #1
    Join Date
    Sep 2005
    Location
    Lower Hutt, NZ
    Posts
    4,894

    MusicLibrary2 - Version 7 Support thread.

    Hi any support calls for version 7 in here please.

    Was a fairly major upgrade.

    Some of the things to check for.
    • Sometimes the Interfaces.Dll and possible the MusicLibraryCommon.dll may need to go into a Gbpvr\Plugins\Common directory (along with the tag readers used).
    • I'd recommend a rescan if coming from an older version as a lot of work was done with the album art, and so it should find more now.
    • If coming from the 6.7 version, you may need to stop the recording service to install and some DLLs may be in use.



    I was notified that if installing GBPVR 1.2.13 from a new install then you will need to create a skin2\skin\MusicLibrary2 and maybe a skin\skin\MusicLibrary2 - but you should already have this latter one.
    Last edited by psycik; 2008-05-28 at 12:21 AM.
    AMD FM1 x4 A8-3870 Llano, Gigabyte GA-A75-D3H, 4 Gb DDR3 Ram, Seagate 500 Gb, Seagate 1500 Gb, HVR3000 x 2 (DVB-S), Nova-T 500 (DVB-T), USB-Uirt, SPDIF -> Yamaha RX-V540, ATI HD6550 (OnBoard) > Samsung LA46A650 TV (HDMI), Harmony Remote 525
    Windows 7 Ultimate x64 SP1, NPVR 2.4.3, AC3Filter, 1 x Popcorn Hour A-100, 1 x AppleTV with Plex

  2. #2
    Join Date
    Dec 2006
    Location
    Cleona, PA, USA
    Posts
    712
    Not to clog this up, but I will try ASAP, THANKS psycik, know it's hard work, but I'm sure it's gonna pay off.
    Currently Running: 1.4.7
    HTPC:
    Motherboard: ASUS P5LD2 Mobo w/ 945P chipset / CPU: Intel P4 3.0GHz
    RAM: 3GB RAM / Video: ASUS Radeon X300SE 128Mb PCIx 16
    Tuner(s): ATI TV 650 Dual (PCIx)
    OS: Win XP Pro SP3


    Feeding:
    2 - Wired MVP

  3. #3
    Join Date
    Jan 2006
    Location
    nl
    Posts
    750

    Feature request

    Version 7.1 works fine here. Thanks

    For the next version I have a request. I would appreciate if you could add the 'Composer' to the properties screen. If possible you could position it between the lines 'Album' and 'Year'. I think that is the least disruptive place for people who do not use the composer tag.

  4. #4
    Join Date
    Nov 2007
    Location
    Philadelphia, PA USA
    Posts
    142
    Just tried 7.1 and it wouldn't work. I just copied the contents of the new Music Library2 folder into the Music Lib folder in GBPVR and no work. The interface.dll was in use, so I had to reboot to get rid of that, but it copied over. Nuked the library, then rescaned. Hit Music Library 2 from the PVR2 menu and it hung for a second, then went back to the menu. Do I need to update Community skin also?

  5. #5
    Join Date
    Jun 2004
    Location
    Scotland
    Posts
    611

    AlbumArt not showing

    Psycik,

    Just trying out latest version, which for some reason does not display any album art.

    I am using pvrx2 ver 1.2.9 and the community skin with the reflect theme

    so far I have only tested on the PC

    I have tried nuking the library and re-scanning and attach a screen shot showing that the database shows that the songs have album art

    Each folder contains a folder.jpg file

    If I go into the config application the radio button for showing either album art or visualisations never remain checked.

    Cant understand what is wrong as it was fine before upgrade

    the following is the musiclibrary section of the config.xml file

    <MusicLibrary>
    <RandomPeriod>60</RandomPeriod>
    <AutomaticRemoveDead>True</AutomaticRemoveDead>
    <ScanHour>5</ScanHour>
    <ScanDay>1</ScanDay>
    <RemoveThe>True</RemoveThe>
    <WhilePlaying>AlbumArt</WhilePlaying>
    <SortTrack>True</SortTrack>
    <PlayQueues>True</PlayQueues>
    <PlayListIndicator>True</PlayListIndicator>
    <RandomAction>New</RandomAction>
    <Layouts>Artist/Album~Album/Artist~Genre/Artist</Layouts>
    <DefaultPanels>Artist/Album</DefaultPanels>
    <LayoutState>True</LayoutState>
    <PlaybackPosition>True</PlaybackPosition>
    <AlwaysQuery>True</AlwaysQuery>
    <FastScanInterval>0</FastScanInterval>
    <JukeboxWaitTime>20</JukeboxWaitTime>
    <RandomAllAll>True</RandomAllAll>
    <VerboseX2Logging>False</VerboseX2Logging>
    <MLLogging>True</MLLogging>
    <AudioscrobblerPassword>
    </AudioscrobblerPassword>
    <AudioscrobblerUser>
    </AudioscrobblerUser>
    <Audioscrobbler>False</Audioscrobbler>
    <SkipFile>noindex.txt</SkipFile>
    <SkipRecursive>True</SkipRecursive>
    <NoAllAll>False</NoAllAll>
    <ExternalUpdater>False</ExternalUpdater>
    <DatabaseConnectionString>Data Source="C:\Program Files\devnz\gbpvr\MusicLibrary2.db3";Version=3;New =True;</DatabaseConnectionString>
    <DatabaseProviderFactory>System.Data.SQLite.SQLite Factory</DatabaseProviderFactory>
    <EXT>.MP3~.WMA~.OGG~.M4A</EXT>
    <LastScan>20080324</LastScan>
    <MLPlaylistDir>
    </MLPlaylistDir>
    <LoadPlaylistPrefix>LOAD_</LoadPlaylistPrefix>
    <PlaylistEXT>.M3U~.WPL</PlaylistEXT>
    </MusicLibrary>

    thanks for all your work on this

    Tkgafs

  6. #6
    Join Date
    Sep 2005
    Location
    Lower Hutt, NZ
    Posts
    4,894
    Prob skin related.. The only skin change I made was related to the album art...and I missed fatman_do releasing by about a day.

    Can you try blue skin and see if your album art shows up??
    AMD FM1 x4 A8-3870 Llano, Gigabyte GA-A75-D3H, 4 Gb DDR3 Ram, Seagate 500 Gb, Seagate 1500 Gb, HVR3000 x 2 (DVB-S), Nova-T 500 (DVB-T), USB-Uirt, SPDIF -> Yamaha RX-V540, ATI HD6550 (OnBoard) > Samsung LA46A650 TV (HDMI), Harmony Remote 525
    Windows 7 Ultimate x64 SP1, NPVR 2.4.3, AC3Filter, 1 x Popcorn Hour A-100, 1 x AppleTV with Plex

  7. #7
    Join Date
    Sep 2005
    Location
    Lower Hutt, NZ
    Posts
    4,894
    Quote Originally Posted by richardw456 View Post
    Just tried 7.1 and it wouldn't work. I just copied the contents of the new Music Library2 folder into the Music Lib folder in GBPVR and no work. The interface.dll was in use, so I had to reboot to get rid of that, but it copied over. Nuked the library, then rescaned. Hit Music Library 2 from the PVR2 menu and it hung for a second, then went back to the menu. Do I need to update Community skin also?
    Do update the in-use ML2 dlls, you normally have to stop the MusicLibrary updater service, and possibly stop the GBPVR recording Service.

    Then start them once you've updated the dlls.
    AMD FM1 x4 A8-3870 Llano, Gigabyte GA-A75-D3H, 4 Gb DDR3 Ram, Seagate 500 Gb, Seagate 1500 Gb, HVR3000 x 2 (DVB-S), Nova-T 500 (DVB-T), USB-Uirt, SPDIF -> Yamaha RX-V540, ATI HD6550 (OnBoard) > Samsung LA46A650 TV (HDMI), Harmony Remote 525
    Windows 7 Ultimate x64 SP1, NPVR 2.4.3, AC3Filter, 1 x Popcorn Hour A-100, 1 x AppleTV with Plex

  8. #8
    Join Date
    Jun 2004
    Location
    Scotland
    Posts
    611
    Quote Originally Posted by psycik View Post
    Prob skin related.. The only skin change I made was related to the album art...and I missed fatman_do releasing by about a day.

    Can you try blue skin and see if your album art shows up??
    Hi yes seems to be fine on blue skin,

    I'll have a poke about in the skin files, what exactly was the change

    tkgafs

  9. #9
    Join Date
    Sep 2005
    Location
    Lower Hutt, NZ
    Posts
    4,894
    In the release notes i mentioned the changes (have a look at the community announcement). Something like adding a @albumart tag to 2 composite images....That's about all..
    AMD FM1 x4 A8-3870 Llano, Gigabyte GA-A75-D3H, 4 Gb DDR3 Ram, Seagate 500 Gb, Seagate 1500 Gb, HVR3000 x 2 (DVB-S), Nova-T 500 (DVB-T), USB-Uirt, SPDIF -> Yamaha RX-V540, ATI HD6550 (OnBoard) > Samsung LA46A650 TV (HDMI), Harmony Remote 525
    Windows 7 Ultimate x64 SP1, NPVR 2.4.3, AC3Filter, 1 x Popcorn Hour A-100, 1 x AppleTV with Plex

  10. #10
    Join Date
    Nov 2007
    Location
    Philadelphia, PA USA
    Posts
    142
    Quote Originally Posted by psycik View Post
    Do update the in-use ML2 dlls, you normally have to stop the MusicLibrary updater service, and possibly stop the GBPVR recording Service.

    Then start them once you've updated the dlls.
    I did that, but I could try again. I think the first time I forgot to update the skin. I tried taking out Music Library 2 completly and reinstalling. I copied the Music folder into the plugin folder, updated the blue skin, and restarted everything. I got the fatal exception error (which is a pain, I loose the pointer and have to shut down PVR2 from the Task Manager), so how would I install from scratch with Ver 7.1 (just for fun). I am back to 6.5, which I can install due to the installer. Oh, how do you stop the MusicLibrary updater? I have been rebooting to free up the DLL's.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •