Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Unable to FF/FRWD

  1. #1
    Join Date
    May 2007
    Location
    UK
    Posts
    23

    Unable to FF/FRWD

    I've got GBPVR working fairly well but I can't seem to get FF/RWD working on recorded programmes.

    It's a bit of a pain, having to watch the whole programme again after accidentally right clicking 5 minutes before the end :-)

    The ability to type in a percentage (how I tend to use the PVR attached to my TV) would be just as good.

    Any ideas?

    Tim

  2. #2
    Join Date
    Oct 2004
    Location
    Sweden
    Posts
    3,129
    Welcome to the forum

    FF/RWD tend to be "buggy" with most decoders. Try using skip instead. If you do, then you can set in configure how much to skip for each press. I think default is 1 minute ahead and 30 seconds back. If you press "4" and skip forward, then gbpvr will skip 4 minutes ahead.

    If FF/RWD gives you problem, it's recommended you set, in config, "use short skip" instead of FF/RWD (I can't remember the exact phrasing right now).
    I'm not always right
    GB-PVR 1.2.9
    Accent HT-400 Case, AMD Athlon 64 3800+ 1024MB, 1TB+300GB+180GB, WinXP Pro-SP2, NVidia 7600GT
    Nova-T USB2, PVR-350 recording from Dilog 355 DVB-T box, USB-UIRT (receiving & transmitting)

  3. #3
    Join Date
    May 2007
    Location
    UK
    Posts
    23

    or alternatively .... Skip doesn't work

    You know that feeling when you seem to have solved a problem but then ....

    OK, for some reason the 'use skip instead of FF' was already set (I must have been playing and forgotten). Unset that and FF works (well, sort of) but it kills the sound.

    So, may I rephrase my question as 'Skip doesn't appear to work'?

    Thanks for the fast response.

  4. #4
    Join Date
    Oct 2004
    Location
    Sweden
    Posts
    3,129
    To beat sub to the answer: reproduce the problem, then zip and attach your logs
    I'm not always right
    GB-PVR 1.2.9
    Accent HT-400 Case, AMD Athlon 64 3800+ 1024MB, 1TB+300GB+180GB, WinXP Pro-SP2, NVidia 7600GT
    Nova-T USB2, PVR-350 recording from Dilog 355 DVB-T box, USB-UIRT (receiving & transmitting)

  5. #5
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,413
    Do you have a PVR150 capture card? If so, then its probably the PVR150 time stamp bug: http://forums.gbpvr.com/showthread.php?t=14006

  6. #6
    Join Date
    May 2007
    Location
    UK
    Posts
    23
    It's a Nova-T-500 rather than a 150.

    The concept of reproducing an error which consists of nothing happening is quite an interesting idea. A bit along the lines of 'when did you stop beating your wife' :-)

    OK, having got the philosophy out of the way ....

    I stopped the programme and closed down the recording service to close anything running.

    Restarted the programme, select Recordings, picked one, started it playing, pressed <Ctrl><F> (nothing happened) then <Ctrl><Right Arrow> (likewise) and closed the programme down.

    Two log files were modfied GBPVR.exe-native.log & GBPVR.exe.log

    Tim

    GBPVR.exe.log
    --------------
    2007-05-25 06:35:14.753 VERBOSE [1] installDirectory is K:\Program Files\devnz\gbpvr\
    2007-05-25 06:35:14.753 VERBOSE [1] configurationFile is K:\Program Files\devnz\gbpvr\config.xml
    2007-05-25 06:35:14.769 VERBOSE [1] getValue() loading new key/value into cache: /settings/DatabaseConnectionString
    2007-05-25 06:35:14.769 VERBOSE [1] getValue: /settings/DatabaseConnectionString : Data Source=".\gbpvr.db3";Version=3;New=True;
    2007-05-25 06:35:14.769 VERBOSE [1] getValue() loading new key/value into cache: /settings/DatabaseIdentityQuery
    2007-05-25 06:35:14.769 VERBOSE [1] getValue: /settings/DatabaseIdentityQuery : select last_insert_rowid()
    2007-05-25 06:35:14.769 VERBOSE [1] databaseConnectionString is Data Source="K:\Program Files\devnz\gbpvr\\gbpvr.db3";Version=3;New=True;
    2007-05-25 06:35:14.769 VERBOSE [1] getValue() loading new key/value into cache: /settings/DatabaseProviderFactory
    2007-05-25 06:35:14.769 VERBOSE [1] getValue: /settings/DatabaseProviderFactory : System.Data.SQLite.SQLiteFactory
    2007-05-25 06:35:14.769 VERBOSE [1] ...using System.Data.SQLite.SQLiteFactory DB Provider Factory
    2007-05-25 06:35:14.769 VERBOSE [1] getValue() loading new key/value into cache: /settings/LoggingLevel
    2007-05-25 06:35:14.769 VERBOSE [1] getValue: /settings/LoggingLevel : Info
    2007-05-25 06:35:14.785 INFO [1] Starting
    2007-05-25 06:35:18.503 ERROR [1] Unable to find node: /settings/SpecialElements/SpecialElement[@name="ForegroundTransparency"]
    2007-05-25 06:35:18.519 ERROR [1] Unable to find node: /settings/SpecialElements/SpecialElement[@name="MenuType"]
    2007-05-25 06:35:19.019 INFO [1] Initializing InputDeviceManager
    2007-05-25 06:35:20.034 ERROR [1] Unable to find node: /settings/SpecialElements/SpecialElement[@name="MenuType"]
    2007-05-25 06:35:24.238 ERROR [1] Unable to find node: /settings/SpecialElements/SpecialElement[@name="ForegroundTransparency"]
    2007-05-25 06:35:32.097 INFO [1] playFile(Scrapheap Challenge, S:\Recordings\Scrapheap Challenge\Scrapheap Challenge_20070520_17451845.dvr-ms)
    2007-05-25 06:35:46.565 INFO [1] NetRadio buffer size is: 96000


    GBPVR.exe-native.log
    --------------------

    2007-05-25 18:35:15.363 INFO Log started
    2007-05-25 18:35:15.363 VERBOSE getSetting(ShowClosedCaptions)
    2007-05-25 18:35:15.363 VERBOSE getSetting(UseFFDSHOW)
    2007-05-25 18:35:15.363 VERBOSE getSetting(TvShape)
    2007-05-25 18:35:15.363 VERBOSE getSetting(EnableTeleText)
    2007-05-25 18:35:15.363 VERBOSE TeleText enabled
    2007-05-25 18:35:15.363 VERBOSE getSetting(ForcedGraphTeardown)
    2007-05-25 18:35:15.363 VERBOSE getSetting(HorizontalZoom)
    2007-05-25 18:35:15.363 VERBOSE Horizontal Zoom: 1.050000
    2007-05-25 18:35:15.363 VERBOSE getSetting(VerticalZoom)
    2007-05-25 18:35:15.363 VERBOSE Vertical Zoom: 1.030000
    2007-05-25 18:35:15.363 VERBOSE getSetting(HorizontalOffset)
    2007-05-25 18:35:15.363 VERBOSE Horizontal Offset: 0
    2007-05-25 18:35:15.363 VERBOSE getSetting(VerticalOffset)
    2007-05-25 18:35:15.363 VERBOSE Vertical Offset: 0
    2007-05-25 18:35:15.363 VERBOSE getSetting(LiveTVPrePlayDelay)
    2007-05-25 18:35:15.363 VERBOSE getSetting(OSDTransparency)
    2007-05-25 18:35:15.363 VERBOSE MinimumFilePlaySize=200000
    2007-05-25 18:35:15.488 VERBOSE DirectShowPlayerVMR9() initialising...
    2007-05-25 18:35:15.488 VERBOSE getSetting(OSDTransparency)
    2007-05-25 18:35:32.394 INFO DirectShowPlayerBase:layVideoFile(S:\Recordings\Scrapheap Challenge\Scrapheap Challenge_20070520_17451845.dvr-ms)
    2007-05-25 18:35:32.394 VERBOSE getSetting(QuickFileChangeWithDVRMS)
    2007-05-25 18:35:32.394 VERBOSE Creating new graph
    2007-05-25 18:35:32.472 VERBOSE getSetting(PreferredAudioRenderer)
    2007-05-25 18:35:32.503 VERBOSE getSetting(TvShape)
    2007-05-25 18:35:32.503 VERBOSE getSetting(VMRPreferYUVMixing)
    2007-05-25 18:35:32.503 VERBOSE getSetting(VMRWindowedMode)
    2007-05-25 18:35:32.503 VERBOSE getSetting(VMRDeinterlaceMode)
    2007-05-25 18:35:32.503 VERBOSE VMRDeinterlaceMode: other (deferred)
    2007-05-25 18:35:32.519 VERBOSE getSetting(DefaultFPS)
    2007-05-25 18:35:32.534 VERBOSE detected FPS as 25.000000
    2007-05-25 18:35:32.534 VERBOSE getSetting(PreferredAudioDecoder)
    2007-05-25 18:35:32.534 VERBOSE getSetting(PreferredDecoder)
    2007-05-25 18:35:32.534 VERBOSE getSetting(PreferredMpegPlaybackDemux)
    2007-05-25 18:35:36.550 VERBOSE getSetting(VMRDeinterlaceMode)
    2007-05-25 18:35:36.581 VERBOSE getSetting(ListGraphFilters)
    2007-05-25 18:35:36.581 VERBOSE Graph contains the following filters:
    2007-05-25 18:35:36.581 VERBOSE - Video Renderer 0005
    2007-05-25 18:35:36.581 VERBOSE - Default DirectSound Device
    2007-05-25 18:35:36.581 VERBOSE - Video Renderer
    2007-05-25 18:35:36.581 VERBOSE - Overlay Mixer2
    2007-05-25 18:35:36.581 VERBOSE - MPEG Audio Decoder
    2007-05-25 18:35:36.581 VERBOSE - InterVideo Video Decoder
    2007-05-25 18:35:36.581 VERBOSE - S:\Recordings\Scrapheap Challenge\Scrapheap Challenge_20070520_17451845.dvr-ms
    2007-05-25 18:35:36.581 VERBOSE getSetting(SaveGraphFiles)
    2007-05-25 18:35:36.862 VERBOSE setSourceAspectRatio() using autoAspectRatio
    2007-05-25 18:35:36.862 VERBOSE video resolution is 720 x 576
    2007-05-25 18:35:36.862 VERBOSE unknown source aspect ratio...showing full frame
    2007-05-25 18:35:36.878 INFO DirectShowPlayerBase:layFile() done
    2007-05-25 18:35:36.878 VERBOSE DirectShowPlayerBase::setPlaybackRate(1.000000)
    2007-05-25 18:35:36.878 VERBOSE Restoring audio
    2007-05-25 18:35:46.300 VERBOSE DirectShowPlayerBase::stop
    2007-05-25 18:35:46.300 VERBOSE DirectShowPlayerBase::stop@2 (skipping window positioning)
    2007-05-25 18:35:46.300 VERBOSE DirectShowPlayerBase::stop@3
    2007-05-25 18:35:46.472 VERBOSE DirectShowPlayerBase::stop@4
    2007-05-25 18:35:46.472 VERBOSE DirectShowPlayerBase::stop@5
    2007-05-25 18:35:46.472 VERBOSE DirectShowPlayerBase::stop@6
    2007-05-25 18:35:46.472 VERBOSE DirectShowPlayerBase::stop@7
    2007-05-25 18:35:46.472 VERBOSE DirectShowPlayerBase::stop@8
    2007-05-25 18:35:46.565 VERBOSE DirectShowPlayerBase::stop finished
    2007-05-25 18:35:46.565 VERBOSE DirectShowPlayerBase::stop
    2007-05-25 18:35:46.565 VERBOSE DirectShowPlayerBase::stop finished

  7. #7
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,413
    What mux and version are you using for recording?

  8. #8
    Join Date
    May 2007
    Location
    UK
    Posts
    23
    A jolly good question (for someone who does server support for a living I'm showing a horrible lack of knowledge about this aspect of computers :-) )

    Running the Mux checker I just found in the GBPVR programme group shows

    NO MULTIPLEXER FILTERS WHERE FOUND ON YOUR MACHINE.

    GB-PVR will not function correctly unless you have WinXP SP1 or higher, which has a built-in DVR-MS mux filter.

    I'm running XP SP1 if that's relevant.

    If I haven't given you the information you need a hint about how to find the information would be handy (using words of few syllables if possible, I really am a novice as far as this sort of thing is concerned).

    Tim

  9. #9
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,413
    Ah, yes - looking at your log snippet above I can see its using the dvr-ms mux. Didnt think to look there.

    Sorry, I'm not really sure what to suggest. There isnt really any tweakable settings. Usually this works pretty well.

  10. #10
    Join Date
    Jan 2005
    Location
    London
    Posts
    2,856
    the reason I DON'T use dvr-ms is because I cannot FF/RW when playing back via the web interface. I don;t know if this is related to your problem.

    I would recommend you try one of the cyberlink muxs (1307 is popular) available from

    http://forums.gbpvr.com/showthread.php?t=25630
    Silverstone LC17 Case,
    ASUS P5Q, Intel E7200, 4GB RAM
    Blackgold DVB-T2, ATI 7750, Windows 7 64-bit
    SAF codec pack,Sony 40" Z5500

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •