Results 1 to 7 of 7

Thread: Another smattering of issues

  1. #1
    Join Date
    Oct 2006
    Posts
    10

    Another smattering of issues

    I also love this plugin, especially the collections feature, which will allow me to organize by genre and subgenre. But I'm having a few problems... I'm running on XP and ripping with WMP 11.

    1. Tag issues:

    a. scattered tracks have "other" listed as the genre on the details panel, and the tracks are sorted by genre as other. I can't find any pattern. It's scattered across albums, artists, and genres. If I look at the track properties in XP the genre is listed correctly, and WMP and Real list it properly. The only workaround I've found is to delete the track from my hard drive, update the library, rerip the track, and hope it sorts properly. Sometimes it does, sometimes it doesn't. Seems to happen regardless of whether I edit the genre field in WMP or edit the properties in XP.

    b. The bitrate, size, and comment fields are blank in the details panel. If I hit the record button, bitrate and size appear, but the comment field remains blank. When I exit the detail panel and come back, bitrate and size are blank again.

    2. Screensaver:

    The screensaver freezes. It never happens when playing music, but happens randomly at other times. The time stops updating and the display stays in one place on the screen. Once it freezes, it doesn't start again; it's necessary to exit the screensaver by clicking a button. It seems to have something to do with processes running in the background. It happens when GBPVR is recording and when my virus scanner runs in the background. It happens at other times too, but I don't know if there's some process in the background that interferes.

    Also, is it possible to have the album title displayed on the screensaver as well as artist and song title? Many of my album covers don't have the album name. I really like the abulm art display, but would like the title as well.

    Thanks again for a wonderful plugin. Let me know if I can provide any other info that would help.

  2. #2
    Join Date
    Sep 2005
    Location
    Lower Hutt, NZ
    Posts
    4,910
    1, a, the other ways this can be solved if by looking at what ml2 is reading when scanning the tracks (or an individual track - the record button will re-read the tag). But before doing this turn on all the ml2 logging (seperate and insane)

    1, b, Yeah this is by design, when reading tracks generally there's no need for ml2 to care about the bitrate, and so it only does it when you hit that record button.

    2. I've noticed this as well, but don't know what triggers it. I've seen it happen when not rescording and not doing anything.

    I'll look at adding the album title in a later release. Not quite sure when the next release is (being the middle of summer here it's a bit nice to be inside on the weekends. ) so as it's starting to get darker earlier, I'll start getting back into programming mode.....
    Gigabyte AMD A8 Brix, 4 Gb DDR3 Ram, 120 Gb SSD, SiliconDust HDHomeRun Dual DVB-T, Samsung LA46A650 TV (HDMI), Harmony Remote 525
    Windows 8.1 Pro, NPVR 3.2.9, AC3Filter, 1 x AppleTV with Plex, Plex Plugin, NextPVR Channel for Plex

  3. #3
    Join Date
    Oct 2006
    Posts
    10
    1,a, I've attached my separate, insanely stupid log. I'm not sure what it's supposed to tell me, other than that it reads the genre as "other" when the track properties show it as "neoprogressive rock" or "ballet". Is the problem the way WMP is writing the tag or the way ML2 is reading it? Maybe I need to get a tag editor and edit the tags manually?

    1,b, I see that ML2 doesn't query the comment field even tho the details panel shows it. Is that in the works for a future release?

    Summer sounds nice. We have more than 2 feet of snow with more on the way, and temps well below freezing. This is the time of year when I hibernate inside with my computers...

    Thanks for taking time out of your summer to look at my problems...

  4. #4
    Join Date
    Sep 2005
    Location
    Lower Hutt, NZ
    Posts
    4,910
    This makes me think that it's reading it:
    Code:
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Reading Audio File details
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2:E:\Progressive Rock\IQ\Subterranea\Tunnel Vision.mp3
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Read Artist: IQ
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Read Album
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Read Album: Subterranea
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Read Title
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Read Title: Tunnel Vision
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Read track number: 7
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Read Genre 
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Read Genre: Neoprogressive Rock
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Read Year: 1998
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Read Duration: 00:07:24
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Read Filelength
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Read Bitrate: 320
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Successful read
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Checking for cue file
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Update DB - update: E:\Progressive Rock\IQ\Subterranea\Tunnel Vision.mp3
    2/25/2007 9:12:31 AM	STUPID	MusicLibrary2: Update DB - ran query: 1
    So has this one track "read" properly? If not, could you go have a look at my user profile and send me that track. So I can see what it's doing.

    Also what the log was telling me was what reader was reading the track details, and it isn't wmp....it'sthe other one I use.

    At the moment no, I don't do anything with the commment, I don't even store it. I might add support for it when you force read on a track and get the details screen (ctrl-k when looking at a track.).
    Gigabyte AMD A8 Brix, 4 Gb DDR3 Ram, 120 Gb SSD, SiliconDust HDHomeRun Dual DVB-T, Samsung LA46A650 TV (HDMI), Harmony Remote 525
    Windows 8.1 Pro, NPVR 3.2.9, AC3Filter, 1 x AppleTV with Plex, Plex Plugin, NextPVR Channel for Plex

  5. #5
    Join Date
    Oct 2006
    Posts
    10

    Thumbs up Solved

    I seem to have solved it. I installed an explorer shell that lets me edit tags through track properties (like Win explorer but with more detail). Once again I re-edited the genre tags on the problem tracks and forced an ML2 update. All the problem tracks now show the right genre. Don't know why editing with the shell makes any difference when edits with explorer alone weren't read correctly. Don't know why WMP and Real could read the genre correctly before and ML2 couldn't.

    I've ripped almost 20 CDs since then, batch editing the genre fields in WMP, and all the genre fields are showing correctly on all the new rips. Don't know why the addition of an explorer shell makes any difference to the accuracy of the WMP edits either.

    Now I can view my music by genre, which will be a huge help when I get the rest of the collection loaded.

    Sometime when you're back in programming mode, if there is enough interest from ML2 users, I'd love to have the comment field. That's where I store things like the symphony on classical music, or the plot line for a ballet.

    Next time you're outside, could you toss a frisbee or whatever for those of us in the northern hemisphere? There's another winter storm headed this way...

  6. #6
    Join Date
    Sep 2005
    Location
    Lower Hutt, NZ
    Posts
    4,910
    You'd want the comment field viewable on the details screen? Or anywhere else?
    Gigabyte AMD A8 Brix, 4 Gb DDR3 Ram, 120 Gb SSD, SiliconDust HDHomeRun Dual DVB-T, Samsung LA46A650 TV (HDMI), Harmony Remote 525
    Windows 8.1 Pro, NPVR 3.2.9, AC3Filter, 1 x AppleTV with Plex, Plex Plugin, NextPVR Channel for Plex

  7. #7
    Join Date
    Feb 2007
    Location
    Chicagoland
    Posts
    11
    The comment field on the details screen would be awesome.

    I see a weekend of typing liner notes in my future; my wife will be pleased.
    PIII 933mHz | 512mb | Win2000 Pro | 40gb | ATI Rage Pro | kWorld DVD xPress | Gigabit Ethernet w/Win2000 Server | 420gb

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •