Results 1 to 5 of 5

Thread: GBPVR won't run, new install

  1. #1

    GBPVR won't run, new install

    Apparently i'm not getting things configged correctly. I can run and use the config tool, but when I click OK to be done, it tried to start the recording service, then I get an error box that it can't start the recording service. I am using the newest version GBPVR09905.
    I have disabled Windows Media Center and Beyond TV, so those should not be interfering. I attached a zip file of all the logs.
    I first installed this several weeks ago, then reinstalled this week.
    I verified that I have .net 2.0 installed, and I installed the update you have in one of your sticky threads.
    thanks for any help or advice.Attachment 9183

  2. #2
    Join Date
    Oct 2006
    Location
    good ol' germany
    Posts
    546
    you have some strange characters in your logs, that all started with your scan for channels. see part of that log below. dunno if sub can fix that. you might give a fresh db a chance:
    - stop the service & GBPVR & Tray-app
    - backup/rename your db (either gbpvr.mdb or gbpvr.db3, depending to the database type used, will be the one with the most current change date/time)
    - copy the empty.db3 as gbpvr.db3 and give a fresh start a try
    try to check if it all works ok & your problems start only after adding the recording source / channel scan / EPG update
    if the same error comes up again, you'll have to wait for feedback from sub.
    good luck!

    2/3/2007 1:08:37 AM.687 ERROR [1] Unexpected error parsing scan information: System.Xml.XmlException: '', hexadecimal value 0x10, is an invalid character. Line 13, position 21.
    at System.Xml.XmlTextReaderImpl.Throw(Exception e)
    at System.Xml.XmlTextReaderImpl.Throw(String res, String[] args)
    Quote Originally Posted by sub View Post
    Yep, what he said.
    curiosity killed the cat

  3. #3
    that got me a bit further, thanks.
    Now the recording service starts ok, and I have the icon in the task bar, but gbpvr doesn't start up. I get this message at the end of the gbpvr log

    2/3/2007 9:59:09 AM.625 VERBOSE [1] getValue: /settings/LogSQL : false
    2/3/2007 9:59:09 AM.625 VERBOSE [1] getValue() loading new key/value into cache: /settings/AntiAlias
    2/3/2007 9:59:09 AM.625 VERBOSE [1] getValue: /settings/AntiAlias : true
    2/3/2007 9:59:09 AM.625 VERBOSE [1] getValue() loading new key/value into cache: /settings/DefaultStartupOptions
    2/3/2007 9:59:09 AM.625 VERBOSE [1] getValue: /settings/DefaultStartupOptions :
    2/3/2007 9:59:09 AM.828 VERBOSE [1] getValue() loading new key/value into cache: /settings/MiscMediaDirectory
    2/3/2007 9:59:09 AM.828 VERBOSE [1] getValue: /settings/MiscMediaDirectory : .\media
    2/3/2007 9:59:09 AM.843 INFO [1] Starting
    2/3/2007 9:59:09 AM.843 VERBOSE [1] Direct Playing:
    2/3/2007 9:59:09 AM.843 VERBOSE [1] getValue() loading new key/value into cache: /settings/VolumeControl
    2/3/2007 9:59:09 AM.843 VERBOSE [1] getValue: /settings/VolumeControl : Master Volume
    2/3/2007 9:59:09 AM.859 ERROR [1] System.MissingMethodException: Method not found: 'Int32 NativeUtilities.MediaHelper.getCurrentVolume()'.
    at GBPVR.Utility.x8d9919a3eeaed4d5.x1b7288aba5dcc26d( )
    at GBPVR.Utility.x8d9919a3eeaed4d5.x1fa9fc9cbb6f81c9( )
    at GBPVR.xbb1566157f5f8b1f..ctor(String directPlayFileName, Boolean mvpMode)

  4. #4
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    76,243
    It actually sounds to me like you've installed some old (incompatible) NativeUtilities.dll patch onto a new release of GB-PVR.

    I'd uninstall GB-PVR. Delete the GB-PVR directory, then reinstall.

  5. #5
    I did the hotfix .net2 update in your survival guide thread, don't think i did any other patches. I am uninstalling as i type. (your fast responses are impressive!)
    next rebooting

    That worked, now I am watching Live TV through GBPVR, thanks!
    time to tinker and see if everything else works.
    thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •