PDA

View Full Version : Problems With MPGs On MediaMVP including Live TV



lagrian
2004-02-25, 05:32 PM
Hi,

I was wondering if anyone else has the same issues as me. I have tried everything to get this sorted but haven't had any luck.

The Problem

When watching Video Clips or Live TV on the MVP using any version of GBPVR inlcuding .13 as soon as I try to ff or rw or go to the menu I get a black screen and nothing works except the power button on the remote. When the menu loads up again after returning from the powered down state the remote still does not work except the power button. This happens for both recording sources Direct and WinTV cap.

I often get this error coming up on the PC in a .NET framework window when this happens:

************** Exception Text **************
System.ObjectDisposedException: Cannot access a disposed object named "System.Net.Sockets.Socket".
Object name: "System.Net.Sockets.Socket".
* at System.Net.Sockets.Socket.Send(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
* at System.Net.Sockets.Socket.Send(Byte[] buffer)
* at ab.a(Boolean A_0)
* at ab.d(Image A_0)
* at a.a()
* at a.g()
* at ab.b(Object A_0, EventArgs A_1)
* at System.Windows.Forms.Timer.OnTick(EventArgs e)
* at System.Windows.Forms.Timer.Callback(IntPtr hWnd, Int32 msg, IntPtr idEvent, IntPtr dwTime)

This video playback behaviour doen't occur in the Official MediaMVP client software.

What I have tried

I have tried everything to my knowledge I have gone to Windows 2000 then back to XP on each trying official and latest beta drivers for both Hauppage PVR 250 and the MediaMVP.

Currently I am on v 0.13 of GBPVR and 22035 CD package from SHSPVR for the PVR250 and 22050 version for the MediaMVP running on Win XP SP1 with latest .NET framework installed and latest MDAC.

Any help on this issue would be much appreciated as It currently unusable for me as each time I watch an Mpeg I have to got to the PC and restart the GBPVR MVP server.

Thanks for any help in advance.

Sub, Love the work you are doing, keep it up.

sub
2004-02-25, 05:42 PM
Easy answer for this - ff or rw dont work yet. I'm still scratching me head trying to work out how they've implemented these features. Sorry. I will get it working, but there is a lot of hard work that goes into even the smallest features. ff and rw are more complicated than you'd ever imagine.

I actually thought I'd disabled anything happening with ff/rw, but I must have missed something.

Two release ago I introduce MVP support, but skip/ff/rw weren't working. The last release added skip forward/back. Push the buttons by themselves and they'll attempt to jump sixty seconds. To jump forward 30 seconds type 3 - 0 - Skip. You get the idea. It's not 100%, but should be generally working.

lagrian
2004-02-25, 05:50 PM
Hi Sub,

Thanks for the quick reply and the notes on ff & rw, however I still get this issue when trying to return to the Main Menu , however I don't receive the error shown above (the .Net one) when I do this. I assume the .net error is relating to the ff & rw then ?

Even if I just watch a video clip to the end and the video stream is terminated it doesn't return to the main menu it just locks up and I have to restart the GBPVR media service. This happens on all mpegs played including Live TV, it does not happen for Audio or NetRadio though

Thanks again

Lagrian

sub
2004-02-25, 05:57 PM
Ok, that doesn't sound right. I'll take look.

sub
2004-02-25, 05:59 PM
BTW, the .net error is just saying that GB-PVR is try to send information to the MVP but the MVP has chose to disconnected. It has probably disconnected because GB-PVR has sent it some data it didn't understand.

lagrian
2004-02-25, 06:32 PM
Thanks,

Do you need any logs sent to you or do you have an inkling to what it is ?

sub
2004-02-25, 06:41 PM
Yes, email through a GBPVR.exe.log. Run a short video clip to completion. The GBPVR.exe.log (for MVP) is created somewhere else on your drive - you'll need to search for it.

If you push 'stop' or 'menu' during playback, does it return to the menu? and does the remote function after this?

lagrian
2004-02-25, 11:12 PM
I've emailed the log at the point straight after a video has ended,
.

yep when I push 'stop' or 'menu' during playback it goes to a black screen and the remote doesn't function.

lagrian
2004-03-01, 12:42 PM
Hi Sub,

I know you are really busy so sorry if this sounds like I'm being rude.

I just wondered if you have had a chance to look at this problem. I don't think I am the only one with this problem as this post suggests

Click Here (http://gbpvr.com/cgi-bin/ikonboard.cgi?act=ST;f=1;t=40)

The user Polsen seemed to have the exact same problem.

Background:
OS: Win XP SP1
Capture Card: PVR 250
Software : GBPVR 0.13 , MediaMVP 22050, PVR250 Driver CD 22035, latest .net & MDAC.
Codec: Latest Hauppauge
MVP : PAL , Rev D3a (Replacement)
MVP Infrastructure: Using wired NIC with Crossover cable.

Thanks in advance and I understand if this is a lower priority for you just now.

Thanks Lagrian