PDA

View Full Version : TVxb EPG problem



Lindsay
2005-05-04, 12:38 PM
Probably only for Kiwis!
I use TVxb to produce the xml file but there are additional entries for the Prime programs. The dodgy entry is "<title lang="en">info</title>" and it also has3 little squares after it. This means that all the entries have "info" as the title! I can see where it comes from on the web page but lack the knowledge to fix it. At the moment I just zap all these entries but has anyone got a better solution?

reven
2005-05-04, 01:15 PM
you could always use xmltvnz, found at www.reveninteractive.tk (i wrote it :), gets all the nz channels + sky, more info at the site. or you could head over to www.nerdthings.com and there are a few other sources listed on that site (its a htpc site for new zealand).

Lindsay
2005-05-05, 06:04 AM
Thanks very much, Reven. I took your advice and it loaded all progs fine. However, my channels are displayed in order, tv2 (ch2), tv3 (ch3), Prime (ch7), tv1 (ch1). How do I get tv1 at the top? I've tried all sorts of things (even tried finding a solution in the Documentation!). And there is a spurious One (ch0) but I just disabled this so that is OK.
TIA.

reven
2005-05-05, 06:09 AM
the only time my epg is out of order is when c4 has no data (which happens every once in a while) and it is placed at the bottom of the list. if channel one does have guide info, and is out of order, check the "Channels" tab (or whatever it is called) in the config, and make sure the channel numbers correct (not the edit capture source option, but channels tab). if the channels are in the correct order, try emptying the epg (this time from the edit capture source window) and then reload it (sometime gbpvr doesnt delete this from the guide thou, not sure why. if you can get your hands on access you can manually delete everything from the "Programme" table which will then allow you to do an fresh import to the epg).

Lindsay
2005-05-05, 09:11 AM
Thanks Reven. I have now got it right. Fiddled with the database (I have Access) but I think the key was juggling the Channels on the Channels tab.

Cheers.