PDA

View Full Version : Network Recorder Live TV Freezes After 5 - 8 Minutes



mikeh49
2012-01-03, 10:49 PM
I'm using Network Recorder to stream live TV from the firewire port of the STB connected to the main HTPC to a NPVR box in a different room (the second box has a capture source configured for the Network Recorder tuner). Before yesterday, I've only done short testing and it looked OK. During extended viewing, the screen freezes after 5 - 8 minutes. If I then hit STOP, I return to the previous menu (TV guide or channels pop-up) and I can then restart the stream and it freezes again in 5 - 8 minutes. It's reproducible on 2 different remote boxes. I'm thinking it is a problem with the buffer file. When this happens, various size files are left behind in the buffer folder. For a test today, I played the buffer file in WMP and it appears to START at the time the screen froze (same commercial at start of file as on frozen screen) and then continues until I hit STOP. Logs and network recorder config file attached. I have some screenshots with the time bar if they would help. The most recent viewing was at 1502 to about 1514 today.

Other than this, firewire Network Recorder has worked flawlessly through the winter seasons of The Closer and Rizzoli and Isles - not a singe defective recording. Thanks, Martin!

I note that I have RollingFile false in the config, I think the problem existed even with it true. I'll retest and repost.

Update:

Same problem with RollingFile true. Also confirmed that the leftover buffer file starts at the time of screen freeze.

In addition, Live TV with QAM tuner on the test box does not have the freeze problem.

mvallevand
2012-01-03, 11:19 PM
What are you using as your TS writer in the graph?

Martin

mikeh49
2012-01-03, 11:53 PM
Three filters in the graph: Motorola AV/C Tuner -> NPVR TS Mon -> NPVR File Writer

mvallevand
2012-01-04, 01:19 AM
Did you restart the recording service when you changed from false to true. The NRecord log goes back to yesterday.

Martin

mikeh49
2012-01-04, 01:26 AM
I think I restarted the service. I'll test again with a restart. The issue came up yesterday starting about 1600 or so when trying to watch the Rose Bowl in the basement family room. Several tries there on ESPN, channel 773, then various tests.

mvallevand
2012-01-04, 01:42 AM
I see everything that you are talking about, but if you see a -1.ts file being made, I can`t explain my NextPVR isn`t reading it.

Martin

mikeh49
2012-01-04, 02:17 AM
It freezes as soon as it starts the new buffer file. A screen shot of the buffer folder is attached. The -2 file keeps growing and can be played by WMP until I hit stop in NPVR. Then, the original file (no -2) is deleted, leaving the -2. I didn't see a -1 file, only -2, i.e., the second buffer file created is -2, the first has no dash. You can see all the -2 files left from previous testing.

mvallevand
2012-01-04, 02:33 AM
Sorry, I think that's right it goes to -2, that's all controlled by sub's .ax files in the graph. Again, I am not sure why NextPVR won't try and play it as a rolling file.

Martin