PDA

View Full Version : Scanning DVB-T with HW-CAM crashes on XP



Reddwarf
2010-07-09, 03:27 PM
I was installing XP for some other test reason, and while at it I tried to install NPVR on XP. It has been bothering me for some time that my Technotrend T1500 with HW-cam don't decrypt anymore (the native app works fine on both FTA and encrypted channels). Trying to scan for channels hangs NextPVR, and if I push Cancel or OK the attached exception occurs. Log saying "Object reference not set to an instance of an object".

sub
2010-07-09, 07:39 PM
Bump the thread tomorrow and I'll dust off my TT C1500 and take a look.

Reddwarf
2010-07-09, 08:08 PM
I'm pretty sure that this problem is connected to the non-working decryption in NPRV (I'm talking about the HW-CAM card), I'v found that if I enter the native app (TT-virwer) and watch TV2-HD (which is encrypted), I can afterwards watch TV2-HD in NextPVR, but none of the other encrypted channels.

This leads me to suspect that npvr doesn't initialize the CAM correctly.

sub
2010-07-09, 08:18 PM
Are you sure you've got that technotrend .dll in the NPVR directory (ttBDA something .dll)? It wont do technotrend decryption without it.

Reddwarf
2010-07-09, 10:26 PM
Are you sure you've got that technotrend .dll in the NPVR directory (ttBDA something .dll)? It wont do technotrend decryption without it.

No I did not until now:o. Maybe you told me ages ago (when version number < .10) but I totally forgot that... I get the TV2-channels now but not the Canal+ channels but that may be due to weak signal since my large antenna was blown down.

Can that be the cause of the scanning crash under XP? Because the scanning went fine under W7 without these .dll's. I don't have a chance to test XP again until tomorrow since this is on my main htpc and it's occupied with recordings for most of the night.

Reddwarf
2010-07-09, 10:43 PM
Can that be the cause of the scanning crash under XP? Because the scanning went fine under W7 without these .dll's. I don't have a chance to test XP again until tomorrow since this is on my main htpc and it's occupied with recordings for most of the night.

I was able to check the XP-installation of NPVR without booting XP, and yes, it did have the ttBDAdrvApi.dll, so that's not the cause of the crash reported earlier.

sub
2010-07-10, 06:16 PM
Trying to scan for channels hangs NextPVR, and if I push Cancel or OK the attached exception occurs. Log saying "Object reference not set to an instance of an object".If you leave the scan to run to completion, does this error appear automatically without hitting Cancel/OK.

Glad to hear you got the channels decrypting with that DLL. I'm guessing the Canal channels are something else like signal etc, since NPVR just asks technotrend dll to decrypt the channel and it takes care of the rest. ie if one channel works, they should all work.

Reddwarf
2010-07-10, 06:50 PM
If you leave the scan to run to completion, does this error appear automatically without hitting Cancel/OK.

It never finishes the scan, I left it for about an hour while I was out, so it obviously hangs after that message in the log.

sub
2010-07-10, 07:01 PM
That message in the logs looks like you'd stopped the scan by hitting ok or cancel.

Can you leave a scan running until it hangs then post the npvr.log?

Reddwarf
2010-07-10, 08:15 PM
That message in the logs looks like you'd stopped the scan by hitting ok or cancel.

Can you leave a scan running until it hangs then post the npvr.log?

Exactly the same exception, and this time I didn't touch OK or Cancel button.

sub
2010-07-10, 11:17 PM
The logs look like the device fails to hookup, like it's in use in another process.

Reddwarf
2010-07-17, 06:00 PM
The logs look like the device fails to hookup, like it's in use in another process.

Hm, perhaps the native app has some quickstart that steals the device at boot time. I'll check when I have an opportunity.