PDA

View Full Version : VMR7 Acceleration on .mpg



Northpole
2010-06-25, 06:03 PM
Sub,

Thank you so much for bringing back VMR7. I couldn't get vmr9 to play as smoothly on my old single core XP machine. Playback of H264 files is great and I get hardware acceleration with my nvida board. However, when I playback a .mpg file, I'm not getting hardware acceleration. Currently using the nvidia purevideo decoder for .mpg content and the cyberlink h264 decoder for .m2ts (h264) content.

BTW, does anyone have problems with .ts playback with a .h264 and 5.1 ac3 in npvr/gbpvr. I don't seem to get true 5.1, its more like 5.1 downmixed to 2.0 and then played back at 5.1 speakers. The center channel dialog is spread over all 5 speakers. If I play the .ts file with media player classic or windows media player 10, it works just fine. Also, if i remux the file into a .m2ts and play that file, the audio is just fine in npvr/gbpvr and WMP. Currently using cyberlink 7 audio decoder, but have also tried ac3filter with the same results.

One other thing, (you probably already know this) if I set the recording option to new style then set the startup option to pending, it doesn't stay that way on the following npvr restarts.

Thanks again for all the changes and the vmr7.

sub
2010-06-25, 06:12 PM
Thank you so much for bringing back VMR7. I couldn't get vmr9 to play as smoothly on my old single core XP machine. Playback of H264 files is great and I get hardware acceleration with my nvida board. However, when I playback a .mpg file, I'm not getting hardware acceleration. Currently using the nvidia purevideo decoder for .mpg content and the cyberlink h264 decoder for .m2ts (h264) content.NPVR doesnt really play any active role in whether you get hardware acceleration or not. This is decided by the decoder and renderer.


One other thing, (you probably already know this) if I set the recording option to new style then set the startup option to pending, it doesn't stay that way on the following npvr restarts.The old style recording screen is going away in the next build, so best to stuck with the default new style screen. The reason the view isnt sticking was because of problem upgrading from 1.5.19. If you add <DefaultView>Ready</DefaultView> in the <Recording> section of config.xml, it'll store it correctly next time you go to edit the startup option.

Northpole
2010-06-25, 07:18 PM
Sub,

Thanks for the reply. I added the DefaultView line and that did the trick. Also, I tried using the cyberlink video decoder and that works fine. Just doesn't seem to like the nvidia decoder. I can't seem to get the AAC decoder setting to stick. Everytime I set it and restart, it goes back to disabled.

One last question,

what is this line do in the config

<HDPVRBufferLonger>false</HDPVRBufferLonger>

I'm currently using npvr with hip/mce remote and a Hauppauge HDPVR. It has been working OK so far. (About one week)

Any chance of some type of program search feature in the works?

sub
2010-06-25, 07:28 PM
Sub,

Thanks for the reply. I added the DefaultView line and that did the trick. Also, I tried using the cyberlink video decoder and that works fine. Just doesn't seem to like the nvidia decoder.Great


I can't seem to get the AAC decoder setting to stick. Everytime I set it and restart, it goes back to disabled.Someone else mentioned this. I havnt investigated yet. I've got it on my list.


One last question,

what is this line do in the config

<HDPVRBufferLonger>false</HDPVRBufferLonger>It was just something I was experimenting with. Leave it set to false.


Any chance of some type of program search feature in the works?I do intend to add a search screen, but I havnt started it yet.

Reddwarf
2010-06-25, 09:28 PM
I do intend to add a search screen, but I havnt started it yet.

In the meantime, there is a search function in the buildt-in NEWA (http://localhost:8866)

Northpole
2010-06-26, 02:17 AM
I do intend to add a search screen, but I havnt started it yet.

Looking forward to it.


In the meantime, there is a search function in the buildt-in NEWA (http://localhost:8866)

Thanks, I'll give it a try.