PDA

View Full Version : Error running Skin Plugin



JavaWiz
2009-09-04, 06:28 AM
I just downloaded CS WS Edition (v4.0.4). Install went fine, set CS as default in config.

When running PVRX2 and selecting the skin plugin, I get the following repeating exception:


2009-09-03 22:15:54.781 ERROR [1] Unexpected error: System.NullReferenceException: Object reference not set to an instance of an object.
at SkinPlugin3.SkinPluginMenuTask.GetRenderList() in D:\My Documents\Visual Studio 2005\Projects\SkinPlugin3\SkinPlugin3\EditableSkin ItemsUiList.cs:line 26
at GBPVRX2.MenuTask.x0be92cb4e3ac1817.needsRendering( )
at GBPVRX2.MenuTask.x9006c1ed9ccb79de.needsRendering( )
at GBPVRX2.x0061b801bdf12d35.xdb012c437aec4a40(Boolea n xd23bf32f3b17e3be)
at GBPVRX2.xb979ad394703258e.xfb409e85bd292293(String[] xf18a926310372520)


Just prior to that, these messages appear:


2009-09-03 22:25:33.390 VERBOSE [1] getValue cached value: /settings/ActiveSkin : Community-WS
2009-09-03 22:25:33.390 VERBOSE [1] getValue cached value: /settings/ActiveSkin : Community-WS
2009-09-03 22:25:33.406 VERBOSE [1] Skinhelper loading image from file: C:\Program Files\Devnz\GBPVR\skin2\Community-WS\SkinPlugin\..\_CoreImages\ScreenHeader.png
2009-09-03 22:25:33.421 VERBOSE [1] Skinhelper loading image from file: C:\Program Files\Devnz\GBPVR\skin2\Community-WS\SkinPlugin\..\_CoreImages\Hotspot_Home.png
2009-09-03 22:25:33.421 WARNING [1] node not found: /settings/Placements/Placement[@name="Tasks"]
2009-09-03 22:25:33.531 VERBOSE [1] ReturnToMainMenu()


Bad skin.xml?

Any ideas?

McBainUK
2009-09-04, 08:46 AM
at SkinPlugin3.SkinPluginMenuTask.GetRenderList() in D:\My Documents\Visual Studio 2005\Projects\SkinPlugin3\SkinPlugin3\EditableSkin ItemsUiList.cs:line 26
at GBPVRX2.MenuTask.x0be92cb4e3ac1817.needsRendering( )

Did you upgrade to v4.0.4 from a previous version of the CS/SkinPlugin? You need to remove v3.x before using v4.x.

http://gbpvr.com/pmwiki/pmwiki.php/Skin/CommunitySkin#toc8

JavaWiz
2009-09-04, 03:24 PM
Duh! When all else fails, it helps to read the instructions.

I actually scanned them when downloading, but saw "Use with previous versions", but did not read the 'fine print'. I thought it meant it was ok to use with previous versions.

I removed the old version and viola, works!

Thanks.

McBainUK
2009-09-04, 04:05 PM
Great. I've updated the wiki page to try and make it a bit clearer.