PDA

View Full Version : Crashes when I access it from the menu



rowle1jt
2009-06-05, 03:55 AM
Installs ok, config is ok. I am on silverlight and it is selected in the plugin settings. I have checked WMP is set to download usage rights. I can stream a movie in IE. I don't know what else to do? :(

When in GB-PVR (pvrx2) and I click on the watch now plugin, I get a .Net error and that it can't find the watchnow.serializer or something. I have zipped and attached my logs.

I am pretty good with GB-PVR... but I need help on this one.

Thank you in advance!

rowle1jt
2009-06-05, 03:56 AM
Oh yeah, I have tried the patch and the second monitor trick as well.

Snooze
2009-06-05, 10:36 PM
Try it with the default blue skin and see if this still happens.

rowle1jt
2009-06-06, 04:05 AM
Well, that made some progress. No more giant red X and instant crash! :-)

It still errors: "unable to locate DLL: NetFlixAPI.XmlSerializers.dll".

BUT, I can get in see the different "lists". Says it can't get my queue, and it tried to update the list and then got another dll error, Micrsoft something maybe? I should have wirtten that one down.

I am making progress... WAF would go through the roof if I could get this going! :)

Thanks!

whurlston
2009-06-06, 07:09 AM
It looks like it's failing to download the list properly. Does it work if you download the movie list manually from http://www.epgtools.com/Plugins/Netflix/MovieList.zip and extract the xml file to the Movie Cache folder? (note that the list is severly outdated but I'm working on that.)

rowle1jt
2009-06-06, 12:56 PM
That didn't seem to help. I even set back to the "blue" skin and tried again after putting the xml file in place. One time it did open a couple IE windows with the netflix site in the background... not sure what that was all about?


Of note: everytime I go into the setting of the plugin in the config, it shows that I have selecred the internal player. I siged up for netflix the other day so I know I am on Silverlight. Everytime I'm in there I set it to Silverlight, I have tried kiosk mode and non kiosk as well. I even unchecked the "initialze" thing to see if that would help.

When it errors, I can "ok" through the errors (1 dot net error and 2 dll errors) and get back to the pvrx2 menu, but the app has lost focus and I can't control anything.


Thank Whulrston, I appreciate it. Not sure if it helps or not... but logs are attached.

whurlston
2009-06-06, 05:05 PM
For some reason, it's plugin's deactivate routine is being called almost immediately after starting. Have you logged into the Netflix website with Internet Explorer and told it to remember you on login?

rowle1jt
2009-06-06, 05:16 PM
Yes I have, but I will try it again.

rowle1jt
2009-06-06, 05:52 PM
Just tried it... and still does the same thing. Do you need the logs again?
Thanks!

whurlston
2009-06-06, 06:27 PM
I'll see if I can reproduce the problem. I vaguely remember this happening before but I can't remember the cause.

rowle1jt
2009-06-06, 08:13 PM
Thank you! Much appreciated!! :) :) :) :)

rowle1jt
2009-06-12, 07:33 PM
Any update whurlston? I know your busy... Sorry. :)