PDA

View Full Version : MovieWizLauncher question



stevenjwilson
2009-03-04, 07:44 PM
I am having a problem getting to files on one the disks that I have: I am getting a zero length string error. I can configure it to read other disks OK, I can also get to a few of the directories on this disk that I tried. But when I point it to the whole drive, it give me 0 length error.

See attachments; error info and file list and .xml

I like this program, nice and simple

JavaWiz
2009-03-06, 04:15 AM
Hmm.. I can't seem to recreate on my side. I have a slightly different version, maybe try this and see if it still occurs.

If it does, I may have to add some logging into this program. At this point it has none.

stevenjwilson
2009-03-10, 02:02 AM
I hate to say it does the same thing. crashes with 0 len string

JavaWiz
2009-03-10, 04:32 AM
Ok, give me a couple days to add logging, then we can work thru this.

JavaWiz
2009-03-16, 02:39 AM
Ok, here is a version that adds logging. Also, I made a change that I think will fix your error.

stevenjwilson
2009-03-22, 02:53 PM
I tried it but I got an error right on startup. I tried downloading the latest wizdll.zip, but same thing. I couldn't find a log file either. I will turn on subscribe so TAT is faster...sorry for the delay.

JavaWiz
2009-03-22, 08:02 PM
Ok, let's try this again. Here is a new version, if it does not work, run WizDllInfoHelper and send me the output.

stevenjwilson
2009-03-23, 03:55 PM
I think that last error was a red herring. I checked the info log and saw I had 2 wizgenhelper files. One in plugins/common and one in devnz/gbpvr. I got rid of the one in devnz/gbvpr and when I did that, I retried both recent .zip you sent and both the last version and this version give me the same 0 value error that I orginally got.
I also found the log file, but I dont see any error msgs. I marked where I think the error happened.
Thanks for looking at this. I appreciate it.
The .zip is after I tried the most recent zip file.

JavaWiz
2009-03-25, 04:20 AM
It must have either something to do with the directories you've configured or either directory names or filenames on your system. No matter what I do, I cannot get it to fail on mine.

Here is another version with some additional logging.

stevenjwilson
2009-03-25, 01:49 PM
Did you make any changes? That one works! I will play with it some more....

JavaWiz
2009-03-25, 03:53 PM
I may have, I was trying to insure there was no invalid strings, so it's possible I may have made a change to correct the problem.