PDA

View Full Version : MVP keeps re-requesting DHCP lease



pulp
2005-02-08, 08:30 PM
Setup:
- MediaMVP
- PC running WinXP (XP firewall disabled, no other software firewall)
- Linksys router/DHCP server
- GBPVR server, Hauppauge server disabled.

I hooked up the MediaMVP to the Linksys, on the screen I see:
1) Contacting DHCP Server (for less than a second), then
2) Contacting MediaMVP Bootserver (for a long time), then repeat from step 1.

So looking at the Linksys, I can see that the MVP gets a DHCP address with a lease expire time of 60 seconds, but after about 20 seconds it rejects it and gets a new lease (with the IP address incremented by 1), again 60 second lease time, and again after 20 seconds it gets another IP incremented by 1.

So I stopped the GBPVR MVP server, and started the Hauppauge one. Same thing happened.

Anybody else run into this issue? The Linksys router doesn't block any ports from within the LAN (at least that I could tell on the config webpage of the router), so why can't the MVP get to the bootserver?

I hope someone can answer it! The Hauppauge support pages are not very useful for this...

Pulp

bluesxman
2005-02-08, 09:53 PM
I'm sure I had a similar problem a while ago (before i used GBPVR), on a different router though.

What I had to do is disable DHCP on the router and let the MVP get an IP address from the Hauppuage software. It might worth trying that, if only to narrow down what the problem is.

Networker
2005-02-09, 01:16 AM
You say the lease time is set to 60 seconds or that is what the report connection information says? The way DHCP normally works is setting what is called T1 and T2 times. Roughly 1/2 way through the lease time the machine is suppose to check with the server and 'tell' it it wants to continue to use the IP address. Usually a machine will keep it's IP address if it is not off for a long time.

If it can't keep the IP address is certainly isn't going to finish the process of booting. I agree you should try the Hauppauge MVP software and hopefully you can fix the problem.

John

pulp
2005-02-09, 03:35 AM
Still not working (same thing happened). I even uninstalled GBPVR and downloaded the new Hauppauge software, but nothing.

My plan for tomorrow is to install ZoneAlarm to see if the MVP is even trying to access my PC.

WJC
2005-02-10, 09:05 PM
I have had several problems similar to what you are finding since I upgraded to the latest release of GB-PVR. *I have been able to eliminate the problem by changing and turning off some of the settings in Nortons Antivirus software, particularly the Internet Worm Protection. *I run the latest edition of Nortons. *Other than turning off worm protection I have also told the program to not check any of the files in the directories that GB-PVR uses. *Additionally I have the Windows firewall disabled but have not turned it on to determine if it would cause a problem.

If you are running any virus protection, worm protection, ad protection, or anti-spyware you might look at those programs to see how they are interacting with your MVP as it initiates.

The older version of GB-PVR did not seem to have the same sensitivities.

I am also working through a Linksys router with all the settings set to default with no problems.

I have left the Hauppauge initialization software installed and have been starting up the MVP with that program. I then turn it off and run the GB-PVR server program. For my setup it seems to run better that way in that if I set the GB-PVR software to do the initial MVP setup it hangs a large percentage of the time and I have not been able to figure out why (in the last version the newer dongle file that goes with the new MVP remote seemed to cause the problem but in the newer version that doesn't seem to be a factor).