PDA

View Full Version : Black Screen when stopping



steveum
2008-07-15, 05:04 PM
I have had my popcorn hour for almost 2 weeks now. When I stop watching a recording from GBPVR, about half the time I will just get a black screen. The only way I seem to recover from this state is to physically unplug the popcorn hour then plug it back in. I have seen other postings related to this issue, but it is not clear what the resolution might be. I have had a couple a days where it seemed to work flawlessly, then I had days like yesterday where it seems everytime I stop I get this black screen (or is it blank?).

mvallevand
2008-07-15, 05:25 PM
My guess is you haven't set up config.xml to indicate that you have a PCH. Compress and upload your GBPVR logs and we can have a look.

Martin

steveum
2008-07-15, 05:36 PM
Attached is the ZIP of all my log files.

mvallevand
2008-07-15, 06:22 PM
Sorry, could you set the MVP Autostart to 1 and then start up your PCH and duplicate the problem.

Martin

steveum
2008-07-16, 02:30 PM
It has not happened again yet since I reset the MVP Autostart to 1. If it starts happening again, I will post the log files to this thread.

I was also having a problem where I could not go back to GBPVR from the native application. For example, if I used the power button to leave GBPVR, then went back into telnet.html, it would just hang if I selected GBPVR again. This seems to work for me now. Could the MVP Autostart count be related to these problems? I had it set to 2 since I still have a couple MVP's in the house. I have not been using them, so reducing the count is not really a problem for me right now.

mvallevand
2008-07-16, 04:50 PM
Resetting the autostart might have also caused some config.xml changes related to the PCH to take affect. If you want upload the logs anyway and I can confirm that it is being properly identified.

Martin

steveum
2008-07-17, 01:04 AM
Attached are my logs again. The black screen is occurring again when I stop viewing a recording.

mvallevand
2008-07-17, 01:22 AM
Sub is going to have to look into this. It looks like you are using txt based comskip file which is causing a crash of the video stream.

Martin

sub
2008-07-17, 01:35 AM
If you delete E:\GBPVR\Pardon the Interruption\Pardon the Interruption_20080716_17301800.txt, can you then play the file without this problem?

steveum
2008-07-17, 02:01 AM
Yes, that seemed to resolve it. Sounds like I should turn off comskip processing and delete all the my txt files. I will see if this helps. It kind of makes sense since I never see the issue when watching DVD rips (no comskip files).

sub
2008-07-17, 02:04 AM
I'm guessing it only happens if comskip creates a file that indicates it starts immediately with an advert. The majority of comskip files are probably fine.

_Iz-
2008-08-04, 05:33 PM
Is there any resolution to this issue? I'm having the exact same problem. Videos play fine and return to the GBPVR interface but most recordings just go to a black screen on exit.

mvallevand
2008-08-04, 05:44 PM
Could you compress and upload your logs, we can confirm it is this problem.

Martin

_Iz-
2008-08-04, 08:25 PM
logs attached

mvallevand
2008-08-04, 08:44 PM
Yes, it looks like you have three minutes of commercials at the beginning of the show you are trying to record. If you can cut the first five minutes or so of the The Road Runner Show_20080527_19302000.mpg and the edl file and put them on a free upload site, I will look to see if I can do something in mvpmcx2 to avoid closing the socket.

Martin

_Iz-
2008-08-05, 03:06 AM
OK, here's the first 5 mins and the .edl file...

http://www.snapdrive.net/files/563996/The%20Road%20Runner%20Show_20080527_19302000.part1 .rar

http://www.snapdrive.net/files/563996/The%20Road%20Runner%20Show_20080527_19302000.part2 .rar

http://www.snapdrive.net/files/563996/The%20Road%20Runner%20Show_20080527_19302000.part3 .rar

mvallevand
2008-08-05, 03:16 AM
Thanks they are on there way here now. Since I don't have whole show can you tell me if Wile E. Coyote is able to catch the Road Runner? :)

Martin.

_Iz-
2008-08-05, 03:34 AM
I haven't watched all the episodes I recorded yet, but not so far. He's sure trying though! ;)

mvallevand
2008-08-05, 04:01 AM
Let me know.

Thanks too, this file does crash for me, I will see what I can do. Also I don't know a lot about edl files but it looks like this one misses where the program really begins.

"That's all folks" at least for now.

Martin

_Iz-
2008-08-05, 04:42 AM
Comskip generally does a great job of identifying the commercials but I've noticed it does a TERRIBLE job on the commercials in these roadrunner episodes.

jksmurf
2008-08-05, 05:28 AM
I'm at work, so cannot produce clean logs right now, but I'd like to chip in and say I have noticed the same phenomena with the black screen. Most of my shows have adverts at the beginning though and I do run comskip on every show, after the show ends. It produces only txt files.

k.

steveum
2008-08-05, 04:32 PM
I would just like to report that disabling comskip resolved the issue for me. Since I am pretty much viewing my recording exclusively through the PCH, it really did not make sense to have it enabled anyway.

_Iz-
2008-08-05, 04:40 PM
I find it bizarre that the PCH doesn't support comskip and yet the comskip files can cause this problem. (However I'm not a programmer so what do I know)

Disabling comskip is not an option for me unfortunately, all my other clients in the house do support comskip and it is very much missed on the PCH...

_Iz-
2008-08-19, 09:54 PM
Just checking to see if there was any progress on this issue. Thanks :)

mvallevand
2008-08-20, 03:15 AM
Whether or not mvpmcx2 supports comskip, GBPVR thinks that it does. I thought that if I had mvpcmx2 acknowledge the skip it might help, bt GB-PVR time outs so I stopped looking into this. The solution remains to turn off com skip.

Martin

_Iz-
2008-08-20, 04:22 AM
Thanks, I appreciate the update.

rwalker777
2008-09-23, 08:46 PM
Martin,

Is this going to be addressed going forward, either by making hooks to allow the PCH get comskip commands from GB-PVR (I know I am dreaming) or making GB-PVR not pass comskip calls to the PCH (it should have an id field or something).

Roy

sub
2008-09-23, 08:51 PM
Martin,

Is this going to be addressed going forward, either by making hooks to allow the PCH get comskip commands from GB-PVR (I know I am dreaming) or making GB-PVR not pass comskip calls to the PCH (it should have an id field or something).I've got it on my list of things to check for the next release.

_Iz-
2008-09-23, 08:57 PM
i've got it on my list of things to check for the next release.


yay!

mvallevand
2008-09-23, 09:24 PM
The current version of mvpmcx2 doesn't have a problem if there is a commercial at the beginning of the file but now PVRx2 gets hung up waiting for a response to the seek, which I cannot give with PVRx2 really having problems the RR example is perfect.

Martin

srhutch
2008-11-02, 11:08 AM
Having this problem also.

I removed the txt file from a recording before trying again but still the same.

I have attached my logs and config.xml file

thanks

steve

mvallevand
2008-11-02, 01:32 PM
srhutch, it looks like you didn't do D.3 of the survival guide. See if that helps.

Martin

srhutch
2008-11-02, 03:00 PM
Martin

Not sure what happened there, as I know I had added it once.

I have attahced, could you just confirm it is right.

thanks

Steve

mvallevand
2008-11-02, 03:09 PM
The MAC address of your PCH is 0006DC41EDF3 you don't a section for that one.

Martin

_Iz-
2008-11-02, 04:50 PM
I've got it on my list of things to check for the next release.


Anyone know if this issue is solved in the just released v1.3.7?

srhutch
2008-11-02, 07:04 PM
The MAC address of your PCH is 0006DC41EDF3 you don't a section for that one.

Martin

Martin

So basically I need to copy the sample and just change the MAC address to that of my PCH.

Steve

mvallevand
2008-11-02, 07:12 PM
Sure those are the instructions, or you could just update the config.xml you uploaded with the correct address.

Martin

jksmurf
2008-11-18, 03:19 AM
Quote:
Originally Posted by sub http://forums.gbpvr.com/images/buttons/viewpost.gif (http://forums.gbpvr.com/showthread.php?p=297433#post297433)
I've got it on my list of things to check for the next release.



Anyone know if this issue is solved in the just released v1.3.7?


Second this question as have same issue with comskip and PCH.

Cheers

k.

sub
2008-11-18, 11:03 AM
I cant actually remember.

jksmurf
2008-11-18, 09:30 PM
Could I make a wee request to have this looked at some time (no hurry)?
Ta

k.

jksmurf
2008-12-02, 01:10 PM
sub, Just making a wee bump for this request...

k.

sub
2008-12-02, 01:40 PM
Sorry, its going to have to wait a few more days. On my work trip I managed to pickup some urgent work that needed to be completed before the weekend..

steveum
2008-12-02, 05:30 PM
I work around this now by just turning off the auto comskip. This way I can still let comskip generate its files. Clients that can still use them, must toggle the auto skip back on while viewing.

pBS
2009-01-20, 06:54 AM
good workaround! :)
i am having same issue...
but latest firmwares are really fast on ui...
can't wait for resume that's coming..

skreien
2009-02-04, 12:29 AM
Bump.

Sub, any chance you've been able to look at this yet? Having the same issue with 1.3.11.

Thanks!