PDA

View Full Version : OSD on Xcard



nox71
2004-03-15, 11:07 PM
Is it normal that i can't get menu on mmy Xcard only the live tv or video playback give me something ?

sub
2004-03-15, 11:18 PM
Nope, you should be able to see the menu and OSD.

sub
2004-03-15, 11:21 PM
You could email your gbpvr-native.log, it may contain some clues.

nox71
2004-03-16, 12:00 AM
The only file i got is GBPVR.exe-native01.txt so here is the content:

19:02:48.721 INFO Log started
19:02:48.721 INFO DirectShowHelperXCard()
19:03:54.546 INFO DirectShowHelperXCard::playFile D:\livetv-1-0.mpg
19:04:18.680 INFO DirectShowHelperXCard::stop()
19:07:53.559 INFO DirectShowHelperXCard::playFile D:\998D03-02-2004T21_23_24_0241.mpg
19:08:41.348 INFO DirectShowHelperXCard::stop()
19:08:50.791 INFO DirectShowHelperXCard::stop()

sub
2004-03-16, 12:37 AM
Ok that looks fairly normal. Please confirm your problem: You can see menus on your PC monitor, but not on your TV. Video plays back correctly on your XCard, but you cant see any OSD overlaid on the video?

How do you connect you XCard to your TV? What version of the XCard drivers are you using?

nox71
2004-03-16, 12:41 AM
I can see the menu on my monitor but not on the TV, when playing video or watching LiveTV i got the video and the OSD on the bottom of the screen.

I am using driver 2.1 for my Xcard.

nox71
2004-03-16, 12:41 AM
Xcard connected via Svideo cable to the TV.

sub
2004-03-16, 04:37 AM
Quote[/b] (nox71 @ Mar. 16 2004,01:41)]I can see the menu on my monitor but not on the TV, when playing video or watching LiveTV i got the video and the OSD on the bottom of the screen.
After you stop the video, does the menu appear? The reason I ask, is that the same function that displays the OSD on the bottom of the video also displays the menu. The only thing different is the transparency level.

nox71
2004-03-16, 11:57 AM
No OSD when stopping video or live tv playback.

shspvr
2004-03-16, 02:23 PM
Did you kill SageTV or Joveplayer?.
Buy the way nox71 dose OSD show when using Xmedia Player? you know PLAY, STOP, ETC, ETC screen.
Try run the Configuration tool click on Setting change to OSD what ever it saying to 0.

sub
2004-03-16, 03:29 PM
shspvr is on the case. Does joveplayer output a menu to your tv via the xcard? Even an expired evaluation should be enough to tell if the OSD is functioning on your card.

nox71
2004-03-16, 04:45 PM
Yes JovePlayer is giving me my menu and is working just fine.

sub
2004-03-16, 05:13 PM
Package up your computer and send it to me here in New Zealand, and I'll take a look. http://gbpvr.com/iB_html/non-cgi/emoticons/biggrin.gif Just kidding

Sorry, I dont know what the problem is.

shspvr
2004-03-16, 05:26 PM
Oh my I can just see S/H now hehehe.

nox71
2004-03-16, 10:30 PM
I will restart my system from scratch and see if it solve the problem. http://gbpvr.com/iB_html/non-cgi/emoticons/sad.gif

How much does it cost to send it to you from Canada http://gbpvr.com/iB_html/non-cgi/emoticons/rock.gif?http://gbpvr.com/iB_html/non-cgi/emoticons/rock.gif?

nox71
2004-03-17, 12:54 PM
I restarted my system from scratch but it still doesn't work. I think i will have to stick with JovePlayer for now.

sub
2004-03-17, 04:51 PM
Just reconfirm one thing that isnt 100% clear from the previous posts. When you playing video with GB-PVR configured to use the XCard, you are seeing OSD shown over the bottom of the video (on the TV)?

Can you email me you config.xml. I'll also add a few more diagnostic messages to the XCard support and send you a download link.

nox71
2004-03-17, 09:26 PM
Correct when playing video or watching Live TV i got the video with a little OSD bar on the bottom of the screen on my TV. Here is my Config.xml file:

- <settings>
- <!-- make a backup of this file first if you attempt to manually modify any settings!
-->
- <!-- extras
-->
<WindowedMode>true</WindowedMode>
<WebInterfaceEnabled>false</WebInterfaceEnabled>
<WebInterfacePort>2033</WebInterfacePort>
<TvGuideSpecialTaskExecutable />
<TvGuideSpecialTaskArguments />
<PreShowPadding>1</PreShowPadding>
<PostShowPadding>1</PostShowPadding>
<IconView>true</IconView>
<PromptForResume>false</PromptForResume>
<DontAntiAlias>false</DontAntiAlias>
<DirectRemoteAccess>false</DirectRemoteAccess>
<MvpPrePlaybackDelay>200</MvpPrePlaybackDelay>
<HideExitButton>false</HideExitButton>
- <!-- mpeg2 decoder
-->
<HardwareDecoder>Sigma Designs XCard</HardwareDecoder>
<SupportedDecoders>InterVideo NonCSS Video Decoder for Hauppauge,CyberLink Video/SP Decoder (ATI),NVIDIA Video Decoder,CyberLink Video/SP Decoder,Elecard MPEG2 Video Decoder,MainConcept MPEG Video Decoder,Sonic Cinemaster® DS Video Decoder</SupportedDecoders>
<PreferredDecoder>InterVideo NonCSS Video Decoder for Hauppauge</PreferredDecoder>
<Renderer>VMR9</Renderer>
<ShowClosedCaptions>true</ShowClosedCaptions>
- <!-- XCard settings
-->
<OutputMode>0</OutputMode>
<TVStandard>1</TVStandard>
<XCardOSDMarginLeft>0</XCardOSDMarginLeft>
<XCardOSDMarginTop>20</XCardOSDMarginTop>
<XCardOSDMarginBottom>30</XCardOSDMarginBottom>
<XCardOSDMarginRight>0</XCardOSDMarginRight>
- <!-- PVR350 settings
-->
<UsePVR350>false</UsePVR350>
<UsePVR350QuickMode>true</UsePVR350QuickMode>
<PVR350Width>640</PVR350Width>
<PVR350Height>520</PVR350Height>
<PVR350OffsetX>45</PVR350OffsetX>
<PVR350OffsetY>20</PVR350OffsetY>
- <!-- MVP Settings
-->
<MVPWidth>640</MVPWidth>
<MVPHeight>500</MVPHeight>
<MVPOffsetX>45</MVPOffsetX>
<MVPOffsetY>40</MVPOffsetY>
- <!-- database settings
-->
<DatabaseConnectionString>Provider=Microsoft.Jet.O LEDB.4.0;Data Source=".\gbpvr.mdb";User Id=admin;Password=</DatabaseConnectionString>
- <!-- skin settings
-->
<RootSkinDirectory>.\skin\</RootSkinDirectory>
<ActiveSkin>Blue</ActiveSkin>
- <!-- mame settings
-->
<MameEnabled>false</MameEnabled>
<MameExecutable>C:\downloads\misc\mame072b\mame.ex e</MameExecutable>
<MameRomDirectory>C:\downloads\misc\mame072b\rom s</MameRomDirectory>
- <!-- media library settings
-->
<RecordingsDirectory>D:\</RecordingsDirectory>
<MiscMediaDirectory>.\media</MiscMediaDirectory>
<VideoLibraryDirectory>D:\</VideoLibraryDirectory>
<MusicLibraryDirectory>D:\</MusicLibraryDirectory>
</settings>

nox71
2004-03-17, 11:35 PM
Got some hope for no reason the OSD appear for about 1 minutes and i was able to navigate trough and start playback of a video but when stooping the video to get back to the menu i lost my OSD. I will continue to make testing and give you some feedback Sub.

nox71
2004-03-18, 12:03 AM
More detail: the only way i can get the OSD is by goimg to Net Radio -> select a station and then the OSD appear as long as i don't try to playback a video because every time i stop a video playback i lost the OSD and i have to go back to the Net Radio to get it back. If i start a video playback and let it go to the end it gave me an error message in french so i will try to translate "Error: The object reference is not define to any objetct" something like that!

sub
2004-03-18, 06:10 PM
That is just bizzare! In the XCard settings in Config app, what is your tv standard set to (NTSC/PAL/PAL60/Default)?

nox71
2004-03-18, 10:42 PM
NTSC!

sub
2004-03-18, 11:02 PM
Have you tried "Default" just on the off chance? It might be worth trying it with this setting after running the XMP player. This would have the affect of letting XMP setup the card, and when it is set to Default GB-PVR wont try and reinitialize it. Worth a shot.

nox71
2004-03-18, 11:26 PM
Sorry i did give a try but still stuck with this problem. I will continue on my side to dig into the problem and gave you some feedback as soon as i find something. Is there a log file or something that can help me with that ?

sub
2004-03-18, 11:48 PM
That the funny thing, the log file that would show any errors is GBPVR.exe-native01.log which contained no errors. If anything returned a failure code, it would be show here. It really is strange that it sometimes shows the menus.

Its Friday here, so tomorrow I'll knock up a version which contains some additional diagnostic messages and send you a download link.

nox71
2004-03-19, 12:05 AM
Perfect !

See Ya! ;)

sub
2004-03-20, 11:36 PM
Nox71, did you try the version with extra diagnostics I emailed the link for? If you did, make sure you email me the log and let me know how you got on.

nox71
2004-03-21, 10:35 PM
Yes i tried it and i email you the log twice so just in case here is the log:

17:33:08.542 INFO Log started
17:33:08.542 INFO DirectShowHelperXCard()
17:33:08.562 VERBOSE Using vertical resolution: 480
17:33:08.763 VERBOSE Original flags: 00000001
17:33:08.763 VERBOSE New flags: 00000001
17:33:08.763 VERBOSE Setting CVBS mode
17:33:08.763 VERBOSE mode: 00000001
17:33:09.964 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:13.540 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:13.950 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:25.316 INFO DirectShowHelperXCard::stop()
17:33:40.959 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:41.330 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:41.650 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:42.031 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:42.371 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:44.254 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:46.056 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:46.367 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:46.687 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:47.498 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:48.490 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:48.830 INFO DirectShowHelperXCard::stop()
17:33:48.910 INFO DirectShowHelperXCard::playFile D:\998D03-02-2004T21_23_24_0241.mpg
17:33:50.453 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:50.843 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:51.855 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:52.856 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:53.858 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:54.859 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:55.129 INFO DirectShowHelperXCard::stop()
17:33:55.560 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:57.242 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:59.345 VERBOSE DirectShowHelperXCard::BlendBitmap
17:33:59.666 VERBOSE DirectShowHelperXCard::BlendBitmap
17:34:00.878 VERBOSE DirectShowHelperXCard::BlendBitmap
17:34:00.968 INFO DirectShowHelperXCard::stop()

shspvr
2004-03-22, 02:39 PM
I was just thinking of something but have try runing the Xcard FiltersControl and unchecking "Rename quartz.dll to quartz.dll.xxx" and all other decoder should be enable.

nox71
2004-03-22, 10:41 PM
?? Don't understand what you mean SHS http://gbpvr.com/iB_html/non-cgi/emoticons/rock.gif?

shspvr
2004-03-23, 02:27 AM
Start | Programs | REALmagic Xcard | click on FiltersControl

nox71
2004-03-23, 10:26 PM
No difference still no OSD on my Xcard.

2004-04-10, 04:28 PM
I also have no OSD on my xcard output, I only have the miniguide under the green button. Still no solution available?

TypQxQ
2004-04-10, 05:05 PM
Doesn't seem to be, I have the same too. Check out "Widescreen and AC3" under Wishlist. If u can send the log files to sub, that would be great. You can use support@devnz.com and attach the files.

/Q

sub
2004-04-10, 05:35 PM
OK, so some of you have reported that the menus show up after using the netradio feature. Does the menus stay visible after this?

For some reason on your machines it seems to be wanting something to be playing before the XCard will make the menus visible. This is not the case on my machine. I could try playing the black.mpg video in the background in the same way that I do for the PVR350. This may just kick it into life.

sub
2004-04-10, 06:50 PM
I've just installed my XCard in my new development machine, and downloaded and installed the latest XCard drivers, and now get the same problem. I guess this was a difference between 2.1 XCard drivers I've just installed and the one I installed about 8 weeks ago (2.0?).

Since I can reproduce it, I'll be able to fix it for the next release.

sub
2004-04-11, 06:10 AM
This problem has been fixed for next release.

TypQxQ
2004-04-11, 06:30 AM
YEPEEEE!!!!!! http://gbpvr.com/iB_html/non-cgi/emoticons/biggrin.gif

Great work!!!!

/Q

shspvr
2004-04-12, 04:07 PM
Hmm that odd I'm runing 2.1 sub

sub
2004-04-12, 05:01 PM
shspvr, I agree its odd. It was certainly working on my last machine.