PDA

View Full Version : MVP resets / freezes after watching Live TV



cannondale0815
2004-11-22, 02:52 AM
sub,

I already read about this problem somewhere in this forum but am not sure if a resolution was mentioned. The MVP resets itself very often for me in conjunction with GB-PVR. Specifically, after having watched Live TV or a recorded show for a few minutes, when I then press the 'Menu' button on the remote, the screen first goes blank, then either it stays like that or the MVP goes into its "Connecting Servers" mode (essentially a reset). Often it then recovers back to the GB-PVR screen, but sometimes it just stays in search mode and I have to restart the GB-PVR recording service on my PC one or more times for it to work again. It seems that this is more likley to occurr the longer I have watched a show. If I just go to Live TV for a few seconds, I usually don't have that problem. Could it have to do with some buffer filling up over time?

If you want, I can send you the logs I have. Just let me know which ones in particular you would like to have.

Thanks
-Jan

P.S.: Just for the archives, my MVP is a rev. D3A.

2004-11-22, 10:17 AM
Hai,

Ive got the same problem and Ive read something about this problem in this forum. According to Sub, the problem will might be over in the next release. I hope so.

I cannot wait for the new release.

Greeting,

Guido

2004-11-23, 05:01 AM
Hey guys, any idea when the next rev is coming out?

Thanks,

Dubya

p.s. Sub your prog kicks a$$

2004-11-27, 10:15 PM
Since I cannot register... therefore cannot start another thread, Here is my problem..

When I attempt to view recorgings or TVguide my MVP reboots.

here are the log errors:

11/27/2004 5:53:17 PM.077 ERROR [40] handleMVPConnection() exception: An established connection was aborted by the software in your host machine
11/27/2004 5:53:17 PM.087 ERROR [40] handleMVPConnection() exception: An established connection was aborted by the software in your host machine
11/27/2004 5:53:17 PM.087 ERROR [40] MVPWorkerThread - Connection lost, waiting new new one

Any help will be appreciated.

Jrock

Lucas_24
2004-11-28, 05:31 PM
I have a similar problem, but the MVP only seems to lose connection when attempting to view the TV guide after the recording service has been running for an extended period of time. In my case, I only have an MVP in the bedroom, so every night before bed I would restart the recording service and things were fine. Since then I've added a custom task pointing to the restart recording service bat file. That way I restart the recording service from the MVP before I try to view the guide.

Not a fix but a decent workaround until the problem is fixed.

2004-11-30, 05:48 PM
Thanks, that seems to be working... well, the workaround is working.

Does anyone know the reason for these MVP errors? Is it all the same? Is there something we can do with our configuration?

I would be happy to do some research if I had more information.

JRock

Lucas_24
2004-11-30, 06:58 PM
I just want to point out that since I upgraded to the version 0.23, that I havn't had to restart the recording service. My MVP has worked great since. Now I'm not suggesting that everyone was having the same disconnect error, but mine seems to have been resolved.

Thanks Sub.

2004-12-01, 11:58 PM
I recently upgraded to version 0.2.38. Menu switching was unbearably slow. I found that a complete re-install solved my problem.

Now though, after 1 day of use, whenever I try to use the TV Guide on the MPV, it resets. I still can access live-tv.

BTW, anyone have problem registering? I have been unable to...

2004-12-03, 03:51 AM
I've had GB-PVR running on my host computer for over a week with no problems. *Upgraded to .238 and things were still fine... but all this while I've been just waiting for my MediaMVP to arrive...

So I hooked it in but everytime I try to watch a recorded show or live TV and sometimes when trying to show the guide I get a socket error. *Here is a sample of the last error which occured when trying to view the TV guide:

12/2/2004 10:20:47 PM.437 VERBOSE [29] User pressed: 13
12/2/2004 10:20:47 PM.765 VERBOSE [29] Initializing TV Guide skin settings
12/2/2004 10:20:47 PM.781 VERBOSE [29] getValue() loading new key/value into cache: /settings/ShowChannelIcons
12/2/2004 10:20:47 PM.781 VERBOSE [29] getValue: /settings/ShowChannelIcons : true
12/2/2004 10:20:48 PM.500 VERBOSE [29] RecordingFactory.loadSchedule()
12/2/2004 10:21:15 PM.937 VERBOSE [29] MVP sending frame
12/2/2004 10:21:15 PM.984 VERBOSE [29] frame sent
12/2/2004 10:21:16 PM.062 VERBOSE [29] MVP request processed
12/2/2004 10:21:16 PM.093 ERROR [2] MVP Timer Refresh error: An established connection was aborted by the software in your host machine
12/2/2004 10:21:16 PM.093 ERROR [29] handleMVPConnection() exception: An established connection was aborted by the software in your host machine
12/2/2004 10:21:16 PM.203 ERROR [2] * at System.Net.Sockets.Socket.Send(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
* at System.Net.Sockets.Socket.Send(Byte[] buffer)
* at n.a(Boolean A_0)
* at n.b(Object A_0, EventArgs A_1)

My host computer is XP w/ SP2 and firewall turned off. *I am running with very little RAM on this box (128MB). *Does anyone know how to fix this socket problem?

TIA,
-Charles

By the way, registering for the forum does not seem to work..

moose
2005-01-02, 01:46 AM
I got something similar. a box poped up with an unhandled exception. this happened as a scheduled recording was starting and I was also scheduling something else to record. once I clicked the OK button everything went back to normal and worked fine.

attached are the log files.

moose
2005-01-02, 01:48 AM
forgot to mention that it is in gbpvr.exe.log