PDA

View Full Version : Beta 1.0.772 Installation/support



zehd
2006-12-14, 02:48 AM
Please feel free to post beta issues here...

Maint release: 772 new 12:40 am MST

http://members.shaw.ca/ztest/ffmpeg.exe

rscheller
2006-12-15, 02:20 AM
zehd,

I tried the new ZProcess and after a little 'accomodating for alpha phase' I got the fmpeg-trans2mvp to work on an avi file but was never able to get mencoder-trans2mvp to work on the same avi file. I kept getting a runtime error with mencoder.

Worse though was that something in the new ZProcess ffmpeg folder is causing GBPVR to attempt to reinstall itself when stopping the recording process or opening the config screen in GBPVR... I assume because it thinks it's missing some piece it can't find? When I switched back to the previous ZProcess ffmpeg folder (yea, I had renamed the old ffmpeg folder before I created the new ffmpeg folder for the new ZProcess files), GBPVR was then happy again.

guydot
2006-12-15, 02:21 AM
Zehd,

Well, I am getting conflicting results: I hit play then it goes back to the folder list and the MVP immediately restarts. Then when it comes back online and I hit play again - it works!

12/14/2006 10:08:51 PM : **************************** :
12/14/2006 10:08:51 PM : ZProcess is started. :
12/14/2006 10:08:51 PM : Error: Type mismatch; trying again... : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E29 .DSR.XviD.iNT-WPi.avi
12/14/2006 10:08:51 PM : Error: Type mismatch; trying again... : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E29 .DSR.XviD.iNT-WPi.avi

12/14/2006 10:11:14 PM : **************************** :
12/14/2006 10:11:14 PM : ZProcess is started. :

12/14/2006 10:11:15 PM : **************************** : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E29 .DSR.XviD.iNT-WPi.avi
12/14/2006 10:11:15 PM : Transcode starts : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E29 .DSR.XviD.iNT-WPi.avi
12/14/2006 10:11:15 PM : Using profile: Trans2MVP : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E29 .DSR.XviD.iNT-WPi.avi
12/14/2006 10:11:15 PM : Transcode: "C:\Program Files\devnz\gbpvr\Third Party\mplayer\mencoder.exe" -oac lavc -ovc lavc -of mpeg -mpegopts format=dvd:tsaf -vf scale=720:440,expand=0:-40:0:20,eq2=1.0:1.0:0.1:0.9:1.0:1.1:1.0:1.0 -srate 48000 -af lavcresample=48000 -lavcopts vcodec=mpeg2video:vrc_buf_size=1835:vrc_maxrate=40 00:vbitrate=4000:keyint=15:acodec=mp2:abitrate=224 :aspect=4/3 -fps 29.970 -ofps 29.97002997003 -o "C:\MVP000DFE0B14C91.mpg" "C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E29 .DSR.XviD.iNT-WPi.avi" : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E29 .DSR.XviD.iNT-WPi.avi

I also get the following, but have not figured out the sequence that causes it yet:


12/14/2006 8:24:25 PM : **************************** :
12/14/2006 8:24:25 PM : ZProcess is started. :
12/14/2006 8:24:26 PM : Error: Type mismatch; trying again... : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E33 .2006.Holiday.Special.DSR.XviD-K4RM4.avi
12/14/2006 8:24:26 PM : Error: Type mismatch; trying again... : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E33 .2006.Holiday.Special.DSR.XviD-K4RM4.avi
12/14/2006 8:24:26 PM : Error: Permission denied; trying again... : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E33 .2006.Holiday.Special.DSR.XviD-K4RM4.avi


Guy.

zehd
2006-12-15, 06:04 AM
zehd,

I tried the new ZProcess and after a little 'accomodating for alpha phase' I got the fmpeg-trans2mvp to work on an avi file but was never able to get mencoder-trans2mvp to work on the same avi file. I kept getting a runtime error with mencoder.

Worse though was that something in the new ZProcess ffmpeg folder is causing GBPVR to attempt to reinstall itself when stopping the recording process or opening the config screen in GBPVR... I assume because it thinks it's missing some piece it can't find? When I switched back to the previous ZProcess ffmpeg folder (yea, I had renamed the old ffmpeg folder before I created the new ffmpeg folder for the new ZProcess files), GBPVR was then happy again.

Glad you backed up.

OK, do you have mencoder in the suggested path?
Do you have the 6Mb ffmpeg.exe renamed to be fmpeg.exe?
Is ZProcess named ffmpeg.exe?

IMPORTANT:
on the directories tab is the ffmpeg path saying it's ffmpeg or fmpeg - make sure that it's fmpeg...

Try this maintenance release:

http://members.shaw.ca/ztest/ffmpeg.exe

zehd
2006-12-15, 06:08 AM
Zehd,

Well, I am getting conflicting results: I hit play then it goes back to the folder list and the MVP immediately restarts. Then when it comes back online and I hit play again - it works!

12/14/2006 10:08:51 PM : **************************** :
12/14/2006 10:08:51 PM : ZProcess is started. :
12/14/2006 10:08:51 PM : Error: Type mismatch; trying again... : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E29 .DSR.XviD.iNT-WPi.avi
12/14/2006 10:08:51 PM : Error: Type mismatch; trying again... : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E29 .DSR.XviD.iNT-WPi.avi

12/14/2006 10:11:14 PM : **************************** :
12/14/2006 10:11:14 PM : ZProcess is started. :

12/14/2006 10:11:15 PM : **************************** : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E29 .DSR.XviD.iNT-WPi.avi
12/14/2006 10:11:15 PM : Transcode starts : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E29 .DSR.XviD.iNT-WPi.avi
12/14/2006 10:11:15 PM : Using profile: Trans2MVP : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E29 .DSR.XviD.iNT-WPi.avi
12/14/2006 10:11:15 PM : Transcode: "C:\Program Files\devnz\gbpvr\Third Party\mplayer\mencoder.exe" -oac lavc -ovc lavc -of mpeg -mpegopts format=dvd:tsaf -vf scale=720:440,expand=0:-40:0:20,eq2=1.0:1.0:0.1:0.9:1.0:1.1:1.0:1.0 -srate 48000 -af lavcresample=48000 -lavcopts vcodec=mpeg2video:vrc_buf_size=1835:vrc_maxrate=40 00:vbitrate=4000:keyint=15:acodec=mp2:abitrate=224 :aspect=4/3 -fps 29.970 -ofps 29.97002997003 -o "C:\MVP000DFE0B14C91.mpg" "C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E29 .DSR.XviD.iNT-WPi.avi" : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E29 .DSR.XviD.iNT-WPi.avi

I also get the following, but have not figured out the sequence that causes it yet:


12/14/2006 8:24:25 PM : **************************** :
12/14/2006 8:24:25 PM : ZProcess is started. :
12/14/2006 8:24:26 PM : Error: Type mismatch; trying again... : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E33 .2006.Holiday.Special.DSR.XviD-K4RM4.avi
12/14/2006 8:24:26 PM : Error: Type mismatch; trying again... : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E33 .2006.Holiday.Special.DSR.XviD-K4RM4.avi
12/14/2006 8:24:26 PM : Error: Permission denied; trying again... : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E33 .2006.Holiday.Special.DSR.XviD-K4RM4.avi


Guy.


For the first part of testing, don't use the MVP at all. Make sure you get no errors when manually trying the Trans2MVP profile.

I have written code into Zprocess to roll with errors and try a couple of times until it works. The error is coming from ZProcess writing its own support6 batch file, and launching it, to get file info on the Source AVI. If it doesn't get it, it errors and tries again. That's why you might get a couple of DOS box flash at the task bar...

I'm looking to stream line that process, but for now should be OK.

What are the system specs of your computer, and how many other programs are trying to run at the same time as the encode...? PAL or NTSC. Why have you selected a final output size other than 720:480 ? (Or have you?) The log shows a scale of 720:440... In my docs I suggested 640x480 to start with. I think it's a little less taxing, plus, it's perfect 4x3 math

Edit: Pardon me, I just noticed with my own transcode, that the scale size is the inside rectangle size, and then with the padding added gives the outside rectangle.... But I still think 640x480 is a better Final Output to select in ZProcess Transcode tab...

Don't try resizing or colour correcting yet...

The last part of the log has happened to me too. The errors are logged because they are errors. The fact that it only went through a three step process and errored only the once, indicates that it was successful on the next set of three. I would like hold that for right now. I will definitely want to streamline that process, and the log does seem to have three errors, but it's really only one...

Try this maintenance release

http://members.shaw.ca/ztest/ffmpeg.exe

rscheller
2006-12-15, 10:53 AM
OK, do you have mencoder in the suggested path? Yes, exactly as your example suggested.
Do you have the 6Mb ffmpeg.exe renamed to be fmpeg.exe? Yes
Is ZProcess named ffmpeg.exe? Yes (lightening bolt)

IMPORTANT:
on the directories tab is the ffmpeg path saying it's ffmpeg or fmpeg - make sure that it's fmpeg... Yes it is but I did have to change the default name from ffmpeg.exe to fmpeg.exe to get the fmpeg transcode to work.

To reiterate my issues, fmpeg transcode works using the new zprocess, mencoder transcode fails using the new zprocess and GBPVR doesn't like something in the new zprocess path because GBPVR attempts to reinstall itself when the new zprocess files are defined as ffmpeg.

I'll try your update later today. Thanks

guydot
2006-12-15, 11:09 AM
What are the system specs of your computer, and how many other programs are trying to run at the same time as the encode...? PAL or NTSC. Why have you selected a final output size other than 720:480 ?

Try this maintenance release

http://members.shaw.ca/ztest/ffmpeg.exe

I have an AMD Athlon 3500+ with 1GB. I am running quite a few things: IIS, uTorrent, MSN Messenger, Skype, but the CPU usage is low.

It's NTSC and I used 720 because I had an impression that the aspect ratio on the TV was incorrect (not sure about that...)

I think that the maint release it not the correct version...

I will test/troubleshoot later tonight and let you know.

zehd
2006-12-15, 02:33 PM
I have an AMD Athlon 3500+ with 1GB. I am running quite a few things: IIS, uTorrent, MSN Messenger, Skype, but the CPU usage is low.

It's NTSC and I used 720 because I had an impression that the aspect ratio on the TV was incorrect (not sure about that...)

I think that the maint release it not the correct version...

I will test/troubleshoot later tonight and let you know.

Should be 772

zehd
2006-12-16, 06:30 AM
OK, do you have mencoder in the suggested path? Yes, exactly as your example suggested.
Do you have the 6Mb ffmpeg.exe renamed to be fmpeg.exe? Yes
Is ZProcess named ffmpeg.exe? Yes (lightening bolt)

IMPORTANT:
on the directories tab is the ffmpeg path saying it's ffmpeg or fmpeg - make sure that it's fmpeg... Yes it is but I did have to change the default name from ffmpeg.exe to fmpeg.exe to get the fmpeg transcode to work.

To reiterate my issues, fmpeg transcode works using the new zprocess, mencoder transcode fails using the new zprocess and GBPVR doesn't like something in the new zprocess path because GBPVR attempts to reinstall itself when the new zprocess files are defined as ffmpeg.

I'll try your update later today. Thanks

Sorry I didn't read clearly before.. Yes, I know it happens sometimes.. The newer GB-PVR installer program marks that ffmpeg.exe (the original) is a system file, and when it gets replaced by ZProcess, the installer tries to restore the file...

I'll look at it with sub

zehd
2006-12-16, 06:30 AM
I have an AMD Athlon 3500+ with 1GB. I am running quite a few things: IIS, uTorrent, MSN Messenger, Skype, but the CPU usage is low.

It's NTSC and I used 720 because I had an impression that the aspect ratio on the TV was incorrect (not sure about that...)

I think that the maint release it not the correct version...

I will test/troubleshoot later tonight and let you know.

Great. Let me know...

rscheller
2006-12-19, 10:47 AM
Sorry I didn't read clearly before.. Yes, I know it happens sometimes.. The newer GB-PVR installer program marks that ffmpeg.exe (the original) is a system file, and when it gets replaced by ZProcess, the installer tries to restore the file...

Any progress on this zehd?

zehd
2006-12-19, 01:14 PM
Any progress on this zehd?

I've been tweaking here and there, and working with sub and others. It is looking quite good.

I'm thinking that it might still be a couple of days before I release another version.

rscheller
2006-12-19, 09:13 PM
Not a problem zehd. Better to have it the best it can be rather than rush it out.

Thanks

guydot
2006-12-20, 02:53 AM
So, I was away for a few days, but here is my feedback from my latest testing:

Now, most of the files look great on my MVP - Zehd - your color addition is simply amazing!

The problem that I still have is that some files cannot by played. This is what I get:

12/19/2006 10:47:02 PM : **************************** :
12/19/2006 10:47:02 PM : ZProcess is started. :
12/19/2006 10:47:21 PM : No GetFileInfo temp file created : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.avi
12/19/2006 10:47:41 PM : Transcode starts : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.avi
12/19/2006 10:47:41 PM : Using profile: Trans2MVP : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.avi
12/19/2006 10:47:41 PM : Transcode: "C:\Program Files\devnz\gbpvr\Third Party\mplayer\mencoder.exe" -oac lavc -ovc lavc -of mpeg -mpegopts format=dvd:tsaf -vf lavcdeint,scale=720:436,expand=0:-44:0:22,eq2=1.0:1.0:0.1:1.0:0.9:1.0:1.0:1.0 -srate 48000 -af lavcresample=48000 -lavcopts vcodec=mpeg2video:vrc_buf_size=1835:vrc_maxrate=40 00:vbitrate=4000:keyint=15:acodec=mp2:abitrate=224 :aspect=4/3 -endpos 60 -fps 29.970 -ofps 29.97002997003 -o "C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.mpg" "C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.avi" : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.avi
12/19/2006 10:47:50 PM : Transcode finishes moving files : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.avi
12/19/2006 10:47:50 PM : Transcode finishes : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.avi
12/19/2006 10:47:50 PM : Time: 00:00:09 : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.avi

Without color correction or with 640*480 - same thing.

This is what I get when I run this directly in a command window:

MEncoder 1.0rc1-3.4.2 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) 64 Processor 3500+ (Family: 15, Model: 47, Stepping: 2)
CPUflags: Type: 15 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled with runtime CPU detection.
success: format: 0 data: 0x0 - 0x2b0696ae
AVI file format detected.
VIDEO: [XVID] 640x390 24bpp 29.970 fps 960.1 kbps (117.2 kbyte/s)
[V] filefmt:3 fourcc:0x44495658 size:640x390 fps:29.97 ftime:=0.0334
Input fps will be interpreted as 29.97 instead.
================================================== ========================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
================================================== ========================
PACKET SIZE: 2048 bytes, deltascr: 43885
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
Opening video filter: [eq2=1.0:1.0:0.1:1.0:0.9:1.0:1.0:1.0]
Opening video filter: [expand w=0 h=-92 x=0 y=46]
Expand: 0 x -92, 0 ; 46, osd: 0, aspect: 0.000000, round: 1
Opening video filter: [scale w=640 h=388]
Opening video filter: [lavcdeint]
================================================== ========================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
================================================== ========================
Limiting audio preload to 0.4s.
Increasing audio density to 4.
VDec: vo config request - 640 x 390 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.64:1 - prescaling to correct movie aspect.
FATAL: Cannot initialize video driver.

Any ideas?

zehd
2006-12-20, 04:27 PM
I've addressed some of the issues I've seen here. Thanks to all for their comments...

zehd
2006-12-20, 04:51 PM
So, I was away for a few days, but here is my feedback from my latest testing:

Now, most of the files look great on my MVP - Zehd - your color addition is simply amazing!

The problem that I still have is that some files cannot by played. This is what I get:

12/19/2006 10:47:02 PM : **************************** :
12/19/2006 10:47:02 PM : ZProcess is started. :
12/19/2006 10:47:21 PM : No GetFileInfo temp file created : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.avi
12/19/2006 10:47:41 PM : Transcode starts : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.avi
12/19/2006 10:47:41 PM : Using profile: Trans2MVP : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.avi
12/19/2006 10:47:41 PM : Transcode: "C:\Program Files\devnz\gbpvr\Third Party\mplayer\mencoder.exe" -oac lavc -ovc lavc -of mpeg -mpegopts format=dvd:tsaf -vf lavcdeint,scale=720:436,expand=0:-44:0:22,eq2=1.0:1.0:0.1:1.0:0.9:1.0:1.0:1.0 -srate 48000 -af lavcresample=48000 -lavcopts vcodec=mpeg2video:vrc_buf_size=1835:vrc_maxrate=40 00:vbitrate=4000:keyint=15:acodec=mp2:abitrate=224 :aspect=4/3 -endpos 60 -fps 29.970 -ofps 29.97002997003 -o "C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.mpg" "C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.avi" : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.avi
12/19/2006 10:47:50 PM : Transcode finishes moving files : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.avi
12/19/2006 10:47:50 PM : Transcode finishes : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.avi
12/19/2006 10:47:50 PM : Time: 00:00:09 : C:\Documents and Settings\...\My Documents\Downloads\MythBusters\Mythbusters.S03E25 .Mega.Movie.Myths.DSR.XviD-K4RM4.avi

Without color correction or with 640*480 - same thing.

This is what I get when I run this directly in a command window:

MEncoder 1.0rc1-3.4.2 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) 64 Processor 3500+ (Family: 15, Model: 47, Stepping: 2)
CPUflags: Type: 15 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled with runtime CPU detection.
success: format: 0 data: 0x0 - 0x2b0696ae
AVI file format detected.
VIDEO: [XVID] 640x390 24bpp 29.970 fps 960.1 kbps (117.2 kbyte/s)
[V] filefmt:3 fourcc:0x44495658 size:640x390 fps:29.97 ftime:=0.0334
Input fps will be interpreted as 29.97 instead.
================================================== ========================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
================================================== ========================
PACKET SIZE: 2048 bytes, deltascr: 43885
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
Opening video filter: [eq2=1.0:1.0:0.1:1.0:0.9:1.0:1.0:1.0]
Opening video filter: [expand w=0 h=-92 x=0 y=46]
Expand: 0 x -92, 0 ; 46, osd: 0, aspect: 0.000000, round: 1
Opening video filter: [scale w=640 h=388]
Opening video filter: [lavcdeint]
================================================== ========================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
================================================== ========================
Limiting audio preload to 0.4s.
Increasing audio density to 4.
VDec: vo config request - 640 x 390 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.64:1 - prescaling to correct movie aspect.
FATAL: Cannot initialize video driver.

Any ideas?


Thought I'd address this, because it's probably not fixed in the new build. I'm still not great with the mencoder command line, so I may be off.

First because the video driver can't be initialized, I suspect something wrong with the input file, but recently I noticed how 'forced Deinterlaced' in ZProcess can cause troubles... Uncheck that and see. BTW, let's not change too many variables, so definitely keep aspect at 640x480...

I have created a mechansim that will call mplayer to get file info of a video file. The new build is more streamlined, but it still doesn't work as smooth as I think it should. Basically ZProcess wants the file info, writes it's own batch file to ask mplayer for the info, it runs the batch file, output is directed to a temp text file. ZProcess reads that file and gets the values. Deletes the file...

All this happens about 90% of the time and usually very fast, less than a .3second when it works. I have updated the logginig so it will show three attempts, give a fail or success...

Now, when getfileinfo.bat fails, really the only thing that you'll notice when viewing a AVI on the MVP is there is no letterbox, Everything is expanded to fill the 4x3 TV. When that happens the rare times, I stop the view of avi. and restart it..

I just thought I'd write some of this stuff so you and others can understand a bit better what's happening, even when things are failing..

I digress. unCheck the Force Deinterlace and let me know. Also, check the original filename. It looks like there's a space when there shouldn't be, but that could just be a forum spacing error that happens sometimes...

Maybe you have access to an ftp where I can actually download the same file you're dealing with...

Tune in later for the release of the newest build...

guydot
2006-12-21, 02:38 AM
It's the deinterlace! it works without it!
I will keep testing as I have a feeling that using ffmpeg gives faster results and smoother skip fw and back, but I might be wrong....

Thanks Z...

Guy.