View Full Version : xmltv feed denmark

2004-03-23, 05:55 PM

cant get xmltv feed to work
the guide shows the channels fine but, there are no programmes in the list.

2004-03-23, 06:14 PM
Can you email me a sample file? Send it to support@devnz.com

2004-03-24, 10:00 AM
I got the same problem (also from Denmark).
The problem is the time zone +01:00 , If you remove that from all the programs before importing into GBpvr then you will got program information too.

(You can open the XMLfile with notepad and use ctrl+H to replace +01:00 with an empty field)

2004-03-24, 12:53 PM
Thank's Jan

This workaround fixed the program guide, but it would be nice not having to manuel edit the xml file

the problem is located at this point

this dont work
<programme start="20040324161000 +0100" stop="20040324161500 +0100"

this work
<programme start="20040324161000" stop="20040324161500"

any idear to create the xml file without "+0100"

/otto http://gbpvr.com/iB_html/non-cgi/emoticons/biggrin.gif

2004-03-24, 01:26 PM
Hi Bjerk

I don't think you can make the XMLfile without +01:00 but If you can program, you can make a vb.script or .net program.
Then you can make it all in at time schedulet bat file.
I the bat file you first makes the XML file, and then calls your own programmed converting program, and last you can make an automatic update in GBpvr with the comand line parameters.

2004-03-24, 03:45 PM
If you add timezone info like GMT it will work too. Maybe that's an option? (So GMT+01:00)


2004-03-24, 08:27 PM
Use the o2grabber, has some support for Denmark. In the grabber you can choose witch timezone you want + it has nice icons and you can download 14 days in a row in one singel file: http://www.o2design.se/o2grabber/

Cheers /Jonas from Sweden

2004-03-24, 10:33 PM

MaBo you are right, but the real problem is in my xml file

syn syntax is "+0100" and it shout be "+01:00" the : are missing.

in o2grabber witc Jonas was takling about, the same problem exists.

for now i have created a vbs script witch prasers the xmltv file and, that works for me,

/Otto, denmark http://gbpvr.com/iB_html/non-cgi/emoticons/biggrin.gif

2004-03-24, 10:34 PM
I've made this batch file to download XMLTV file and "clean" the '+0100' :

<table border="0" align="center" width="95%" cellpadding="0" cellspacing="0"><tr><td>Code Sample </td></tr><tr><td id="CODE">
del C&#58;&#92;XMLTV&#92;xmltv.xml

C&#58;&#92;XMLTV&#92;xmltv.exe tv_grab_fr --config-file C&#58;&#92;XMLTV&#92;tv_grab_fr.conf --output C&#58;&#92;XMLTV&#92;xmltv_temp.xml

C&#58;&#92;XMLTV&#92;xmltv.exe tv_remove_some_overlapping --output C&#58;&#92;XMLTV&#92;xmltv_temp2.xml C&#58;&#92;XMLTV&#92;xmltv_temp.xml

del c&#58;&#92;XMLTV&#92;xmltv_temp.xml

C&#58;&#92;XMLTV&#92;sed.exe &#34;s/ +0100//g&#34; C&#58;&#92;XMLTV&#92;xmltv_temp2.xml &#62; C&#58;&#92;XMLTV&#92;xmltv.xml

del c&#58;&#92;XMLTV&#92;xmltv_temp2.xml [/QUOTE]

You need XMLTV grabber from www.xmltv.org and sed.exe from http://www.cornerstonemag.com/sed/ (for example).