PDA

View Full Version : -OnlyUpdateEPG FATAL Error



teris
2004-03-05, 11:36 PM
Hi,

I've createt an XMLTV-file with nextview epg.
I connected GBPVR to this file and get all the Channels with names in the list.
But the programs are not in the EPG. In this forum I found the tip "remove ' +0100'.
The epg is still empty.
Now I tried to use the command 'GBPVR.EXE -OnlyUpdateEPG' and got the following error:
Title: Common Language Runtime Debugging Services
Message: Die Anwendung hat einen schweren Ausnahmefehler verursacht, der nicht verarbeitet werden konnte.
Prozess-ID=0xd330 (3376), Thread-ID=0x4c (2892)
Klicken Sie auf OK...

The logfile you can see at www.yaggi.de/GBPVR.exe.log .
The compressed XML stays at www.yaggi.de/xmltv.rar .

Please help. I bought an extra WinTV PCI card to get EPG-Data.

Bye,
Sebastian

sub
2004-03-06, 12:24 AM
All of your programs have start and end dates with +0000 appended to the end of them. Try removing these and it should work.

It should cope with these +0000,+0100 (etc) timezones, but for some people it isnt. These files load fine for me, so I guess its something to do with the current machine locale settings. I've added some additional logging to the next release which will hopefully help me track what it is that the system doesnt like about these timezones.

MaBo
2004-03-06, 11:53 AM
Could it be that the timezone information has to be in the format hh:mm instead of hhmm? In teletext2xmltv that is what I use and it works fine. I also include GMT or a comparable indicator. So: GMT+01:00

Greetings,
MaBo

teris
2004-03-06, 05:24 PM
Hi,

that's it!
Now the epg works fine.
But when I manualy start the epgupdate I got the same fatal error.

I hope, the new version comes in the next days.

BB,
Sebastian

PS:
Is there any interface to translate the software in other languages ?

box177
2004-03-12, 05:24 PM
Quote[/b] (sub @ Mar. 06 2004,01:24)]It should cope with these +0000,+0100 (etc) timezones, but for some people it isnt. These files load fine for me, so I guess its something to do with the current machine locale settings.
Hi Sub,

I've got the same problem, EPG is not updated if I don't remove all " +0100".

May be the trick is about the time format (I'm french, so I use 24H format. You're anglo-saxon, you use 12H format).

sub
2004-03-12, 06:22 PM
No, I also use 24H format in my XMLTV files. It uses a function to get the currently locale settings from the machine, which I think must be failing. I should be able to work it out in the next release.