PDA

View Full Version : Poor Quality Recording



Keeper
2006-01-10, 08:10 PM
I have been using gbpvr for about a year now but i still cannot get some tv shows to record with good enough quality. I am not sure if it is setup, hardware or drivers, i am hoping someone can point me in the right direction. Most programs that don't include any quick movements are fine but but sports especially hockey games record in such poor quality that it is unwatchable. (Yes i am Canadian)

I am using a Asus p5p800 board, P4 3.0Ghz, 2 GB of Ram, ATI 9600 SE 256meg (latest ATI drivers) and two Hauppauge Wintv Pvr 150 capture cards. I have tried the DirectX fix that was posted on this forum with little to no changes in quality.

I am thinking that the Hauppauge Wintv Pvr 150 card is not good enough to capture the quick movements of a hockey game.

Any help would be greatly appreciated.

chud
2006-01-10, 08:50 PM
is it a stuttering that you see (say every second or so) or more like a "ghosting" everytime there is movement or panning? if it is the second, it sounds like you are not deinterlacing.

what decoders are you using?

Keeper
2006-01-10, 09:18 PM
I would saying its more ghosting basically its out of focus and takes a second or two for it to catch up. I am not sure how to check if i am deinterlacing or not.

As for decoders if i go to the Playback tab of the gbpvr config:

Hardware decoders device: None - use software decorder
(Options avail: Hauppauge pvr350, Sigma Designs Xcard)

Software MPEG-2 Playback:
Video Decoder: System default (options: Intervideo NonCSS Video Decoder, Nero Video Decoder)

Audio Decoder: System default (options: MPEG Audio Decoder, Intervideo NonCSS Audio Decoder)

Audio Renderer: System default (options: M-Audio Revolution, Default Directsound Device, Default Waveout Device, Directsound M-Audio Revolution )

VM9
Minimal OSD During Playback
Force minimal OSD for MVP

chud
2006-01-10, 09:33 PM
it has been awhile since i have seen the intervideo video decoder control panel (in fact, if memory serves, there isn't one!).

are you outputting to a monitor or a TV? if a TV, is it old skool composite/svideo or vga/dvi/hdmi?

here is a good read on deinterlacing, and possibly some example files:
http://www.100fps.com/

if you still think it is deinterlacing i would try download the Dscaler5 mpeg2 decoders:
http://www.dscaler.org/phpBB/viewtopic.php?t=5205&sid=4e0d4dfdd6a023d214f445eb22e39753

and specify that GBPVR uses them. in the ATI CCC there are video settings and in one section you can specify deinterlacing. if you set the dscaler video decoder to automatic deinterlacing and set the colour output to YUY2 (i believe), set the ATI deinterlacing to adaptive, stand on one leg and hold your finger to your nose, you can get the graphics card to do the deinterlacing in hardware.

i think you will also need to change the deinterlacing setting located in the last tab of the GBPVR configuration tool to "encoder passthrough".

Keeper
2006-01-10, 09:45 PM
I could not find a control panel for the intervideo, i think it came with my dvd writer.

I am outputting via S video to my sony TV but the video is also poor via on the computer monitor as well.

I will read the article you mentioned and try the mpeg2 decoder as well.

I will look again in the ATI ccc to find deinterlacing settings.

I want to say thank you for helping me out on this. There is a hockey game in about an hour and 1/2 from now so i will try out your suggestions. I will let you know how it goes.

chud
2006-01-10, 10:10 PM
no problem. us canucks got to stick together, eh.

since you are outputting to a tv, i am not sure that you even want/need to deinterlace the video. someone with more knowledge and/or a similar setup maybe be able to help you out more, but if it also looks bad on your monitor then something is up.

Keeper
2006-01-10, 11:39 PM
I actually wasn't using the ATI ccc i used the control panel drivers instead and i could not find the interlace options. I uninstalled them and installed catalyst and found the interlace options but for some reason i cannot get the second display to work. It was easy in the control panel drivers but not in catalyst.

gEd
2006-01-11, 10:48 AM
IIFC, you should only deinterlace if you are viewing on a computer, projector, LCD or plasma. A CRT TV uses interlacing.

I also see ghosting on the few occasions that I watch football (soccer!) games.

Perhaps try turning up the min and max bitrates for the live tv setting and see if that helps.

Your ATI card is not ideal - too much (slow) graphics memory and (possibly) not enough horsepower.

Can the pvr-150 capture sport without blurring - don;t know. There is bound to be someone on this board who records sport with this card so maybe they can advise on whether you can achieve HQ, fast moving action.

Funny thing is, cricket looks ok............:-)

Keeper
2006-01-11, 06:35 PM
I installed the dscaler and configured gbpvr to use as well as installing the latest ATI ccc. I was using an older version and the control panel version of it.

I recorded a hockey game last night and the changes did help. I only problem i have now is on the TV screen and not on the computer monitor. Not sure how to explain it but the TV screen sometimes has a correction line half way up the screen which is really noticeable when they skate past center ice.

It doesn' happen all the time but always occurs in the middle of the screen. Its like the TV takes one picture of the play and cuts it in half and doesn't like it up properly offsetting the top half from the bottom half a 1/2 inch of so.
Other then that the rest of the picture is in focus and is fine.

Any suggestions?

gEd
2006-01-11, 08:29 PM
This might be a de-interlacing problem. The picture to your TV should be interlaced but that to your monitor shouldn;t, which possibly leaves you with a dilemma if you want to use both screens to view TV.

If the image improved on the monitor, this may be because you have now enabled de-interlacing. Try (temporarily) disabling dscaler and see if:-

It fixes the "correction line" problem on the TV
Affects image quality for better or worse
Whether the ATI driver update alone has improved the picture.

Keeper
2006-01-12, 01:40 AM
How do i temporarily disabling dscaler for playback?

I did try changing the deinterlacing to different settings and Bob was the best on the TV. There were some fluttering or displacement at the bottom of the screen. Can someone tell me why Bob makes a difference?

So from everyones help it looks like the capture card is not the issue rather it is the playback (mpeg playback and video card) that is the issue. I thought i had a good video card but maybe i don't.

Is there any other drivers like dscaler that i can try?

I may try the omega video drivers as well.

thanx again for all your help

jam_zhou
2006-01-12, 02:17 AM
I've got a 9600xt AIW with one pvr150. I recorded the world juniour hockey champsionships and it recorded just fine and I output to my 15 year old Trinitron.

How high do you have your output resolution? I used to have what I thought was tearing in that whenever there was a quick side to side motion the picture would be as if I was watching TV through blinds. It was always in the centre of the screen but then that's where most of the action is usually so my symptoms seem to be the same as yours. I solved this by reducing my TV out resolution from 1024x768 to 800x600 and should probably be brought down to 750x352 to match the resolution of the video.

What you might want to check out is if the recording still looks bad when you play it using winDVD or zoom player.

I use the cyberlink decoders but this happened with other decoders including dscaler.

Good luck.

gEd
2006-01-12, 01:37 PM
How do i temporarily disabling dscaler for playback?

er, didn't you enable it in the gbpvr config?


I did try changing the deinterlacing to different settings and Bob was the best on the TV. There were some fluttering or displacement at the bottom of the screen.

quote from dscaler site:
DScaler 4 is a piece of software that captures video, processes it, and scales it for presentation on a projector or computer monitor.


So from everyones help it looks like the capture card is not the issue rather it is the playback (mpeg playback and video card) that is the issue. I thought i had a good video card but maybe i don't.

It could be a factor but please try the other suggestions out first before changing the card and spending $$$.


Is there any other drivers like dscaler that i can try?

Just to clarify dscaler is a de-interlacing program, not a driver.


I may try the omega video drivers as well.

I use these for my 9600 pro and the work fine, although I haven't compared them to the the standard ATI drivers to compare differences. I think the supposed image quality improvements would only be seen in games.

Try setting your resolution to 720 x 480 (NTSC) using powerstip. (Perhaps other NTSC users could comment on the merit of doing this).

chud
2006-01-12, 04:05 PM
i would agree that if you are outputting to the tv, you probably want to be running something like 800x600 (or closer to NTSC res using powerstrip or a custom res in CCC).

i think when Keeper is talking about Dscaler, he is talking abou the vid codec (Dscaler5), not the deinterlacer (Dscaler4).

i would think that the S-video out on the video card is interlaced regardless to conform to the NTSC standards. deinterlacing the video would not change this, but possibly some artifacts are being introduced in the conversion (back) to interlaced.

basically in deinterlacing, none (or weave) is best for no motion. the picture will be sharp and stable. with motion you will see the comb or "blinds" effect. bob is good for motion. it tries to deconstruct the 30fps interlaced video (NTSC) into 60fps (and in the process needs to 2x scale the vertical resolution of the half res frames) so each image shown in succession is a full picture rather than an every-second-line one. this leads to a loss of sharpness and "flickering" observed in regions of no motion.

the best deinterlacing methods try to combine the two where algorithms try to apply specific methods on specific parts of the image. these are the "adaptive" options in the ATI CCC.

gEd
2006-01-12, 07:17 PM
good info chud and thanks for pointing out that I was getting my dscalers mixed up!

strategus
2006-01-15, 09:30 PM
I'd like to add something to this...

I'm also a sports/hockey fan (and also Canadian), so I use GBPVR for catching lots of fast-action programs.

Following this thread, I downloaded and installed the DScaler5 codecs. It made a pretty huge difference in "smoothing" out the video. But it introduced a couple of mildly unpleasant issues:

1. DScaler seems to do some weird "ghosting" when the action gets hot. You can especially notice this in a hockey game when the camera pans past the red or blue lines. You can clearly see a thin strip of the line on the ice AHEAD of the panning (ie. if the camera is quickly panning left-->right, the blue line on the ice will have a thin ghost just right of the line itself). You can notice it on the players often, too.

2. DScaler also seems to get befuddled when I use the "skip ahead" function in GBPVR. About 1/2 the time, when I resume, the video will get unbearably jittery -- and stay that way. Usually if I pause/unpause it a couple of times, it will fix itself, though. It doesn't seem to be a performance issue -- it just can't seem to get into synch or something.

I've tried the quartz.dll "fix," but it didnt' seem to help at all.

Any ideas?

Thanks,
S.

strategus
2006-01-15, 09:51 PM
Haven't heard of MainConcept until now. But I'd like to give it a try.

I checked out their website. The latest version seems to be 1.5.1 -- is 1.42 better than that one?

Thanks,
S.

strategus
2006-01-16, 12:05 AM
So, I gave MainConcept's 1.5.1 a try.

I have to say that for smoothness, DScaler5 still has it beat by quite a wide margin.

Not to say that MainConcept isn't superior in other ways, but for watching a sporting event with lots of side-to-side panning, it's still quite jerky and stuttered.

S.

chud
2006-01-16, 04:59 AM
1. DScaler seems to do some weird "ghosting" when the action gets hot. You can especially notice this in a hockey game when the camera pans past the red or blue lines. You can clearly see a thin strip of the line on the ice AHEAD of the panning (ie. if the camera is quickly panning left-->right, the blue line on the ice will have a thin ghost just right of the line itself). You can notice it on the players often, too.

2. DScaler also seems to get befuddled when I use the "skip ahead" function in GBPVR. About 1/2 the time, when I resume, the video will get unbearably jittery -- and stay that way. Usually if I pause/unpause it a couple of times, it will fix itself, though. It doesn't seem to be a performance issue -- it just can't seem to get into synch or something.



i am not quite sure i have seen your point #1, but i have come across point #2. i believe it is some sort of failure to properly deinterlace. i am not sure what causes it or how to make it go away. i have had this issue twice and after fiddling with decoders, video card drivers and settings, etc, eventually it was gone. out of curiosity, are you using an ATI video card?

strategus
2006-01-17, 05:24 PM
Yes, I'm using an ATI card -- x300, with AVIVO. Drivers are up-to-date.

But I'm outputting the signal through SVideo to a TV. So, I don't imagine interlacing is the problem (all NTSC TV images are interlaced, if I'm not mistaken).

I've scanned DScaler5 forums, but haven't found anything that seems to resolve this issue.

S.

chud
2006-01-17, 06:02 PM
i would imagine this could still be a deinterlacing issue. it is safe to say that the signal to your TV is always interlaced by the video card+drivers, but what happens to the signal before that could be anything (deinterlaced, scaled, sharpened, levels, then re-interlaced by the video card). any artifacts in the deinterlacing by the decoder will corrupt the video stream and will be seen in the final (re-interlaced) picture.

if you disable deinterlacing (weave) in the ATI CCC this may remove this problem of jittery video, but the picture may still not look good according the experiences of some of the other people in this thread. i don't know why that is, but i would imagine that the interlacer in the video card may not recognize that the video signal is already interlaced and is interlacing an interlaced video (see how i interlaced various forms of "interlace" there...). you can imagine if you are watching tv in a window on your desktop. i would think it would be tough for the software to recognize that part of the screen is already interlaced and somehow sync the progressive portion of the screen (the rest of your desktop) with this interlaced signal when interlacing the whole picture...